Setting up MIDI OUT with Analog RYTM MK2?

Hi all,

I am quite new to the ANALOG RYTM and was recently considering buying an external sequencer to control it and my Virus TI2. Well, as you all know, Elektron have gone and saved me a bit of bob! I hope.

My problem is I cant, despite reading through the manual and youtube tutorial after tutorial, set up MIDI OUT sequencing with my Virus TI2. I have a feeling I have selected or deselected something somewhere.

Can anyone advise on what settings are correct for MIDI OUT sequencing? I have watched Bobeats video on the upgrade but his settings won’t allow me to sequence the Virus TI2 from the ANALOG RYTM. I’d appreciate any advice even just to allow me to begin from a confident starting point when setting up the MIDI OUT for external gear.

Why not take the initiative and list all of your relevant settings/changes here and somebody can show you what you have set wrong or missed.

Every pitfall has been covered here Analog Four/Keys 1.40 & Analog Rytm 1.50

and existing issues/bugs with MIDI are covered in lots of detail here Analog Rytm OS 1.50: bug reports

Explain what you have tried and how you are testing it

Have you enabled the new Track MIDI out e.g. ?! etc etc what are the MIDI settings, what’s in the Port Config Menu … Do the bugs listed explain your issues and so on
What is not working ? Details

1 Like

@Garyjumanji yo I decided to get this working myself…I am testing this out rytm mkii->Prophet Rev2. Just got it working! And although there could be a trillion things wrong have you:

hit FUNC+TRIG (Quantize) and selected “TRK (whatever track number) SEND MIDI”?

Sam

1 Like

I’ve been through this several times and it appears my Rytm MkII does not send midi notes out from the sequencer trigs. The pads work, they trigger my external synths and they work in chromatic mode, but the trigs don’t send anything out to my external equipment. I have switched synths and channels numerous times.

OK @EightySix but

2 Likes

The solution to your problem is probably enabling MIDI Out (per track) exactly as described above or search SEND MIDI in the manual

The problem you will face in the short term and it could also explain the silence when sequencing is that there is a bug whereby the pads’ MIDI range when playing is offset from the MIDI range when sequencing, it’s a clear bug Analog Rytm OS 1.50: bug reports

This would not be an issue for you if you were sequencing a piano with full range, you’d hear it (but offset), but if you were sequencing a drum rack that only covered a couple of octaves you could miss it entirely - so having enabled the SEND feature you could still face a problem - this is when using a MIDI monitor can be useful

2 Likes

Thank you and I appreciate the suggestions, now as @avantronica sugested, here are the settings I have enabled.

  1. FUNC+FX > MIDI CONFIG > SYNC =
    Clock send (enabled),
    Transport send (enabled)
    Program CH send (enabled).

  2. FUNC+FX > MIDI CONFIG > PORT CONFIG =
    Turbo speed (OFF).
    Out Port Func (MIDI).
    Thru Port Func (MIDI)
    Input From (MIDI + USB)
    Output to (MIDI +USB)
    Param Output (NRPN)
    Encoder Dest (INT + EXIT)
    Pad Dest (INT + EXIT)
    Pressure DST (INT + EXIT)
    MUTE DEST (INT + EXIT)
    RECIEVE NOTES (OFF)
    RECEIVE CC/NRPN (OFF)

The TRK SEND MIDI Feature has been enabled the whole time. After going through the bug thread, I don’t believe any bugs should stop me sequencing the VIRUS via the Elektron RYTM.

2 Likes

Let’s keep it simple - is Overbridge off ? Are all the tracks MIDI enabled ? Are your tracks muted ? Can you use a different synth or a MIDI monitor to see if midi activity related to trigs is coming out ?

Do you get MIDI activity when the pads are played (this was the case before this update)

Try a different MIDI cable - ensure the cable is plugged into the Out port

You have not listed Port Config / Output Channel (which relates to playing pads)… What have you assigned, Auto(def) or Track(ideal) ?

You’ve not detailed the track channels nor how you expect those to relate to an external chromatic instrument - keep it simple, use a single track to play/seq a chromatic instrument

Refer to the offset bug disclosed above as well

Also refer to the bug reported that you will have to play the sequencer blind (if controlling externally via auto channel) as MIDI is not transmitting through - so stick to pads for now

A midi monitor is a good plan - or a synth that works in Omni RX mode

2 Likes

Overbridge is off. All tracks 1-12 set to SEND MIDI. Tracks not muted.

MIDI Monitor inputport on PC is reading each change to the trigs, filter, amp etc. as far as I can see MIDI messages are being sent with each push of a button, turn of a knob etc.

Port Config output channel is set to Track ch.

Track channels? If I understand correctly, at this moment in time I’m simply seeking to sequence a bassline from Virus with the RYTM.

OMNI RX? The virus has a MIDI DEVICE ID > Omni mode?

Omni in your context there may relate to an editor finding your specific virus if two were connected. I meant a MIDI Omni mode where messages on any incoming channel are played

So do you get midi activity on a monitor when a sequence is playing. If so then the issue is your MIDI connections or settings on the Virus. It is not an AR issue (bugs notwithstanding)

The MIDI Monitor is corresponding to each track being played in the sequence, so, by your understanding that would mean the barriers to sequencing the Virus with the Analog Rytm lie within the Virus’ settings?

Truely, thank you for putting me in the right direction.

Also, does overbridge have to be switched off in order to communicate with the virus ti2?

I was hoping I could use overbridge to split the 8 tracks into DAW mixer and then record.

I wouldn’t complicate your picture by worrying about a beta program whilst you are still getting the basics right - get the easy part fixed and see what you can do thereafter, I have no interest in the exponentially more problematic routing issues that adding OB into the picture brings

It may be helpful to report to the thread what eventually resolves your MIDI sequencing issue

For what it’s worth, I have been recording/splitting 8 tracks into DAW mixer for a while, that part is easy!

I certainly will. I have contacted Virus support and hopefully they’ll be able to provide useful information on part of the Virus.

1 Like

Ok, so no message yet received from Access. So I’ve been sitting here, playing around with the electribe and, well, the RYTM is sending a signal to the electribe but the internal sound from the analog RYTM continues to play. No sound from electribe…am I missing something basic here?

I got a response out of the Virus earlier too in the form of a musical note on the LED screen but now I can see it clearly with the electribe. Anyway, at the risk of making myself look like a real dunce, I thought I’ll let you all know.

Just use a DAW to see what MIDI notes the RYTM is sending out…maybe you need to transpose them to be in range of your other hardware

Thank you for your replies, I had not enabled track midi out. It works now, thank you!

2 Likes

Another quick question while I’m here: Does anyone know why they’ve made it so that you don’t have to press the track button before touching a pad to switch tracks? It’s weird to get used to it like this.

It’s an option you can toggle off under Sequencer Config

2 Likes

Hello, I’ve gone through the manual backwards and forwards and am at a loss as to how to get my AR MkII (with the 1.50 update) to send the sequence trigger data out through either the midi or usb to another drum machine (rd-8). I can trigger the rd-8 no problem from the AR MkII when i physically touch the pads but when i play the sequencer all triggers are going to midi 61 and not their respective notes. I’m going a bit insane. All i want to do is trigger note. No other cc data or anything.