AR Bugs thread

That was the problem. Thank you!


Just an update on my “problem”. It was 100% user error. I had an LFO assigned to that sample slot. Thx Elektron support!


Hoho, something new for me
Just switched device on, project didn’t load, after reboot is ok…

On AR MKI OS 1.31B here and my parameter slides are sliding to conditional trigs upon first pattern cycle without their conditions being met. If I have a 2:2 trig after a slide trig it slides to that on the first pass…

Anyone else run into this? Fixed on latest OS???

RYTM Mk2 OS 1.45:

Attempted to “Save Project” twice in a session today, only to have everything I had just done revert back to where it was upon LAST save. First time I have had this issue.

Hi community.

Let’s start a collection of known bugs of the Rytm MK2 to our and hopefully Elektron’s benefit:

  • if they want less customer/user disappointment (hence more loyalty)

  • a finished product with functions working as promised finally after years in some cases

- since satisfied customers and a good product is actually the best marketing.

It makes the following easier for us at least:

  1. If you want to buy the device, you can check quickly and with more oversight, if the functions you need are actually working as described and you expect

  2. If you just bought the MK2, you can check quicker if what you experience is a known bug or a unique problem of your device and decide quicker what to do (swap it, contact support, accept it “as is” or just give it back for good)

  3. If you experience bugs or missing features, you can report them more structured also here (and to customer support) to be able to make more pressure collectively to get things done


This thread will surely develop, so this is a starting attempt to get some structure into it. I will collect bugs on top here, which are acknowledged by Elektron’s support and are not being stated as normal or user error.

  1. If you experience or know about a bug you don’t see here yet, please make an independent thread first as usual and report it to customer support of course. The best is to make a short video of the misbehavior for them.

Only if it really turns out to be a bug, please report it here.

  1. If you experience a bug or a missing feature already listed here, please state it as a “vote for fix”. Also make sure to open a ticket at Elektron’s page for support, if you did not yet.

  2. I will start this list to the best of my knowledge. Please feel free to correct me or to add anything you know. Thank you!

KNOWN BUGS list for the Rytm MK2:

>> Freezes - different reasons possible
All firmware versions (to this date, 1.46 Beta1)

>> Laggings - scrolling and hit lags or misses while in sample browsing mode
All firmware versions (to this date, 1.46 Beta1)

>> Sample names bug - SMP slots showing the same name for diff. samples in diff. slots
1.45B & 1.46 Beta1

>> Pattern trigger and SYN trigger bug - Not triggering SYN (only?) if programmed
1.45B & 1.46 Beta1

>> CHANG bug - Pattern not changing as programmed
All firmware versions (to this date, 1.46 Beta1)

>> LFO to Accent bug - LFO does not change Accent level as described
All firmware versions (to this date, 1.46 Beta1)

>> SONG-mode LED-bug - Not indicating Song Mode off while in “Edit Song” menu
1.45B & 1.46 Beta1

TBC of course!

A post was merged into an existing topic: Stirring

As soon as you mute just one track in any pattern while in “Song Edit” mode, the “Song mode”-LED stops indicating song mode being off.

How to test:

  • Make a cleared new song with any pattern
  • go to “Song Mode” (FUNC > EDIT SONG)
  • press MUTE for track muting in Song Mode (yellow pads)
  • check all pads are on, none muted (should be by default if cleared song)

Now you can toggle Song Mode by pressing the button. the LED changes blue/magenta

Leave it on blue (= Song Mode off)

  • mute any track

You will see the Song Mode LED turning Magenta (Song Mode on), though Song Mode is still actually off if you left it off.
You can check that by pressing “NO” and exiting Song Mode.

If you unmute all tracks again, the LED indicates right again.

Submitted, acknowledged by support - just posting to make it public.

If I load any samples to other slots than the active track’s sample slot (going to the sample menu through 2x hit on SMPL, then FUNC + YES) they are all called the same as the sample I load onto the one active sample slot, until I restart the unit.

I can’t reproduce it to make a video, but I could film the proof and submit that at least to Elektron.

This happens in all projects from time to time, yes. I could not yet reproduce it reliably enough to catch it on video about how this exactly comes to be.

But in this video you can see, that I loaded your factory samples

“Brass Major Chord” to slot 16

“Dist Minor Chord” ro slot 17

But if viewed through the sample selector it is showing me

16: Dist Minor

17: Dist Minor

Which is wrong and gets fixed if I restart the device.

I can only tell you that it happens, when I browse through the samples (accessing them through 2x SMPL then FUNC + YES), load a sample to the selected slot, then load other samples through “LOAD TO PROJ” then replace the sample in the selected slot again. Some combination of these steps lead to this name bug.


I’m still not able to reproduce this, but if you find a way to do it consistently we’re very interested.

If you experience this and you can reproduce it, please submit a video to Elektron, how this comes to be and also state it here, if you like.

They should employ you as beta tester…

Yeah, time to step up :stuck_out_tongue:

Ran across what I think is a bug tonight.

Track 4 - on Trig page I shut off the synthesis trig (leaving only sample on) but the Syn trig continues to play. No plocks on the trigs. In fact even plocking Syn Trig off doesn’t work.

However if I turn off Syn Trig on track 3 then track 4 Syn turns off (!). Also if I solo track 4 in mute mode (via rtrg&pad) Syn shuts off.

Is this a known issue? Tested same behavior on tracks 7&8 and those work correctly.

Ok even weirder: if I plock Syn off on Track 3 track 4 Syn turns off wtf. But if I plock it on on the same trig step track 4’s Syn trigs!

Please share your OS version - this needs to move to an existing thread

There are aspects of the relationship between voice Track pairs that i find odd

I’ll compare with the latest beta if you provide the bare minimum steps (fewest trigs) to replicate from an empty pattern and clear kit - also advise which machines you have loaded

OS is 1.45b. I’m headed to work so it will be awhile before I can test again. But I was also experiencing incorrect muting behavior on tracks 11&12 (to do with the overdrive maybe). I’ll have more info later. Thanks.

1 Like

Ok track 3 is Rimshot Hard and track 4 is Snare FM. Changed 3 to RS Classic. Still happening. Changed track 4 to a couple of different machines still happening.

So started a new pattern (same kit) and it’s not happening. So what setting s could have been on my original pattern to have caused this?

That’s what i was wondering - I suspect trigless locks (any locks) are a part of this

trigless locks under certain circumstances wrt the shared ‘lesser’ track get the shared ‘greater’ track to sound when you might not have expected it - i recall reporting as such years ago - i’m not recalling 100% the circumstances here without access, but examine the suspect tracks for locks

i’d generally be live programming and tweaking so it generates a lot of trigless locks, when these locks appear on say T4 and a trig was on T3 i think that may be a scenario to promote T4 voice to a trig - this may not relate, but as i said i believe there are at times counterintuitive outcomes depending on the exact entries on the pair of track seqs

1 Like

Yes, track 3 here was definitely a live programmed tracked w/o fixed velocity. I definitely could shut off the greater track syn but plocking the lesser track’s syn off so I think you’re onto something. Thanks for the feedback!

1 Like

Hi there, I experienced the same bug (or similar) and reported it to support as:

… There seems to be another bug I noticed:

If I set the trigger-lock “syn” off for certain or all steps in a pattern it won’t work. If I don’t lock the parameters but set it globally under TRIG, it does not mute the triggering of the sound engine either.

I f I play the note while SYN set to off globally, it does not trigger, as expected. To make it more weird, if I record the notes like this, it records and plays back right. I can even switch SYN on/off globally, if not locked. But if I “set” a note manually, it does not work.

So to sum it up, this error of not being able to set the triggering of SYN to off for notes only occurs for manually set notes. Liver recorded ones behave normal.

If I try the same with the SMP trigger, it does work as expected without bugs.

I updated to 1.46 BETA, bug is still there. Was there in 1.45B as well. …


Does this issue occur specifically on tracks that have shared voices and does it involve one track choking the other? The possibly affected tracks would be Track 3, 4, 7, 8, 9, 10, 11 & 12.


yes, #10, but 9 is not playing at all. And as I said, the other way (SMP off) is working on the same pattern/sound/kit.


The issue you describe is known to our developers, though not in as much detail. Could you make a short video showing the issue? It would be very helpful. You can upload it as an unlisted video on youtube, send it via a dropbox link in this thread or attach it to your reply. The chances this will be fixed soon are way better if they can see the different behaviors you describe.


I tried to recreate the trigger bug as described, which I could not.
“Luckily” I ran into a very similar issue. I tried to set notes in record mode, which would not trigger. If I record them live, they would.
I filmed it luckily, but I forgot to look up, if it was connected to only SYN being triggered :confused:
It happens occasionally. How it comes to be - I don’t know.
Hope this still helps somewhat…

Can you make a video of that bug and send it to Elektron maybe?

1 Like

Reported this bug too, but wasn’t able to figure the origin. Finally recorded a video as asked, will send it to support when they are back from holidays.

Running OS1.46 BETA1, I am noticing the Problem described here.

It appears that Chain Mode currently only works when Pattern Length (via Func + Page) is set to normal. When setting Pattern Length to advanced, Chains don’t progress, even with the “change” Parameter configured correctly.

Judging by the Manual, this should how ever work —>