Pattern Change Between Digitone / Syntakt / Digitakt (FIXED)

Sorry you all for another question lol. Learning as I go about these. Yesterday I learned about copy / paste patterns, tracks, trigs etc…

Today I’m trying to get digitone (master) to send program change to syntakt and digitakt all at the same time but for some reason it won’t. I have all the appropriate clock send, receive, transport send, receive, prog ch change send, receive boxes changed inside my digitone (master) and the other two boxes.

I’m not sure what I’m missing here to get this to work across all 3 devices? Is it something to do with midi track somewhere? Although I thought just having them all sync’d up in the SYNC section should do this automatically?

1 Like

In the settings for MIDI channels try to change prog chg in/out ch from auto to 16.

I got it now. I had my Func+Page stuff not set right per pattern which is what was throwing it off!

Here we go, strap yourself in for a ride.

You want to change the pattern on your Digitone (master) and have the others follow.
It’s that simple, right?

But, it does not work.
To many, including me, it’s the biggest flaw in the Elektron world that you can’t have a reliable Elektron only set up where one master unit changes the others.

Save yourself a lot of frustration and accept having to change patterns on them individually.

1 Like

No… I got it to work now :stuck_out_tongue:

You’ll be back.

:wave::joy:

@CCMP for me it works without a problem :diddly:

4 Likes

If it works for you, great.
Maybe we’re not talking about the same level of sync control though, because it’s far from straight forward.

I just noticed another post on another thread here though that seems like it could be a solution to getting the PC messages sent early enough to the slave devices.
This is for the Digitakt, but same should/could go for the Digitone;

1 Like

Don’t need all of that just to sync the 3 boxes though.

There’s a sync option in the system settings you do stuff in. I just needed to have all 3 boxes change patterns at the same time and it wasn’t working. I found the problem was that the pattern i was changing too had different length and stuff under func+page menu. Once I set all my patterns to the same info, it changed fine :slight_smile:

2 Likes

I hear ya, I’ve been there too, then it’s stopped working consistently.

I’m not being a dk or beating on Elektron here, it just is what it is… it’s never worked consistently for me in that way.

If it works for you, cool.
Do me a favour though, report back here if/when they start losing sync. (Usually it’ll be one unit starts changing a bar late). :v:

2 Likes

Hey I had it working inconsistently for me just now and I was looking for a solution, but I couldn’t find it here (maybe this solution is already documented somewhere, but I couldn’t find it). So I just dug a little deeper into what @Brockstar said about the page parameters. I found out that the problem starts when I enable length per track. Specifically, if I put the master length on infinite on the box that needs to follow the other box, it will start changing program one bar too late. But if I put it on 16, 32 or however long the pattern actually is, it changes in time. (but of course with 32 it might be late if the 32 hasn’t completed yet). The page parameters do not need to be the same between the boxes and ch. length can be off or whatever. The only thing that seems to matter (for me) is if master length is set to infinite on the box that receives the program changes.

3 Likes

For what it’s worth, I discovered pretty much the same thing when attempting to sync M:S <-> M:C,

Interesting. I wonder if it’s a bug or if it’s intended behavior somehow.

I pretty sure it’s very deliberate, whatever the motivation. I’ve seen (somewhere in the many threads on this topic) detailed feedback from Elektron support about why PC works “within the Elektron ecosystem” but no guarantees about what happens elsewhere.

The fact that it doesn’t work with varied track lengths on at least two machines suggests it’s coded not to accept program change when it’s ambiguous where the pattern ‘ends’ (starts to repeat exactly).

EDIT: Link to Elektron feedback on PC.

It does work with varied track lengths though. It only doesn’t work if master length is set to infinite. And if that is the case it does in fact change, just one bar too late. Beyond that the tracks can be as different, but of course if one is set to 32 and the master to 16, you’ll need to align the changes properly yourself, but that at least makes perfect sense. I wonder what about infinite master track length makes it so that it changes one bar too late

1 Like

Aah … I can’t explore that on my setup (M:C/M:S only, the master option is not there). I’ll doubtless read some more though.

On the M:S/M:C, when when the receiver track lengths do not match (mode=TRK) then the change happens one bar late, same as your setup when set to ‘infinite’.