Octatrack OS Bug Reports

After setting trigs for realtime recording / playback I found something weird : recording is not played if buffer is empty before recording. :scream:
I’m on 1.30B, pretty sure it was working properly before.

Can anybody try ?

Simple test, no midi connection :
New project, default settings
Track 1 Flex with a trig on step 1
Track 1 recorder with a rec trig on step 1
Play and check the play cursor.

Not played the first pass, played after 2nd pass. :sketchy:
Clear the buffer to try again (Rec Setup, Fn + Play out of Grid Recording).

Doesn’t seem surprising not to get playback when rec and play trigs are on exact same step…

So microtiming forward fixes it, but it seems you have to give enough time. At 120 bpm putting the play trig at +1/384 isn’t enough to get immediate playback, whereas +1/192 it works… if slowed right down to 30bpm +1/384 is enough. There must be a tempo somewhere between 30 and 120 at which you have to add another tick between rec and play.

Sorry to say nope, as @Open_Mike confirmed, without SRC3 source, it should record at first pass (empty recording buffer), without microtiming.
I really need people testing that seriously.
That bug is really annoying, to be polite.

Did exactly that, plays immediately in real time as soon as I hit play. FW1.30D. SRC=AB. OTMkII. I cleared the slot, tried again, same result: it plays back as expected.

3 Likes

Perhaps I should have mentioned that yes, performed your test as outlined and yes, can confirm the behaviour. 1.30C

2 Likes

Also yes, now doing the AB source non-micro timed simultaneous rec and play thing (with an audible source) and it all starts working only on the second pass, no playback on the first pass. After a recording has been made it works immediately. Clear the recording and it’s back to silence for the first pass

2 Likes

I definitely can’t reproduce this behaviour, so it might as well be a bug that was corrected in the 1.30D firmware. I never had any other, 1.30D is the one my OTMkII came with, so for me it has always worked as it should. Might be worth it to check the release notes?

1 Like

Sure. I didn’t noticed anything valuable concerning MKIs but maybe that thing would worth last 0S…

1 Like

And a thanks a lot for tests, more to confirm (OS 1.30B and 1.30C) would be great.

Works on 1.25H, as written in the manual… :slight_smile:

Works on first pass…

3 Likes

1.31. Still not working properly.
With empty buffer (greyed), at the first pass recording is not played.
@Clancy confirmed with 1.30C wich is supposed to be like 1.30D. @roadmoviemusic are you sure the buffer is empty at first pass?
I can’t believe it’s a MKI bug only…


Sometimes I just feel like getting rid of it all

Yes, I started with a new project, default settings (didn’t set up a new set though, so global settings might differ from yours). Definitely worked as expected. Will try again but after work

1 Like

I don’t know any parameter that would change the first pass behavior in Personalize menu…

Nor do I I. But I mentioned it for the sake of science :wink:

1 Like

I’m totally pissed of with that bug.
They said the product is finished.
So be it.
New bugs with updates are unacceptable.
As @Open_Mike mentioned, as it is stated in the manual, it should work.

I’d like some more tests from users here.
I’m off till then.
Btw, I didn’t count how many times I checked bugs for other people.
Thanks to @Clancy, @roadmoviemusic and @Open_Mike of course.

6 Likes

There’s still hope… :smile:

3 Likes

It sure is a nasty one. I’m glad I don’t have this (yet!) because that would be a serious show stopper

1 Like

@Olle only responed on the page light problem. Nothing about the knob’s clicking on the OT MK2 or the problem that @sezare56 described.

Hope @Olle will respond on this.

1 Like

Sorry to be off-topic-ly amused, but that’s exactly what our top managers preaches since decades while they are cutting costs at every possible corner they can find (dev/QA/QM) …

:wink:

1 Like

On my OT Mk1 with 1.30B, it works without any issues.
Also works after I cleared the slot.

1 Like