Octatrack OS Bug Reports


The midi track with same channel as audio channel is not supposed to receive midi data at all!

Especially if the midi track has no channel assigned or if a different channel is assigned.

Edit: Maybe better to say the midi track shouldn’t be recording the data even if it receives it.


Hi there,

my OT (OS 1.31) is midi slaved of my digitakt which is also sending program change to the OT. When a midi track set up is selected on OT, it doesn’t follow the program change. No problem when it’s an audio track set up which is selected.

Is it a bug ?

Thanks :wink:


Doesn’t seem normal. What are your Program Change send / receive setttings?
Why do you want DT master?
For pefect recording lengths according to tempo, OT has to be master.


By program change I mean pattern change.

I prefer digitakt to sequence my others synths and you can p-lock program change on each step with it. I’m used to have it as a master. I will give a try to the OT as master clock and pattern change message sender :wink:
But it doesn’t explain what is happening …


So do I (except that I use a DigiTone). I have tried OT as a master, but I found the way it handles PC’s, and Bank Changes, as well as CC’s when those are needed to change banks and programs/patterns on external gear, pretty complicated and quite unpredictable. The DN handles that in a more predictable way. And it has BPM per pattern as well. Some say that OT doesn’t sample well when slaved, but I didn’t notice any issue. I don’t use PickUp Machines, I got mad at that undefeatable automatic tempo adjustment: can be very funny when rehearsing but not so much in front of an audience. With Flex machines I have no problem at all (yet).

I watched a talk between @Dataline and BoBeat the other day, where Cenk said he used the DN as master for his set-up for the same reasons, particularly the BPM per pattern (I believe it was that talk…now I’m not so sure but well…)


I just tried to send program change with OT but it’s not working at all. I well configured the midi sync menu, program change midi channel corresponds on OT, DT and DN (both configured to receive PC). Midi clock is ok, transport as well but no program change … this is twilight zone :sweat_smile:


Send Prog Change Checked?
Same midi channel? (don’t use AUTO)


Yes for the program change send checked but I was on auto for the midi channel :wink:

It works for DT and DN, why not with OT ?

Well, it works ! Thanks willow :love_you_gesture:


But it doesn’t explain why OT, when one midi track set up is open, doesn’t change pattern when I send pattern change with DT … :no_mouth:

Anyway. OT is getting more and more important is my set-up but I still prefer DT to manage program change of my synths :stuck_out_tongue_closed_eyes:


You can use DT for program change with OT as master clock. You can also send PChanges to OT.


Because AUTO doesn’t mean the auto channel for this setting. It means “automatically assign it” (yes, it is somewhat stupid to name the choice this way).

From the manual:

If AUTO is chosen the first MIDI channel used by the audio tracks, and not used by any of the MIDI tracks, will be used.


What was the philosophy behind this rather intriguing feature?


I don’t know and if a midi track uses the first channel, it’s the second, etc! Safer to use a defined channel. Not a bug. Crossfader CC 48 output uses the same channel as AUTO (not AUTO CHANNEL).


Yes but why OT doesn’t change pattern when a midi track setup is opened ???


I don’t know. Try with OT Auto Channel set to off, and then with a midi cable only between DT and OT…


Already did with midi cable only between DT and OT. Will off the auto channel.



Again the problem was program change received on auto channel. Now it is solved :sunglasses:





AUTO :sweat_smile:


Found a bug when in arranger mode you exit to another page, still some white pixels on the screen. They disappear when you use any button so not a big deal.