Sending Program/Pattern Change Messages from Ableton to Rytm


#1

Okay here goes…

Ideally, I’d like to jam on the Rytm, use it’s strengths like p-locks and quick sound design, etc. and then arrange a larger song in Ableton, tying together my Rytm, other hardware gear, and virtual instruments. But it’s always been a challenge, to say the least, to integrate my Rytm projects with my larger studio and DAW-based song projects due to sync issues, OverBridge weirdness, etc.

I simply wish to have a track of MIDI clips spread horizontally along the Ableton Arrangement view that send messages to my Rytm to change Patterns accordingly with various parts of the song (intro = A1, chorus 1 = A2, etc.). Then I can change these around as my larger DAW arrangement evolves. Add in new parts, try different patterns, make fills, move parts around, etc… and then go back and perform on the Rytm while recording new audio in Ableton Live when I am ready.

(NOTE - some embedded pics will be cut off due to size. Click on them to expand to full-size.)

But doesn’t seem to be able to do things in sync. Rytm always goes wonky.

After reading all these various threads on pattern changing issues, not to mention OB, sync, latency, etc. I was about ready to give up and play acoustic guitar, or maybe even something more simple, like tambourine.

But, after a lot of research and experimenting, I’ve found something that appears to work for me, on my setup, for now at least. There was a lot of great tips on Elektronauts.com so I’ve gathered a few links at the bottom. Maybe if my little summary doesn’t work for someone, they can find something of value in these other threads.

Ableton Preferences > Link MIDI

Input: Elektron Analog Rytm

Track = On / Sync = On / Remote = On

Output: Elektron Analog Rytm

Track = On / Sync = On / Remote = On

MIDI Clock Sync Delay = -32.0 ms
MIDI Clock Type = Song

Ableton Clip Settings

  • Note - Find these in Session View

Launch Section

Launch Mode = Trigger
Quantization = None

Notes Section

Pgm Change

Bank — (not sure if you have to have this set to anything or not, this is just how mine happened to be set when I found things to be working.)
Sub — (not sure if you have to have this set to anything or not, this is just how mine happened to be set when I found things to be working.)
Pgm = Whatever Pattern you are trying to trigger. For instance, A12 = Pgm 12, A10 = Pgm 10, etc.

Ableton Track / I/O Settings

MIDI From = Elektron Analog Rytm
Ch. 16

Ableton Track Delay Settings

For the track with your empty MIDI clips triggering Rytm pattern changes…

Track Delay = -416 ms

Elektron Rytm Settings

Rytm Global Menu > MIDI Config

Clock Receive = check
Clock Send = blank
Transport Receive = check
Transport Send = blank
Prog CH Receive = check
Prog CH Send = blank

Rytm Global Menu > MIDI Port Config

Turbo Speed = blank
Out Port Func = MIDI
Thru Port Fun = MIDI
Input From = MIDI + USB
Output To = MIDI + USB
Output CH = Auto CH
PARAM Output = NRPN
Encoder Dest = Int
Pad Dest = Int
Pressure Dest = Int
Mute Dest = Int
Receive Notes = check
Receive CC/NRPN = check

Rytm Global Menu > MIDI Channels

Track 1 channel = 1
Track 2 channel = 2
Track 3 channel = 3
Track 4 channel = 4
Track 5 channel = 5
Track 6 channel = 6
Track 7 channel = 7
Track 8 channel = 8
Track 9 channel = 9
Track 10 channel = 10
Track 11 channel = 11
Track 12 channel = 12
Track FX channel = 13
Perf Channel = 15
Auto Channel = 14
Prog CH In CH = 16
Prog CH Out CH = 16

Rytm Global Menu > System

USB Config

Overbridge Mode = blank (will experiment later using OverBridge to record separate audio channels)
USB-MIDI Only = check

Rytm Scale Menu (Function + Scale - bottom right button on machine)

Will need to set this for each Pattern you wish to have control over.
Setting the CHNG parameter to 2 seems to make the difference.

ADV / CHNG = 2

I have so far only tested with these settings:

ADV
32/32
LEN = 32
CHNG = 2
1x

Not sure what happens if you get crazier with pattern lengths and scales.

Rytm Direct Change (look for Bank Group button)

So far I have only tested PTN = Sequential

Ableton Arrangement View

Looks pretty tight so far. Clips are starting and stopping when they should and kick is locked onto the grid nicely.

Hope this all makes sense. Please let me know if I have something wrong and I’ll try to answer when I have time. I’m not the most knowledgeable member, but I had to come up with something that worked for me. Maybe it doesn’t work for your situation or setup, but hopefully it will get you a bit closer to a solution for your issues.

As of this writing I’m on Live 9.7.1, old 2011 imac, and OS 10.9.5.

Other helpful links:







Rytm pattern change from Ableton (AKA: I'm stupid)
#2

damn, son


#3

What? Help me out here. Like I say, I’m not the most knowledgeable about all this, just testing and writing shit down when it works.


#4

Oh, wait are those the same thing, hehe? I guess I had MIDI Clock Sync Delay set to -32 ms from before, in other projects, just to keep Rytm in time with Ableton. So I could just have Track Delay set to - 448 ms?

Edit: Yep. I guess I could just set Track Delay to -448 ms. Thanks for pointing that out. :blush:


#5

I tried to accomplish part of what you described in your first post, compose a song in ableton with all the necessary clips, so I didn’t have to “play” the patterns or create the song in the machines. I couldn’t make it work, what I do now is I play everything on hardware (AK+AR). It would have been cool tho, so thanks for uploading this tutorial, im sure it will be helpful to some folks


#6

Thanks. I was headed down the all-hardware path myself after trying unsuccessfully for so long to integrate Rytm into my Ableton-based productions, but just couldn’t give up playing my nice plug-ins as well. I think this workflow iteration might work. I basically took all these notes as a way to retain settings in case I needed to return to starting point. Might not work for everyone, but yeah, hopefully others might find some benefit also. Cheers.


#7

It works in Overbridge USB mode as well. Depending on what you’re doing you may get better results by setting the CHNG to 16 on your patterns.


#8

Little update here… I tried this with my new RYTM mk2, and it works like a charm in Ableton Live even without a track delay. Also, the MIDI clock sync delay is significantly better at only -10 ms on my system (PC, Live 10).

So thanks for putting the tutorial together, this will keep my workflow intact until Overbridge is finally ready :slight_smile:


#9

Hello,

I’m trying to do this tutorial on the MK2. On the clips ‘A1’, ‘A2’ etc, what notes should i put so Rytm can recognize which pattern i want to trig ?


#10

The Analog Rytm doesn’t respond to MIDI Note messages for changing patterns; it responds to MIDI Program Change messages.


#13

After some search i figured out i need to click on the program and move the mouse up / down to change it. It’s working now, but there is a big delay when Live send the program change and the Rytm actually change it. I’m trying to adjust the program change channel’s delay to a value that fits.


#14

When the rytm received the program change it will finish the pattern first before changing to the next one. A solution for this is done by creating a track with clips that only do program changes and turn off quantization for the clips.
Now when you’re in track mode you can switch scenes on the last bar of the pattern and bam, pattern changes right when you want it too.
When you’re in arrangement mode just move the clips a little so the program change is send during the last bar of the rytm’s pattern.

There’s a bug in Ableton that sends the last program change again when you press play even when no clips containing program changes are active. Ableton is aware of this issue.


#15

So far i could make this work only by doing this :

  • Func+Scale > Adv > Len 16 , Chng 16
  • In Ableton, positioning the clip that will send program change 2 bars BEFORE i want it actually to change.

Doing this i don’t need any delay on the track. I tested other scenarios, but all of them ended up making the Rytm go out of sync when the program changed.

It’s not the best scenario, but a lot better than i was doing before, that was putting the Rytm on Song mode and sequencing the Rytm part manually directly on its sequencer :stuck_out_tongue:


#16

Is there a way to change a Midi command to activate the ‘Fill’ button on the Rytm ?