Midi loopback bug id'd - might help your headscratcher moment


#1

Hey all. Just found a bug in the OT to watch out for if you ever use midi loopback. I thought some of you might be interested in this one because it answers some of those WTF? moments. I was using loopback, and could not figure out why changing LFO depth in the LFO setup page of one of my midi tracks was making an audio track cut out. If IRC, @defenestration was trying to identify some of these types of things. Simple to reproduce. Try it out:

Connect midi in to midi out. Make sure that Track 1 is selected in both the midi and audio sections of the OT. Navigate to the midi section of the OT. Go to the LFO setup page, and turn the depth knob up to some value. Now, switch back to the audio section of the OT. Notice how the depth knob of the audio LFO has changed to the same value that you set in the midi section LFO setup page. The same bug exists with the Speed knob, but none of the other LFO setup parameters. The bug only affects twin tracks (i.e. midi track 1 and audio track 1). This bug does not work in reverse, i.e. making a change in the LFO setup page of the audio section does not change the LFO of the midi section. This bug also does not appear if you simply use the regular LFO pages (as opposed to the LFO setup page). Turning Audio CC in to OFF, or Audio CC out to INT, both solve the problem.

So what was happening for me was that I had a Thru machine on audio track 1 set to listen to input AB. Making a change to the depth parameter of the LFO in the LFO setup page of midi track 1 would then make audio track 1 cut out, because its default LFO target is INAB.

EDIT- the audio track and midi track in this test must be set to respond to different midi channels. I.e set midi track 1 to midi channel 1, and audio track 1 to any midi channel other than 1.


Ot internal midi control without cable
More noobing: Track starts sampling without recorder trigs
#2

I couldn’t reproduce it with a new project.
Other settings?
1.30B. mki

Your audio track is apparently receiving midi CC 28-33 from midi track. Does it also happen if you turn speed / depth in lfo page? (out of lfo setup)
Edit : no apparently.


#3

#4

Yeah, I tested and it totally doesn’t work with a brand new project. But- if you create a new project then set midi track 1 to channel 1, then set audio track 1 to channel 9, you’ll see the problem appear. Don’t ask me why the midi track and audio tracks need to be on different channels, but that’s when it happens. Original post edited to add this condition.


#5

I confirm. In Midi mode, lfo setup page only…
Buggy. If you check my above post… :thinking:
Devs, back to work with “old” gear please… :slightly_frowning_face:


#6

Response from Elektron is that they are very unlikely to ever fix bugs that only occur in the midi loopback environment. They also did not confirm the bug in general.


#7

Tell them that unfortunately that occurs even without midi loopback. I checked with a midi monitor. This is not a surprise for me.

It sends the 6 midi lfos CCs (28-33), on the channel of the corresponding audio track.

By default, audio channels are 1-8,
midi T1 will send lfo CCs on channel 1, but if you change audio T1 channel to any other channel, it will send lfo CCs on the same channel.

It also happens if you don’t set any channel on the midi track, but doesn’t if the midi track have the same channel as an audio track (1-8).


#8

If you don’t use midi loopback nor control OT audio tracks, the workaround is to set audio channels to off.

But it is totally unacceptable that by default you send CCs on channels 1-8 when you set the corresponding midi track lfos in LFO SETUP page. It is not related to midi loopback, and from a new project you don’t have to change any other parameter to reproduce that bug.


#9

Wow, that’s a biggie!


#10

OP says you can turn audio cc out to int and it solves it, my hunch is the issue is linked to that parameter. Is anyone using audio CC int+ext and atctually using the “ext” part for something? I never use that, if OP is right just turn it to “int”…


#11

With EXT there is a no Main Out audio bug!
I don’t think INT solves it. Checking now.
Edit, yes it solves the problem, because the audio track can’t send midi anymore.


#12

No one said they used ext… By default its int+ext, try just int as in OPs post…
Int+ext is for using OT knobs as a midi controller at the same time as controlling OT parameters, ext is for using OT in a local off fashion when the midi is routed and bounced back from some other gear/midi sequencer…


#13

I say it’s too much bugs.
So yes indeed if you set to INT, it doesn’t send CCs.
For me it means that you send the CCs with the audio track! (setting the midi track)
Mixed up!


#14

All I’m saying is I’ve never even read of anyone using the “ext” part of “int+ext”, and certainly not in combo with loop back, so the issue can easily be avoided and midi loop back life can go on… :slightly_smiling_face:


#15

I do, with midi loopback, if you set all audio channel on the same one you have control all (the time) :stuck_out_tongue:


#16

HahHa… I should figured if anyone did it’d be you… :stuck_out_tongue_winking_eye::smiley:
The issue/bug to me seems like midi setup pages, or at least one of them, or at least a few parameters, send cc’s when audio cc is set to int+ext, ext…


#17

I used EXT for my crossfader position to scene trick, otherwise there is a little conflict between actual and midi processed position.
And Funnily the midi loopback solves the no audio problem with EXT.

For me the bug is that midi tracks lfo setup pages control audio lfo pages CC send without changing their values… :thinking::scream:

And once again, that’s with default settings!


#18

It’s actually starting to make some sense to me that the two parameters (depth,speed) in the setup page that are shared with the main page would still send midi if OT was being used in local off fashion, and since there’s no cc’s for knobs that only exist in setup pages those won’t send midi and just control internally regardless…

Does seem weird that the audio track receiving channel is different than the midi track sending channel though… Any autochannel set? Anyway, I’ll leave it to ya’ll if you want to pick it to pieces, I don’t even use loopback. :grin:

Another way out as per OP is disable audio cc in, if that helps…


#19

Won’t work if you want to control external synth.

OT is already complicated, how do you explain to a noob that by default you can send CCs on audio tracks channels when you change midi tracks parameters ?
“Ah, audio tracks and midi tracks are internally midi linked?”
“No, they are not supposed to but they are”


#20

No because with that bug it doesn’t use midi track channel at all. It happens even without midi track channel set! :sketchy:

For me it controls the audio track which sends corresponding CCs.