Bug- Midi track LFO setup cc’s sent on audio track midi channel


#21

How will disabling audio cc in make OT not control an external synth?

Anyway, like you and I usually do I’m just trying to help find solutions to weird OT behaviors, I’m not saying I like it like that… :smiley: Hence my “in case it helps”…
I think we’re tired again… I have yard work to go do… I can’t do this right now… But I love you all. :heart_eyes:
Later… :slight_smile:


#22

I have used it. I wanted the crossfader to command parameters on an external module while playing with scenes on the OT. Not very convincing and the audio CC’s messed up other params in the ext synth, so I set it back to int.


#23

I mean it doesn’t change the bug behavior if you disable CC in. It happens WITHOUT MIDI LOOPBACK. It sends CCs anyway, execpt with channel off or CC INT.


#24

I just meant no one said in this thread that they were utilizing it…

@sezare56, my brains toasts, I’m tired, and I don’t use loopback, just trying to point out some stuff from OP’s post that might help, but now it’s too much for me. Maybe later. It’s all good… :slight_smile:

Suns shining here and it’s warm after chilly and raining for weeks, yard work for me! :smile:


#25

Sorry to insist, but even Elektron says it’s not a priority, but this bug is NOT related to midi loopback, and can be annoying for any user using midi tracks lfos and external midi gear.


#26

Definitely my case…


#27

Ahh… I’m still on a built up sleep deficit so sometimes I haven’t been catching all the bits and pieces… I literally have insomnia from stopping my long time smoking of Cali buds (legal here) a few weeks ago, it’s a thing, happened to me before, happens to other too… :grin:


#28

I do that all the time but I always have all audio midi channels off, audio note and cc in both off, and audio cc and note out both set to int, so it hasn’t happen to me. And I’m not saying it doesn’t suck I’m just explaining why I’ve never run into it… :slight_smile:


#29

This is the key post I missed… :wink: And parts of the one before… :grin:
I guess I have to learn how to read again, and try to control my post reflex… :upside_down_face: Probably be easier after I learn how to sleep again. I don’t want to clutter threads with my thought process, hopefully those posts might contain some info that helps someone…


#30

It’s my fault, I should have written it bigger.
NOT RELATED TO MIDI LOOPBACK!
NOT RELATED TO MIDI LOOPBACK!
NOT RELATED TO MIDI LOOPBACK!
@Zac_Kyoti please modify the title and tell Elektron that it is NOT RELATED TO MIDI LOOPBACK! and happen with a default project, even without setting a midi channel in a midi track. Just turn the midi lfo setup knobs to enjoy the bug.

58779414


#31

Unacceptable !


#32

That would have helped a lot actually. :grin: Please start writing the main point in your posts
THREE TIMES IN BOLD!
THREE TIMES IN BOLD!
THREE TIMES IN BOLD!
…from now on… :rofl:


#33

The OT is such an genious machine that I can forgive it/him/her some personal flaws …

About the “three times in bold and uppercase”:

I miss the HTML blink tag soooo much. That would make it even better. :wink:


#34

Before making changes to the title and body of my OP (and contacting Elektron again) , I think we need to simplify all of this for clarity. I am not at my OT to test atm, but may need to do so for peace of mind. It seems like there are a few key points here - please confirm:

  1. This is actually not related to midi loopback, it’s just that loopback allows us to see the problem easily.
  2. The Depth and Speed parameters on the Midi LFO setup pages are sending CCs. OK, so this in itself is a bug, right? Shouldn’t the only CCs that come out of the midi section be from whatever a user has set in the CC1+2 pages?
  3. If the buggy LFO setup CCs are received by the OT, they can affect the audio LFO pages. The necessary condition appears to be that the midi channel of corresponding audio and midi tracks (i.e. audio T1 and midi T1) have to be on different midi channels. Also, ONLY the corresponding audio track can be affected by movement of the midi track LFO setup parameter (again, midi track 1 only affects audio track 1, etc.)

Is my understanding correct?


#36

Yes, yes, and for 3, midi tracks with the same channel as a track are not supposed to receive midi but they can, because of another bug, maybe related…
Octatrack OS Bug Reports

**There is definitely a weird midi correlation between midi tracks and audio tracks **

I can’t test again for a few days…


#37

#38

#39

OP contacted us and said

the problem described here is not an OT bug, but was actually related to one of the Max for Live devices in my Live set.


#40

Aaaaaaand… opened again !


#41