Digitakt wont start


#1

I was out of town for the weekend and didn’t use it, tried to turn it on tonight when i got home and now its not starting up. Makes a little click but nothing turns on. no lights, no sound, no screen… nothing. :frowning:


Digitakt DEAD
#2

I think your best option is to contact Elektron or your retailer.


#3

ughhh i really hope i dont have to do this, has this happen to you too?


#4

No, mine has been fine, so far. It could be something simple like a fuse.


#6

Same thing for me. Won’t turn on this morning. Just black screen. So bummed :frowning:


#7

Ok. And as if by magic after an hour of turning off and on, unplugging cord, letting it sit, then finally posting here. Now it turned back on. That’s really not good but I’ll take it.


#8

Hey, same thing just happened to me. Did yours all enventually turned back on? Did it do it again?
Have you identified the problem ?

So frustrating… Seems to be a poorly connected wire or a fuse but can’t repair it myself. And got a gig on next friday :fearful:


#9

PANIC: Mine just did this. It was on this morning, working fine. Turned it off and went shopping. Came back, it is still sitting exactly where I left it, and now it won’t power on. OY!


#10

unplug everything, put it on table tell it how you love it, then plug in to power and we will see :smiley:


#11

yeah, had exactly the same Today. Tried few hours later- now working again. It happened at about 14:00 GMT.


#12

unplugged it for half an hour…
explained my love and passion to it…
got upset, turned my back and ignored it…
considered a fling with another sampler…
couldn’t bring myself to do it, so instead wallowed in pity…
came back…
gently plugged it back in…
AND IT BOOTED!

Whew…


#13

It happen to me some week ago…but i was thinking it was a bad connection between cord and psu…


#14

I pretty much have eliminated the possibility of faulty power adapter as I tried with two different adapters, both working fine with Heat. I’m convinced it was caused by internal issue - I’m guessing probably the faulty booting application.


#17

@MarHabrine you can edit your patterns in Grid Recording mode. To go from Live to Grid, just push the Rec button once. If you are new in Digitakt, you may want to watch this great tutorial https://youtu.be/MXexVHNO0ms


#18

This type of thing is unacceptable. This is supposed to be a professional piece of gear. It’s annoying when this happens at home, but imagine if it happened at a gig. Mine used to do this (then it permanently locked up), and was returned. Elektron needs to get focused and start fixing problems with their existing gear before they release new products.


#19

To be honest , i made a 4500 km bike trip this summer with digitakt and battery in the bike bag. I dont power it up during the last two weeks of this trip. When back home, it happen . I remenber thinking shit something maybe disconnect inside due to vibration on road. I switch it on 2 or 3 times without succes, then a bit later it was ok.was 2 month ago, never happen again… honestly i wasnt thinking at it anymore, but this post really annoyed and surprised me. Really want to know what really it is: hardware or software prob?’. Why so occasional?? Maybe just another sort of easter egg ( joke),. Would really know a bit more about this from elektron.will post for a support ticket next day. Really strange and a bit scary. sort of remind me a lot of post i read at the time about nord lead 3 which apparently were very sensible to power. Really curious.


#20

Now that i think at it, the lenovo x201 i have has too a problem which the same symptom, largely documented on the web forum by user. In th x201 case it has something to do with static elec, the solution was to unplug it, remove the battery then press the power button to "discharge ’ it, then its ok after. Happen to me two time in 2 years owning it…


#21

I ended up having to ship it back to Elektron and wait a few weeks for it to come back, luckily i havent had any problems since then and they gave me a dust cover for the inconvenience.


#22

This is major annoying – but once you know what’s happening, no biggy.

Early this year, long before this message thread appeared, i was sooo excited getting the box in the mail, you can imagine, and being excited i flipped the power switch on and off and on the first time out of the box. Dead – i was convinced MY Digitakt was DOA. And again you can imagine.

But of course miraculously it came back from the dead – and i figured out what was happening and all has been happy ever since.


#23

This is a joke. Seriously loosing faith in this company. Went with elektron instead of Akai as I thought Elektron would be better build quality. seems i was wrong.