Digitakt 1.30 : Bug reports

New firmware has been released!

Remember to back up before upgrading and even load a new empty project to avoid any damage to your current project.
And avoid upgrading before a gig. :tongue:

You encountered something wrong in this OS and want to check if others can replicate it ?
Here is the place.

Doesn’t replace a support ticket, of course, but you might want to check if it’s not a feature before declaring a bug :wink:

Please report all bugs via the Support Tickets section on elektron.se if they have not already been confirmed below.


My DT no longer responds to pattern change commands coming from external devices (ie DN, AR). DT also no longer appears to send pattern changes to DN. Anyone have similar issues?

We had some issues in testing with projects not wanting to load if they were made in really old firmwares but They’d gotten those issues ironed out before release thank you for posting this recovery technique for anyone else who needs it. :slight_smile:


I assume you were a beta tester? Did you experiences any issues with the DT not responding appropriately to pattern change messages? I’m able to change patterns directly on DT, but not from another device sending midi

Hello Nauts,

can anyone replicate this issue…

after the new 1.3 OS, whenever I am in step jump record and input notes from a midi keyboard or in chromatic mode to the audio/midi tracks the green trig is not moving/progressing according to trig length, it stands still at the 1st trig, normal record modes record midi notes normally…previously notes would be recorded and the green trig would progress according to the trig length set.

In fact neither of the jump record modes seem to be working, the traditional nor the new multichannel, I am in an older project, will try a new one…in the meantime can anyone replicate this behaviour?

edit; just created a new project and it still is not working.

Nevermind, after power cycling the Digitakt it seems to have sorted itself out…weird though


It’s not one of the use cases I ever take advantage of so wasn’t focused too hard on that. Are you saying you can’t send PC messages at all? or is there a specific set of steps needed to reproduce the issue?

1 Like

just tried it with my keystep and it works fine. what midi channel are you sending on?


thanks for the reply, it sorted itself out and works now after a power cycle

1 Like

This is looking to be a case of user error due to user’s lack of understanding on how to use the auto channels. As of right now this is no longer an issue for me (all devices have program change send/receive set to auto channel now). After AR changes DT pattern, it does take the DT one time thru to change the pattern on the DN, but it is now working.


The other thing to check is your master length settings on each device, for instance if one device is set to change over after 16 steps and the other is set to change after 64 it is going to lag 3 bars behind the other. :slight_smile:


I’m noticing a bug with the PRE/-PRE trig conditions. I have a snare on steps 13 of all four pages. I have the same snare on step 14 of all four pages and it’s microtimed to start at 13, and also has the delay knob plocked. The snares on 13 are currently set for 100% hit, and the ones on 14 are set for -PRE, meaning they shouldn’t play at the moment because of step 13. Unfortunately, that is not what’s happening. The snares on 14 play anyway. No matter what I do, what trig conditions I change or remove on either of them, I can’t get it to work. I want to make it so the 13 steps are at 50% probability so that when they don’t hit, the 14s with the delay plock are triggered. It happens on all patterns in my project.

I created a new project and it works fine, so I’m thinking it’s a bug in reloading old projects perhaps.

There is currently a bug where if you change PRE/-PRE while the sequencer is running you can more or less cause them to act in opposite of how they should, hopefully it will be ironed out soon. I think this is possibly the same bug you are running into here.


Digitakt 1.30 Overbridge_2.0.58.8 + Ableton 11 sync problem

Since the latest Overbridge and OS upgrade of the Digitakt i have a strange problem.
When i drag Digitakt or Analog Heat from the Ableton browser into a miditrack both machines are out of sync .
But, when i drag the whole track to a random track of session view the machines sync.

So , drag > drop to a midi midi track = no sync
Drag whole track while running to the anywhere of session and release = sync.

Update: After some testing saving a project in ableton, opening the project everything starts out of sync again, clicking a couple of times on Live stop button resets the sync.
So my guess is overbridge does not get a proper reset command when loading the plugs into live.

Edit: Waiting for Support , asked for version 1.20A to go back,

there is a 2.0.59 out there

1 Like

Had an issue last night where I was copying parts about and some key combo faused the FUNC key to be metaphorically stuck down, needed to reload project to clear it or everytime I pressed play it would try to clear the pattern.

Can anyone give me info?
Like i mentioned in this tread OS 1.30 gave a lot of issues. I opened a support ticket yesterday to ask for OS 1.21A , but no reply yet. I found a link in a tread with the previous OS Old projects sounding different after 1.30 update and how to solve it - #12 by maerteijn
I downgraded the OS , and had no sound, reloaded project and it’s ok.
But now when i boot the digitakt it shows a E in the left corner in the boot screen.
I don’t recall seeing this ever, my intuition says E of error? What does this mean? The Digitakt functions normal.

I don’t know about your main issue but don’t worry about the E - it doesn’t mean Error at all.


More like a few observations;

  • Trig Note still does not go higher than +24, meaning that if you use a single cycle waveform, for example, and pitch that down to the extended range you will not be able to extend the octaves in chromatic mode. Seems like a major oversight.
  • EQ filter clips (sort of, sounds like something is wrong) almost immediately when gaining or attenuating, doesn’t seem that usable to me. Feels like a bug, but might just be that the EQ needs more headroom.
  • Dual switch icon breaks the layout on the Master External Mixer page, I would love to see a vertical one instead. :kissing_heart:

Well that’s weird. It’s pretty much unuseable as an EQ. Fine as a narrow range clipper effect though, but is that the point?

Hehe ok, I’ll submit a support ticket. Haven’t done that since 2015. :smiley: