Analog Four/Keys OS 1.50A: bug reports

Firmware 1.50A is now released

Discuss here


Think about updating Transfer app and Overbridge.

Remember to back up before upgrading and even load a new empty project to avoid any damage to your current project.
And avoid upgrading before a gig. :tongue:

You encountered something wrong in the newest OS, reproduced it in a project created since the upgrade and want to check if others can replicate it ?
Here is the place.

Doesn’t replace a support ticket, of course, but you might want to check if it’s not a feature before declaring a bug :wink:

Please report all bugs via the Support Tickets section on elektron.se if they have not already been confirmed below.

2 Likes

Looks like the boot issue is gone one my A4 MK2 Black. Let’s hope it continue like that.
Sadly, still the same on my ARMK2 Black.

2 Likes

I noticed an issue with 1.50 on the Mk2 that I didn’t get a chance to report where all track scale settings for all existing patterns were reverted to 1/1 (as opposed to whatever else they may have been).

I noticed in the release notes they mentioned something similar, so I’m wondering if that’s the sort of behavior they were referencing, or if that was a fix for something else.

The update really made the boot faster and without issue. Very glad ! :slight_smile:

That’s what they fixed

Hi folks,
Not sure it’s a bug or if I miss something on my A4.
I wanted to use the internal keyboard to play an external synth.
I’ve set the keyboard to int + ext on Ch1, the external synth is also set to Ch1.
The synth receive MIDI but not sound is coming out. BUT, when I put trigs on a pattern on the same track, the external synth is indeed sequenced and I can head my sound / sequence.

Is it something I missed on the internal keyboard set up ? :slight_smile:

Thank you !

2 Likes

Two things

  1. try disabling midi sequencing from the track and see if it works as is wrt int kbd playing externally.

This may have just changed due to 2)

  1. external midi passthrough for an external controller was just added, it may have compromised the onboard way that midi is handled (haven’t tested this, just thinking aloud)

People have been bemoaning the fact that the internal keys would only transmit at playback and not with sequencing, so it’s v surprising to learn that it appears to not do this for you

Make sure auto channel isn’t clashing with a track chan

I’ll have a look at this out of interest shortly

This imho has clearly stopped working since the last update, whilst it’s something i don’t use it absolutely used to work - i’ll ping @Patrik for a confirmation on this one as he has been involved on this recent release - but @Carmelo_Ponente please submit a bug report at Elektron to enquire if there’s a reason it is like this

i suspect it’s arisen due to the changes to incorporate external ‘pass-through’ and it now leaves the definition of ext and int+ext as redundant afaict wrt the Keyboard Destination

I tried on a Mk2 running 1.50A

2 Likes

Following, because I constantly use both int en ext keyboards. Crucial to know before I update to 1.50A. Do more people have this issue ?

Doing the ticket now :slight_smile:

3 Likes

Awesome and fast reply of @Patrik :slight_smile:

" Make sure to set OUTPUT CH to TRK CH in global settings > MIDI config > Port config. Otherwise, the miniKB will send on the auto channel. Set the track channels of choice in global settings > MIDI config > Channels "

Worked like a charm !

8 Likes

oops … i completely forgot about that setting

1 Like

Not easy to remember everything.
I have to admit, the forum is very helpful !
Having less space on my table helps me to use the A4 keyboard :slight_smile:

1 Like

I dialed-up a lead sound for AK last night.

When trying to play legato from a master keyboard, via Overbridge, I noticed that something’s not quite right. Doesn’t seem to happen when playing the AK locally.

Let’s say I hold a ‘C’ down, then whilst that’s playing as a mono voice, I play a ‘G’. As expected, I get a legato move to the ‘G’, with a bit of glide as configured.

…but when I release the ‘G’, on all my other synths, the ‘C’ is normally re-triggered. On AK and A4 Mk1, that’s not happening. It is happening when playing the AK locally. Only seems to happen with Overbridge.

So - I’d say that’s a bug. Obviously, the notes played can be anything. Anyone able to reproduce and agree that it’s a bug?

hi all

i appreciate all of you grabbing the updates on release and working through the issues, i am late to the upgrade party as i am developing FW for behringer drum machines and that is taking 100% of my time and i really have no extra headspace for more FW - before i upgrade my a4mk2 is all ok now?

i know this is for bugs so i apologise

Seems good, the last release fixed the major problems.
Haven’t noticed a new one yet.

Hi, my AK keyboard didnt work as expected after the update. The seq is alright, BUT the keyboard plays only one sound whatever Track. I noticed there was a MULTIMAP but I cleared it. And now it works, somehow the MULTIMAP (I never use that) was on after the update. Confusing, but now it works.

If I may, try to know more about the multimap. It’s a very interesting mode.

Its happened less since I updated but sometimes when I’m in the LFO menu the destination option starts self scrolling itself if I touch another knob

I agree … very powerful, strange things happended :smile:
But your right, this will help:


Thx
1 Like