Syntakt & Linux

I try to use Elektron Syntakt as a external soundcard on Xubuntu 22.10.

The device is connected via USB, correctly detected and I can select it as an output device.

The Problem:

The sound coning out is completely distorted. Listen to some playback recordings here.

To me it sounds like the wrong sample rate and/or sample format is being used. But this is just guess …

I tried to change the device configuration on different levels of linux audio stack including ALSA, PulseAudio, JACK, PipeWire without any success. I’m stuck. :frowning:

(Btw: The device works properly on Windows)

My Questions:

  • Does anybody ran into the same issue? How did you fix it?
  • What approach/tools do you recommend to better analyze the cause of this.

Any help would be highly appreciated!

1 Like

Hi, and welcome to the forums!

I’ve had similar issues in the past. For me it was caused by that my (pipewire) setup was by default configured for 44.1Khz sampling, where the digitone/takt are suppying 48k.
This caused a lot of resampling which sound surprisingly similar to what you recorded.

I did a lot of tinkering, so I am unsure if this will fix your problem but changing the following lines in ~/.config/pipewire/pipewire.conf (might have to copy a template from elsewhere in your system.) = {
# Properties for the DSP configuration.
default.clock.rate          = 48000
default.clock.allowed-rates = [ 48000 96000 192000 ]

After restarting the relevant components, the pipewire system should now run at 48K.

I hope this helps, or at least points you in the right direction.

To try it out before committing it to config:

pw-metadata -n settings 0 clock.force-rate 48000

Thanks! I’ve changed the configs accordingly but unfortunately the issue persists :frowning:

Meanwhile I tried to play a sound directly on the Syntakt device without any Audio Servers in between using ALSA speaker-test. Therefore I stopped PulseAudio/Pipewire and set the playback params according to what I think the Syntakt works internally (the device refused other params anyway). This should give us a clean 440Hz sine sound on two channels in 48kHz and signed 32bit sample format:

speaker-test -Dhw:1,0 -tsin -c2 -r48000 -FS32_LE


speaker-test 1.2.6

Playback device is hw:1,0
Stream parameters are 48000Hz, S32_LE, 2 channels
Sine wave rate is 440,0000Hz
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 16 to 96000
Period size range from 8 to 48000
Using max buffer size 96000
Periods = 4
was set period_size = 24000
was set buffer_size = 96000

I can hear the sound playing on both channels, but still is completely distorted.

I keep searching …

I just used and it’s all good for me


@sse, same thing happens with my Digitakt and I’d say with the same type of audio artifacts. I tried to fix it without success.

But I don’t think the issue is in the audio rate as I use a Soundcraft Signature 12 MTK which runs at 48 kHz too and works totally fine out of the box on channels 1 and 2. The only difference is in the bit depth as MTK is 16 bits.

@Baztek, do you have any special configuration to indicate the bit depth?

Does anyone know for sure the Elektron boxes bit depth? @sse is indicating they are 32 but I always thought they were 24 and I’m not sure anymore.

I’m trying to use syntakt as an audio interface in Ubuntu Studio 23.4, and I’m getting this completely distorted sound.

I’ve tried both pipewire and jack, with different settings, without any noticeable change. Jack server keeps complaining about “XRUN callback”, no matter the settings.

The thing is it worked without any problems in Ubuntu Studio 22.4, and trying another audio interface (audient id14), it also works without any problem or special configuration.

Any insight into this problem would be appreciated.

I use a Digitone as an audio interface to Ubuntu 22.1. I don’t own a Syntakt. There is a setting on the Digitone:


That can cause distortion for sounds coming from the computer…if it’s turned up too high.

Probably not your issue…

1 Like

Thank you for your answer, @aMunchkinElfGraduate.

I’ve ended up returning the new laptop for a refund (there were other problems in addition to this). Now I’m listening to music using the Syntakt as an audio interface with my very old PC, with Debian 11, without any problems, plug and play. So, it wasn’t a Syntakt issue. Maybe the kernel or audio system version (but there were problems too with Windows 11 in the same computer, so maybe even a hardware problem).


I did not have good luck with Syntakt as a class-compliant audio device when trying it with Ubuntu LTS either. I have Bitwig on Linux and the Syntakt just wouldn’t work as an audio device. Other devices have worked.

1 Like

Strange. It worked perfectly for me on all computers and OS (including Ubuntu Studio LTS with Bitwig) until this.

I reported to this thread some findings about Digitakt issues in the USB audio compliant mode.

The thread is about Analog Heat +FX and this one is about Syntakt but I’ll bet the same happens for different products.

arecord works but aplay doesn’t. Do you have the same problem?

I can’t test this, as I don’t have that computer any more. But, Syntakt works fine in other computers with Linux.

In fact, I’ve used it in Linux, Windows, and MacOS, and it always worked fine.

In that computer, I had problema with Windows 11 too (not the same distortion, but it kept losing the audio for a while).

So, I assumed that the most probable cause was a hardware problem, and the second most probable cause, a problem with very new hardware/drivers.