Syntakt & Linux

I try to use Elektron Syntakt as a external soundcard on Xubuntu 22.10.

The device is connected via USB, correctly detected and I can select it as an output device.

The Problem:

The sound coning out is completely distorted. Listen to some playback recordings here.

To me it sounds like the wrong sample rate and/or sample format is being used. But this is just guess …

I tried to change the device configuration on different levels of linux audio stack including ALSA, PulseAudio, JACK, PipeWire without any success. I’m stuck. :frowning:

(Btw: The device works properly on Windows)

My Questions:

  • Does anybody ran into the same issue? How did you fix it?
  • What approach/tools do you recommend to better analyze the cause of this.

Any help would be highly appreciated!

1 Like

Hi, and welcome to the forums!

I’ve had similar issues in the past. For me it was caused by that my (pipewire) setup was by default configured for 44.1Khz sampling, where the digitone/takt are suppying 48k.
This caused a lot of resampling which sound surprisingly similar to what you recorded.

I did a lot of tinkering, so I am unsure if this will fix your problem but changing the following lines in ~/.config/pipewire/pipewire.conf (might have to copy a template from elsewhere in your system.)

context.properties = {
# Properties for the DSP configuration.
default.clock.rate          = 48000
default.clock.allowed-rates = [ 48000 96000 192000 ]

After restarting the relevant components, the pipewire system should now run at 48K.

I hope this helps, or at least points you in the right direction.

Edit:
To try it out before committing it to config:

pw-metadata -n settings 0 clock.force-rate 48000
6 Likes

Thanks! I’ve changed the configs accordingly but unfortunately the issue persists :frowning:

Meanwhile I tried to play a sound directly on the Syntakt device without any Audio Servers in between using ALSA speaker-test. Therefore I stopped PulseAudio/Pipewire and set the playback params according to what I think the Syntakt works internally (the device refused other params anyway). This should give us a clean 440Hz sine sound on two channels in 48kHz and signed 32bit sample format:

speaker-test -Dhw:1,0 -tsin -c2 -r48000 -FS32_LE

Output:

speaker-test 1.2.6

Playback device is hw:1,0
Stream parameters are 48000Hz, S32_LE, 2 channels
Sine wave rate is 440,0000Hz
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 16 to 96000
Period size range from 8 to 48000
Using max buffer size 96000
Periods = 4
was set period_size = 24000
was set buffer_size = 96000

I can hear the sound playing on both channels, but still is completely distorted.

I keep searching …

I just used https://github.com/dagargo/overwitch and it’s all good for me

1 Like

@sse, same thing happens with my Digitakt and I’d say with the same type of audio artifacts. I tried to fix it without success.

But I don’t think the issue is in the audio rate as I use a Soundcraft Signature 12 MTK which runs at 48 kHz too and works totally fine out of the box on channels 1 and 2. The only difference is in the bit depth as MTK is 16 bits.

@Baztek, do you have any special configuration to indicate the bit depth?

Does anyone know for sure the Elektron boxes bit depth? @sse is indicating they are 32 but I always thought they were 24 and I’m not sure anymore.