Solution for some mac connectivity issues (disabled software)

Hey Elektronauts,

just arrived here with a new Digitakt which did not initially connect to my mac with the Overbridge beta. This led to a lengthy tangent in the joy of mac (love it when it works, major shit when it doesn’t).

Quick solution after the break, how I got there:

Many have already pointed out that in the initial installation you will get a prompt that some software has been blocked that you will have to enable right(!!) after installation in (System Preferences/Security & Privacy). Here’s a solution if like me you didn’t get that till it was too late.

It turns out that some of the driver seems to persist despite deinstalling and so there is no new prompt (at least in my case).

Some searching via “System Information” found in the app drawer under utilities revealed the fact I was on the right track.

A great user post revealed the way to go https://discussions.apple.com/thread/8172194

And that method worked in the end.


Here’s the brief thanks to “mnaile” from the Apple Support Community

  1. Uninstall the Overbridge Beta"
  2. Check “System Information” for the line “Disabled Software”, use your Phone to take a picture of the Number/Letter combo (KS6W2DLCW9 in my case) attached to the driver

Now take a picture of step 4 before you reboot :wink:

  1. Reboot to recovery, holding down command-r while restarting.

  2. From menu > Utilities open terminal and type the following replacing the team_id’s noted from step 2:
    “spctl kext-consent disable”
    “spctl kext-consent add KS6W2DLCW9" <-- this should be your number
    “spctl kext-consent enable"

  3. Reinstall the software, it should work now

Worked for me, I hope it does for some of you!

23 Likes

Just here to bump this super helpful post.

Thanks Marbla!

1 Like

Post moved here for added public prominence

1 Like

After days of other fixes, this is the one that did it!

Thank you and bumpity-bump.

I had some weird install issues ages ago , was quite an early build which didn’t fully uninstall.

The info above is handy :grinning:

Yeah, I think that’s basically the problem. If the uninstall was complete I’d figure that the privacy prompt would be accessible again on the next install.

this doesn’t fix it for me. is there any way to make sure that the kext is the problem? A log file, maybe? I’ve done everything that I can think of, but my digitakt and digitone are not seen by OB.

1 Like

Bump.

Thanks a lot. I’ve been looking for a solution on this forum, but my searches never got me there; a post on Reddit did. Maybe one should pin it or something, to make it more findable.

1 Like

IT WORKSSSSS!!! After multiple installs and uninstalls, this fixed the problem. Thank you so much!

Wow Marbla!
Thank you! I’ll give it a try this afternoon

sorry guys I’m stoopid why exactly do I have to type on my terminal? its not very clear to me thanks

had the same issue with my digitone and worked. thanks marbla!

Typing this but i get this message : spctl: failed to store new configuration
any idea?

I am having the same issue. did u find out how to do it properly or fix it or anything?

I finally did, I was just making mistakes writing the code.

Thanks for putting this together. I was totally stumped by this issue. I’ve been trying to get both my Analog Keys and Rytm to be detected in Catalina 10.15.4 and couldn’t do it. Followed your steps and it finally detected! Wanted to just mention your key and my key (Number/Letter combo) were identical in case that threw anyone off. Cheers :call_me_hand:

thanks a lot !

I’m still having this issue, even with the release version. I’m unable to get the code because it does not show up in the disabled software section of System Information.

Any ideas?

Did it once. Worked. Tried to launch Overbridge after few days and i can do this whole process again. Suggestions?