Slicing samples using midi?

Guys, I just thought of this trick which could (theoretically) work, but i can’t get it to actually work. Maybe one of you can figure this out…

The digitakt has really become my favourite piece of gear ever, both because of it’s workflow and its sound. I use it to make sample based hiphop beats, and the one thing which is kind of awkward to do is chop a sample and play it along with the rest of the beat. Right now I often create a ‘‘dummy’’ pattern in which I use all audio tracks playing the same sample with a different start point to play with, and then copy p-locked trigs of each audio track to my actual pattern. This is an irritating workaround, especially because you can’t actually hear the pattern playing while trying out the slices.

Now the ideal solution would be for elektron to implement a slice mode (for instance as a toggle of the chromatic mode), but for now I thought of another possible method:

Solution 1:
Using a midi loop in which the 8 midi channels are used to control one of the audio tracks, it should be theoretically possible to send both a note value, and a cc value to this 1 audio track. Since cc20 controls the start point of the sample, it should be possible to have the 8 midi buttons each play a specific slice of the sample loaded on this audio track, which would work great, because all the slices would work as if they were in a mute group. I tried to set this up, but the cc20 value is not sent to the audio track with every press of the button, just by turning the knob controlling the cc parameter. Is there any way to have every button send out the selected cc value every time it’s pressed?

Solution 2:
The LFO of the midi tracks can also be used to control cc20, and i should also be possible to trigger the LFO by triggering the note. Now I’m no expert on LFO’s, but whatever I tried, the results seemed to be very unpredictable and random. I did get every midi channel button to play a slice of the sample loaded on audio channel 1, but the slices were different every time, even when retriggering the lfo with every trig.

If one of you has any idea if this would be a possible workaround for “chopping” samples and how to set it up, please help me out! If we can get this to work it would be a huge improvement for at least my workflow, but i think a lot of people would like this!

5 Likes

He Sleepyhead, no shit, i had the same idea!!
So, i don‘t have yet an solution but i try to figure it out. It would be a biiig benefit.
If we don‘t find a solution we can ask elektron for a solution?

My point till now

I set up an long Sample, a Piano Intro on Audio Track 1.
Took a Midi Cable and connected MIDI Out to MIDI In
Set up all the 8 Midi Channels to control Audiotrack 1 and to control CC20
Than i tweaked the Value knob on each Midi Channel to a different Value (start point in this case)

If i press the Midi Channel buttons he‘ll play pack the Audiotrack at the Startpoint i‘ve set on the Value page of the Midi track BUT, and here comes the big But :sweat_smile:
If I set Midi track 1 to play back from stratpoint value 20, and Midi track 2 on startpoint value 30 etc, he‘ll adapt the start point to all Midi tracks, even if there is written that the Value is 20, he‘ll play it back at Value 30 cause the last Value I‘ve set up was 30, and so it goes on and on.

So that‘s my standpoint, and actually it‘s the sam thing you experienced right?
Greetings!

2 Likes

Haha good to hear someone else had the same idea! And yes, thats exactly what I did.

So the problem is either the audio track is not receiving the cc value, or the midi tracks is not sending it with pressing the button, only with changing the value. I think it’s the latter. Do you have any ideas on how to possibly solve this issue? I was thinking LFO, but so far it has only been causing more confusion…

Or does anyone else? :grinning:

2 Likes

yeah, let’s hope someone else has some idea. But i’ll stay meditating on that :smile:

Man, i tried everything. Working with Auto Channel, all possible Midi Setting combintion, poly midi cable. Nothing works.
Are you good with Ableton? Maybe we shold try sending cc20 out from a computer with diffrent values to the Audiotrack and see if it will work. Than at least we know if the Midi channels arent sending CC information out.
Can you try it if you got some time left?

reaktor blocks

For the people who have done this. Are you plocking the cc20 values or just setting them as the parameter value for the track?

I’m setting it as a parameter.
If i put in a sequence on the midi channel and parameter lock different values, he"ll do it, but that"s not the point. We want the midi tracks to control different parts of the sample when we hit them (fake slicemode).
Cheers :smiley:

Interesting. I’ll be keeping an eye on this thread!

1 Like

Same, very interested in this. Dummy patterns everywhere gets old fast!

I don’t really use midi on the DT yet, but just a quick thought while I’m here…

It seems to me that the CC values are sent only when there is a trig. So, if you want to fake slice mode, you could:

  • put a trig on all steps, on all midi tracks
  • mute all the midi tracks
  • hit play
  • unmute the midi track with the slice setting you want
  • quickly mute it and unmute another one etc.
  • if you want to change the speed at which the slices are triggered, you just have to change the pattern scale.

That could work, right ? Or create a midi mess, I don’t know haha.

1 Like

Some great ideas guys, i’m trying the parameter locked unmute thing tomorrow, you could even make the midi channels loop a single step i think…

Another method i thought of is:

Set the lfo to trigger once if you press the button (so it will function like an envelope) set it to a square wave and adjust the phase so it wil only send the second half of the wave. Let the lfo control cc20, and make it really quick. This way, it should theoretically send the depth of the squarewave as the cc20 value once, so that the depth of the lfo per midi track will determine the start point.

I havent tried this yet… i think in my previous tries i set the lfo speed too slow, causing all the midi tracks to send different lfo values to the audio track at the same time, probably causing the totally random slices that came out. Setting the lfo to trigger very quick and only once could work… ill also report back tomorrow, but i honestly fear were really close to a solution but cant get it to practically work :frowning:

1 Like

yes, this is intersting things

Tried, and both failed :frowning:

The mute method kind of works but is unworkable in practice. Setting a trig on every step causes it to repeatedly play the sample from the start point unless you quickly mute it again, which is almost impossible to do at 90 bpm, using less trigs makes it impossible to feel like you’re actually playing the sample instead of unmuting a track.

As for the lfo thing: It seems like as soon as you send more than one LFO to the same cc value on a single audio track, things start going mayhem no matter the settings.

Nothing left to do but hope and pray Elektron implements a slice mode, or at the very least a way to zoom in on the sample when editing the start/end point.

2 Likes

Damn… Well, you tried ! Back to the dummy patterns method.

But whatever, I find the real caveat of the DT when beatmaking is the fact that you can only preview 8 slices at the same time, which is def not enough when you’re into microchopping. A slice mode with adjustable in / out point for each slice would be top notch.

1 Like

Microchopping is me!
I not using midi at all with DT
but gets great microchop from
set sample in/out point s
then rolling on the encoder I am
when in record mode. Slices up
strange yes, not control yes.
great micrchop experiments yes.

Is not what you want. Know that.
but is microchopping goodness, fam!

also love would a slice mode!

1 Like

Haha don’t worry, I still microchop all the way… but the long and hard way. Even pondering if I would not be better just going with my old school mpc500 for sample chopping duty, then trig the slices from the DT.

1 Like

same here.
i’ll make a ticket and ask Elektron, maybe it could be a bug.

I asked and i got an answer very quick (that is support):

„ I read the thread, I don’t think we can consider this a bug. If each trig sent also updated MIDI CC values there would be a higher risk of the MIDI bus getting full, so that’s why it’s implemented the way it is. It does unfortunately mean that the workaround you want to do doesn’t work. „

So i guess it‘s clear, lets find a workaround for this :joy:

1 Like

Thanks for asking them! I think we got really close to a solution.

I really do hope they add a slice mode and won’t try to keep the digitakt simple to make sure it doesn’t keep the customers away from the octatrack. To me the absence of a way to slice samples is the single thing keeping the digitakt from being the one sampler to rule them all. if they add this feature i’m buying another one to keep in a box, so I can still make beats on it when i’m 80 years old :grin:

2 Likes

I still am thinkin about this, but i did not come to any solution.
At last, i think, it‘s a good to revive this topic.
Maybe the amazing people at Retrokits have any thoughts on this with their RK 002 cable? I just read about DUY

Greets