Pickup machine double tempo


#1

Helloo

Currently setting up pickup machines for live looping. When I set up the first loop and sync to the loop, the expected tempo is double what I want.

Doing slow tunes around 80bpm, but sync tempto says 160.

Anyone experienced this?


Pickup machine doubles tempo
#2

I haven’t experienced this because I always make my loops with the sequencer running first, using qrec for perfect loops that are multiples of the pattern length. I can see how this could happen though.
First, is making the loops with sequencer going like above an option?
If not someone else may have a better answer but maybe after you record the first loop and before you do pickup sync, jump into the audio editor attributes page and change either the bpm or trim length…
OT’s tempo guessing algorithm uses a base range of 85 to 170 bpm, so since 80 is just outside this range, it thinks your at 160…


#3

I’d glossed over this stat from the manual, but i’ve read many comment on the guess being off by their measure at any rate

So fwiw, expanding on the comment above, here’s the text from the manual (although it’s not all directly applicable to PUMs)

The tempo guessing algorithm analyzes the sample filename for tempo
figures, checking if the initial guess is off by a factor 0.5 or 2.0. The 
”normal” BPM range the Octatrack uses to make its initial BPM guess
is 85 BPM-170 BPM. If you have loops with tempos outside this range, 
it might be a good idea to put the BPM value in the filename. Typically, 
a 70 BPM loop is initially loaded as 140 BPM loop, but if the number 70 
is found anywhere in the filename, the octatrack will use 70 BPM
instead. Similarly, if 280 is found in the filename, the BPM of the sample 
will be 280.

#4

It seems that I experienced the same behaviour: At tempo 80 the pickup machine recording sets the BPM to 160 and doubles the length.
Motivated by the tempo range stated above I checked different tempos and found that at exactly 80 this behaviour starts (and stays for lower tempos, I assume). Solutions are:

  • Choose tempo 81 or higher
  • Set rlen to 64 (it works here with qrec = 64, haven’t checked other combinations)

It is a pity that this powerful machine has these undocumented features which are not wanted for everybody / in all cases and we cannot expect any updates. Would be nice to switch this behaviour off. But as long as I find workarounds which makes everything stable I am happy.

BTW I haven’t checked if there is a higher limit, too.

Edit: Another undocumented feature or bug (or however you call it) is the fixed ratios of lengths. I am using rlen = max, qrec = 64, qrec = 64, trig = one2.
I can record 64, 128, 256 (or 512, haven’t tried) steps. These are the length ratios which are available in the src page of the pickup machine (I have set it to off everywhere). The risky thing is, if I hit the play/stop (rec2) button to finish the recording and change to play mode of the machine, the tempo is changed if I am doing this between 128…192. It is not possible to have a record lenght of 192 (why not?). The length is set to 256. There is some logic behind this, but in practice I would like to deactivate this. As 64 steps give me enough time to wait for the next window, this is OK. But this is another thing which prevents the pickup machine to be a fool proof and robust live looper.


#5

I am trying to you the pickup machine as a guitar (and other) looper. And as long as the sequencer is runnen and I have the quantize option set, everything is ok.

but now I’m playing a song at 70 BPM, and after recording with the pickup machine, the OT changes to 140 BPM. Biggest problem here is that I have a digitakt slaved to the OT which has the whole song in 70 BPM, so keep on working in 140 BPM is not an option here…

I have searched around but have not really found an answer.


#6

The tempo guessing algorithm analyzes the sample filename for tempo figures,
checking if the initial guess is off by a factor 0.5 or 2.0. The ”normal” BPM range
the Octatrack uses to make its initial BPM guess is 85 BPM-170 BPM. If you have
loops with tempos outside this range, it might be a good idea to put the BPM value
in the filename. Typically, a 70 BPM loop is initially loaded as 140 BPM loop, but if
the number 70 is found anywhere in the filename, the octatrack will use 70 BPM
instead. Similarly, if 280 is found in the filename, the BPM of the sample will be 280.

You don’t have that problem with Recorders + Flex.


What's the most efficient way to get a sample in time?
#7

Yes, I was thinking about going with flex machines, but I really need the overdub. mostly for catching delay and reverb tails. this isn’t possible with flex machines…

I guess I’ll have to go try and change everything in the Digitakt to 140 bpm… and I have a few of those, at 60 or 55 bpm.

I understand each machine has its limitations we have to work with, but the simple feature of turning off this ‘master’ thing would have made so much sense.


#8

Sh*t I can’t do this either because all my delay and other time based effects are stored for this tempo. a dotted eight would have to become a dotted quarter, which might be a problem…


#9

Overdub is possible with Flex, a recorder can record it’s recording and inputs > overdub.


#10

ok, I’ll have to dig in there then… is it also possible to set the recording length manually with the flex? so I can hit record with my footswitch, and hit it again for playback with no predetermined length?


#11

Yes with these settings (rec quantized).

QREC 16 = 16 steps rec quantize.
Maybe PLEN (pattern length) is too long if you want trails only.

For overdub with Flex, AMP VOL has to be set at +63 (or +12, not sure). Not super easy to setup.
I posted it somewhere!
:sleeping_bed:

https://www.elektronauts.com/search?context=topic&context_id=75937&q=%40sezare56%20overdub%20flex&skip_context=true


#12

All right, I got it to work like this:

  • monitor AB on 127 in mixer page
  • inputs track x to AB and cue (with the track being cued)
  • One shot record trig (arm for record + arm again for overdub)
  • playback trig microtimed 1 notch backward

I have to be in record menu to arm the one shot record trig. Is there a work around for this? I also made work with normal record trig’s, but then I have to delete the trig after the overdub, which also is in record menu…

Is this the easiest way? Or is there some more tricks to make it behave like a looper? The only thing I miss is undefined loop length, but I can live with that.


#13

You can arm One Shot with YES, Grid Rec off.

A trick I found : use patterns. Go back to previous pattern undo. It records all the time, change pattern to stop recording. Defined length. Realtime monitoring with fx (DIR not needed)

Pattern 1 :
T1 Rec trig + Flex trig
T2 Flex trig
T3 Flex trig
T4 Flex trig

Pattern 2:
T1 Flex trig
T2 Rec trig + Flex trig
T3 Flex trig
T4 Flex trig

Pattern 3:
T1 Flex trig
T2 Flex trig
T3 Rec trig + Flex trig
T4 Flex trig

Pattern 4:
T1 Flex trig
T2 Flex trig
T3 Flex trig
T4 Rec Trig + Flex Trig

Pattern 5:
T1 Flex trig
T2 Flex trig
T3 Flex trig
T4 Flex trig


Recorder buffers for looping and live sampling
#14

Awesome! Very cool trick. Will try tonight :slight_smile:

I also have my midi foot controller arrive today, I was thinking if I can use this to ‘footally’ press quantized track record. Then I only need to press once for record and once for overdub.

I try to keep it as simple as possible in the OT because I use a lot of improvisation on tracks (this is where I need the loops) and I can easily do very different thing when I play a song twice…


#15

I can’t! :smile:
As I use several recorders for realtime mangling I need to find a specific workflow.
I think we’re getting of topic. Maybe Flex with Overdub is more appropriate?
What is your foot controller?


#16

Off topic indeed… I order the source audio soleman. It has different modes, switchable with an auxiliary switch. One mode is for presets of my midi pedals, and another mode can assign any (and multiple) midi parameter to the switches. So in there I can setup cc notes to control the OT, and in the first mode select presets. All in 1 pedal :slight_smile:
But this is off topic too.

On topic: I found 2 solutions for the initial problem.

1: double your bpm so it’s in the 85-170 range, if you’re not syncing external gear with dotted eight delays or stuff like that…
2: use a muted master pickup track and set tempo back to normal. Make sure the dummy master is playing before recording other pickup machines, and only if you don’t need overdub.


#17

1 is pretty obvious, 2 seems a good idea, not ideal.
I have a 3 with Midipal / Midibud, which can divide / mutiply clock tempo.


#18

Hmm never went into that territory. Have to check that out! So I can set the OT to 140, and this thingy will convert to 70 which is then sent to all my other gear? This seems to be what I need!!!


#19

Yep. Maybe RK002 or other midi processors can do it too. Midipal as several build in interesting functionalities, such midi dispatcher = 1 midi channel per note > make Octatrack poly, midi delay with pitch / feedback…


#20

Checked the rk-002 and ordered :slight_smile:
You saved my workflow! Many thanks for that.

Too bad the rk-004 is out of production, this would have solved e few midi problems in 1 box.