Octatrack OS Bug Reports


#124

Nice, I’ll install that and mess with it tomorrow. Doesn’t seem to apply to the issue I had but at least I shouldn’t have to worry about the UI Not Tested bug showing up now.


#125

List of changes from Octatrack DPS-1 OS 1.30B to 1.30C

Bug fixes

Fader position would sometimes not be stable on some MKII devices.
The device would sometimes report ``UI NOT TESTED’’ at startup, and then respond incorrectly to keystrokes. Does not apply to MKII devices.


#126

Fader position is still a little out of sync for me on my MKII. While in scene A, if I change the rate of a sample in scene B the OT will adjust the pitch of the sample in scene A slightly. Leads me to believe that the fader isn’t able to move 100% into scene A, which is an issue.


#127

Did you do crossfader calibration in test mode ?


#128

Thank you! I was not aware of test mode. The crossfader was off slightly. I reset it and everything’s working as it should now. Phew.


#129

So the other day I was working on a project that had one bank using three parts. At one point I copied and pasted some of the older patterns into different locations in the bank, always playing them back to confirm that I had pasted the right one before clearing the source I copied from, and then spent some time working on a few new patterns. About ten minutes later, I went to select a different pattern to work on and discovered:

-ALL of the older patterns that I had moved earlier were now gone
-I was now working in bank 2 not bank 1
-Two of the three parts were now back to their default settings and names (the currently selected one hadn’t changed, though).
-Bank 1 now had two patterns and two parts that were from a completely different project I haven’t opened in at least a month
-Even though I hadn’t saved since these changes showed up, reloading the current project didn’t revert them to the last saved version
-Today, I tried reloading the project from the card and I get a parse error

This is the second or third time I’ve gotten parse errors when reloading a project but I’ve never had the actual contents of the project get jumbled up. I’m using a SanDisk Extreme 64gb card but the first time it happened was with the factory card, and it has happened with OS versions 1.25h, 1.30b and now 1.30c.

Any ideas? I wouldn’t even begin to know how to replicate it for a support ticket.

EDIT: in the mean time I’m going to reformat the card and copy my files back on, just to be on the safe side.


#130

I’ve noticed when switching banks there’s always card activity, like only the current one is stored in ram and the OT needs to read the next bank from the card, and I imagine save the one your switching from…
If your getting parse errors and missing a bank, it leads me to think corrupt cf card issues…
That’s my train of though and speculation…


#131

That’s the weird thing, I wasn’t missing a bank, the changes I made since booting it up had somehow jumped to a new bank, all previous editing done before that session were gone, and the bank I had been working in before whatever happened happened was replaced with a bank from an entirely different project. And all of this happened without stopping the sequencer or interrupting my workflow in any way.

The last time I had a parse error(about 6 months ago) it seemed to actually be propagating from the project in working memory, not the saved version, in that it was fully working but when I saved to card, any saved versions were corrupted, but the one in memory was still fine. Only saved copies of it were corrupt.

Also, just checked the log and the specific file that was generating the error in this case was the .work file for bank 12 (which I didn’t use at all) so it’s definitely something weird going on with banks. Looking at old logs, the previous times I had the problem last summer were the .work files for bank 12 and bank 9, neither of which I had edited at all.


#132

That’s super weird and scary… My OT’s never flinched, it’s been a rock on 1.25H and I’ve never had a parse error or anything weird with the card, it’s never frozen, and I’ve never lost anything…
Being kinda ocd, if I started getting parse errors or something, I’d probably trash the project, get a new card, empty reset, and build it back, but I’m a bit of a must make sure everything is perfect with minimal chances of future failure type…

All of this may have nothing to do with the new OS, it’s probably card stuff, but from reading this and some other funny business on here I think I’m gonna hold out for the D version…


#133

Yeah, I have no idea how I could have done it accidentally. I bet it’s the card but I hope not, because it’s only a few months old and these things aren’t cheap. If it happens again I’ll swap the factory card back in.


#134

Didn’t use the OT for about 10 days over the holidays. Turned it on today and a lot of the record setup setting were different than when saved. Record sources that had been assigned to inputs, main and cue are no assigned to other tracks, mostly tracks 7 or 8, or have no source selected. The track that had the source set to Input CD last time I used the OT is now set to Input B. Reloading the project didn’t fix anything. Loading the template version of the project (same as the working version but with some effect parameters set differently and the patterns empty except for the trigs needed to activate thru machines and a couple other things) didn’t fix anything - the record setup settings didn’t change.

I’ve got no explanation for why this happened. The files on card don’t appear to be corrupt (at least they aen’t generating errors), the setting shave just changed since the last time the OT was on. Very, very strange. I’m thinking it’s time to do another full backup of my card and then wipe the card itself (maybe do a full diagnostic and low level format from a computer before formatting it in the OT, just to be sure) and start from scratch.

This is a 6 month old Sandisk Exteme 64gb 120mbps UDMA 7

Can’t afford to get a second one to rule out a bad card, right now unfortunately.


#135

Yeah, so the OT is completely messed up. I’m randomly losing data in the record buffers, files will come back corrupted from the card regularly, sometimes the track recorders won’t record from inputs C and D, old projects have their record parameters scrambled, different effects assigned or different flex slots assigned compared to when they were saved, XLV no longer works correctly, resampling sometimes (but not always) results in a feedback loop, even though the settings are the same in either case, it spits a bunch of junk MIDI CC data out when I first play a newly loaded project, sometimes (but not always) the lights on inputs C and D flicker even when there’s no input. I wouldn’t even know where to begin a bug report. It was working perfectly two weeks ago and now it’s completely unusable and the only thing that happened in the interim is that I didn’t use it. I’ve got no idea where to even start.

Anyone have any ideas what might be wrong? I’ve got a show coming up in a couple of weeks and this is a huge problem.


#136

Sorry man, brick report… :joy:

I’d probably get a new cf card and then do an empty reset before using it, or backup your card to a computer and format the card, but I wouldn’t trust it…

You could try demo mode and see if that functions properly, I think you just turn it on without a card in…
There’s the test mode in early start up as well to see if it reports errors…


#137

It functions properly so I’m hoping it’s the C.F. card. I started a new project and so far everything is normal (also the output is significantly louder that it was before, even though the settings are identical). I wonder how likely it is that the data has been getting progressively more corrupted without the OT actually recognizing that it’s corrupted, seems unlikely but possible - I’ve experienced similar situations with Arduino based stuff where Some kind of junk data would get introduced inti memory because of a bug and it just made things not behave quite right even though they still fundamentally worked.


#138

Is the current project that loads when you boot the OT stored on the card, or is it in RAM that’s powered by the internal battery, or what? I ask because it has been pretty cold in my apartment lately, down into the high 50s (Farenheit) at night, and I know cold isn’t that great for batteries.

EDIT: jsut checked the log before I started backing up the card, and the file that was corrupted when I saved and reloaded earlier was another bank, 13 this time. Every single time I’ve had an issue with a corrupt file it has been a bank, either 12, 13 or 16. There have been at least four of them so far since I got the OT (I’m not sure exactly how many because some of the old logs were deleted).


#139

2 types of files on the CF for a project.

The loaded files at startup are .work files on the CF, they are auto-saved.
.strd files are saved files, created after saving, loaded when you reload the project with the Reload function.


#140

Not sure why I asked that to be honest, it’s right in the manual and I read about it before I even had the OT, heh.

I’ve backed up everything, wiped the card and reformatted on an external computer instead of the OT itself this time, and am going to start from scratch since there wasn’t much on there that I couldn’t recreate quickly - I haven’t been using the OT for complete tracks much, more as a live improvisational tool, so there were mostly variations of a couple projects that I’ve been refining for that purpose. Easy enough to just rebuild them in their most recent form.

Hopefully that will solve everything, it seems to be fine so far.


#141

Hi there. Not sure it was already reported, when i’m using track+stop to stop a specific track, my OT stops the recorders, messing up every flex :confused: Everything worked perfectly before the new OS. Anyone else has this one ? Sorry if it’s been discussed before, i didn’t read the whole subject i think it makes me unlucky to read bug report threads ^^


#142

Hey guys,

When I want to create a new scene, the OT seems to not respond to my changes.
I have try to create a scene on another project I have created and it’s working perfectly, it’s only happening on this project I don’t really know why…
I had the same deal when I was switching parts while looping with the pick up machine, since I had no answer from Elektron after my ticket, I decided to give up this option and now I’m using the flex recording buffer.

Is anyone had issued this kind of similar problem in the past?
It annoys me so much and I really hope to find a solution or my project is fu**ed…\

Please don’t tell me that there is no solution :disappointed_relieved:


#143

Had a weird one today, on my mkI running OS1.30c I have had a project loaded which was created in 1.25 since before the update, so I was working on a simple 1 bar pattern, I loaded a flex BD sample into track 3 and laid out trigs on 1,5,9,13 but the sound wouldn’t play, I checked to see if I could preview it in trim screen but it still wouldn’t sound, I made sure that the track wasn’t muted or otherwise turned down somewhere, no midi was connected - emliminating the possibility of it being caused by some external CC, and when playing the pattern instead of the leds for track 3 flashing in time with the trigs, there were a couple of extra flashes between the third and 4 trig.

Anyway I gave up and created a new project, loaded up the same sample and did everything exactly the same and it all worked as expected.

I thought it worth mentioning though as it could possibly be a bug when adding stuff to projects created in earlier versions.