Octatrack OS Bug Reports


#103

Regarding the UI NOT TESTED bug, I’ve come to a quite stupid solution : switch on the OT, the bug occurs, the OT freezes… push every single button on the machine and voilà ! You can use the OT again without switching it on and off several times.

Seems like the UI test doesn’t process to the end for some unknown reason.

Now waiting for Elektron to give us a correction for this… and the rest ! :stuck_out_tongue:


#104

Maybe you can do this (touch all buttons) in test mode…


#105

Getting UI NOT TESTED on most boot ups with 1.30b on a MK I. Pushing every single button does unfreeze it but the functions are mixed up, as someone said above, Project turns on the Metronome. I need to re-boot a couple times to get it working. Bummer.


#106

Just out of curiosity, people who are getting UI NOT TESTED - how old are your Octatracks? I wonder if it’s either related to a specific hardware revision or something more esoteric (maybe there are ribbon connectors that get a little oxidized with age and cause enough resistance to make the test fail but not enough to actually keep the controls from working, or a socketed IC that needs reseating eventually, or something like that). Obviously there’s a bug involved since it didn’t happen before the firmware update, but it seems plausible that the bug could be triggered by a specific hardware revision or a specific run of parts or something. Maybe some hardware revisions aren’t detected correctly because of a bug, and fool it into thinking it’s testing a MKII UI? I don’t have any idea, just speculating.

I got mine new in January or February of this year. I don’t know the exact date of manufacture but it has the last finish variation. I’ve been running 1.30b since the day it was released and so far I haven’t had the UI NOT TESTED bug show up. I haven’t had time to use it as much as usual since then but I’ve booted it at least once or twice every day since 1.30b was released and no trouble yet.

EDIT: also, as far as the buttons getting mixed up, I wonder if the order you press them in when you’re pressing them all to make it finish booting changes that.


#107

What a nightmare. Hitting that on switch with crossed fingers now


#108

Same here, I am not getting that message – my MK1 is from early 2011.


#109

Definitely following this closely. I have my eye on a 2nd hand OT from late 2010. Would hate for this issue to happen.


#110

Has anyone who’s having the problem tried downloading and flashing the 1.30b firmware a second time just in case there was some kind of corruption? Everything I’m suggesting is a long shot but it’s still worth ruling out.


#111

I also ran into similar issue on 1.25H several times. I had a one-shot record trig on a track, which suddenly stopped working though I pressed FUNCTION+YES (and track+yes in record mode, too). Only a reboot helped to solve the problem.


#112

Me neither. Third hand MKI, I don’t know her age, minimum 5 years. She was adopted.


#113

Any Update on the “UI Not Tested” Problem?
Has anyone tried to re install the firmware?


#114

Mine is a first hand MK1 (2012)

I’ve managed to downgrade to 1.25G as I don’t have the 1.25H version of the OS.


#115

If you were willing to upgrade to 1.30b again and see if the problem came back that would definitely help narrow down whether it’s a bug in the firmware itself or something that went wrong with the update process on some machines, but I definitely get why you wouldn’t want to go through the hassle of that.


#116

For those with UI NOT TESTED issue, I’d be interested to know which OS update method they used: BIN or SYSEX?


#117

BIN here!


#118

BIN here, no problems.


#120

Just hit my first 1.30b bug. I won’t have time to try to replicate it and submit a ticket until next week.

I brought the OT and Tanzmus along for the holiday so I could practice with the Tanzmaus and get my default project reorganized so it would be fully integrated into the live setup by my next practice on Tuesday. So the only thing hooked up to the OT right now is the Tanzmaus. Right not I’ve got about half a dozen patterns and scenes and two parts that load up by default as a starting point for the live duo I’ve been working on. I don’t use parts much these days, I’ve basically got part 1 geared toward more rhythmic stuff using a couple external synths with thru and neighbor machines processing them, and part 4 is mostly flex machines and is mainly for more ambient stuff, with just three thru machines for the external synths and Tanzmaus I’ll be using live. I spent about 45 minutes jsut now jamming with the Tanzmaus and internal sounds, with som patterns using part 1 and some using part 4 and everything worked fine, but a couple minutes ago I manually switched parts with the sequencer running and this happened:

The buttons all worked still and the display was fine and the sequencer kept running, but all audio and midi output stopped (I was only sending clock and transport to the tanzmaus, but I suspect MIDI notes weren’t being output either, I jsut don’t have the synths that would have been receiving them with me), and the LEDs for inputs C and D (what the Tanzmaus was connected to) got stuck on yellow and stayed yellow even if I physically unplugged the patch cables from them. The only way to get it back to normal was to restart the OT, and after that it worked fine but I didn’t mess with it much and came here to post this instead, while the details were still fresh in my mind.

If avoiding it happening is just a matter of not manually switching parts manually while the sequencer is running that’s OK for the short run for me since that’s not important to my workflow right now anyhow, but if it happened live it would be a big problem, especially since the OT is the master clock for the other guy’s entire Eurorack system too. And also obviously it’s not a bug I’d want to have to worry about avoiding permanently, so hopefully it will get fixed in an update soon along with the rest of them!

I should be able t really sit down and figure out how to replicate it next Wednesday, and I’ll post more details once I’ve done that and submitted a formal bug report to Elektron.


#121

@Supercolor_T-120 - related to this, perhaps? Octatrack MK1 Visual and Pick Up Machine bug


#122

I was thinking it could be related but the symptoms are different so it’s hard to say. For me, everything is still responding like it should but the audio and MIDI i/o seemed to be frozen so nothing would go in or out and the input LEDs were stuck on. But all of the controls I tried before I restarted responded in terms of ebing able to change screens, change scene, change parts, tweak parameters and having the screen and front panel LEDs (except the input meters) act like they should - there was just nothing actually coming in or out of it. Like the interface was working but the audio and MIDI engine was frozen.


#123

New Os OT 1.30C, bug fix release, for those interested!https:
//www.elektron.se/support/?connection=octatrack#resources