Octatrack OS Bug Reports


#43

Help. I just updated the Octa, went from clearing flash to this. Update file on memcard. I can access function page, test passes ok but machine refuses to progress from here. Any suggestions MUCH appreciated.


#44

After memory card upgrade failed I dug out my iConnectivity audio card to do it via midi and this happens. Two LEDS slowly light up and then the error message on screen. This is a second hand octatrack and haven’t needed to update it before but I have managed just fine with my 3 other Elektrons and made no error? Any ideas before I jump on support?


#45

Sorry, I can’t help, I worked for me with .bin file.

I have weird behaviors with parts.
Exemple : If I record with part 1, it takes part 2 rec setup settings !? :zonked:

@alex3368 is that your problem too ?


#46

I think I found out what’s the problem :
The Rec Setup keeps last tweaked settings, even if you tweak it in another part.
Don’t know what to do with this, it seems to be a bug.


#47

Could someone confirm ? @avantronica, should I fill a support ticket ? How ?


#48

I can take a look in about 20 minutes, I haven’t been using parts much at all lately so it’s not something I would have stumbled on since I updated.

If I’m understanding your description right, I should start a new project, go to part 2, change some settings in Rec Setup, and then check to see if the changes are still there when I switch back to part 1. Correct?


#49

Thanks, correct.
To check, you have to listen the recording. Parameters won’t change visually in part 1.
For tests, I set In AB for part 1 and In CD for part 2. I used a rec trig.
It would be interesting to test it with previous Os, H or E.


#50

I just tested this, not having the same behaviour, very odd. This was an old 1.25h project though.

Edit: Actually have not tried any new projects since the update. :zonked:


#51

Maybe you can test with a new project ?
I use Thru for pattern 1 part 1 track 1 and a Flex playing the recording on pattern 2 part 2 track 1.


#52

For what it’s worth, I have about 3 hours of time in on 1.3b and haven’t hit any bugs so far, but that has all been using template projects I made in 1.25h, I haven’t started a new project since the update. I haven’t done any recording yet, either, mostly MIDI sequencing and playing back flex samples I already had in the project from before.


#53

edit : this was another problem above, solved.
Rec setup problems are not solved.

I found out why I had a Thru on a Static track :
After part change, you need a trig to make a new machine effective. In previous patter/part, Thru had trig with INF hold/release, so Thru was still active.

As @Open_Mike remind me, Silence Track parameters can help.

I also found out why I had midi notes without midi channels nor notes : in previous pattern/part, notes were set to INF, with arp.


#54

I think you need to specify the exact minimum steps to recreate
I read you said parts were forgetting the recording settings, so I just tested that in a new proj

It works fine for me if I switch parts whether they are saved or not, I tried two saved parts and one unsaved and the relevant settings were kept fine when switching between all parts

Can you be very specific about minimal steps to reproduce

edit:you just posted - are you okay, found the issue ?


#55

One bar patterns.
Pattern 1, Part 1, Track 1 :
A trig with Thru
Rec INAB, Rec trig, Rec Len 16

Pattern 2, Part 2, Track 2 :
A trig with Flex, Recording 1
Tweaking Rec Setup INCD, LEN

Go to pattern 1, listen recording in pattern 2.
Tweak Rec settings again, go to pattern 1, etc…

Pattern 1 part 1 keeps pattern 2 part 2 rec setup tweaked values.
I reproduced it in 4 new projects.


#56

At the first few attempts it seemed to be playing the recording1 buffer captured from AB fine when going into pattern 2, but messing with those recording settings in part 2 did eventually result in the recording1buffer being full of CD content although there is no recording trig in the second pattern - so I guess you’re seeing this ? - I do think you absolutely need to detail the minimum steps to replicate 100% so that there’s no hit and miss - it does look like something’s wrong on the face of it, but I haven’t thought it all through - write out your detailed step by step so someone else can try and then send to support if it’s still not right


#57

I didn’t mess with the rec settings too long but I haven’t been able to replicate it yet.


#58

Hi everyone,

I updated the OS to 1.30B and now, when I’m switching on the OT, I have an error message : “UI NOT TESTED”. The current project is loading fine but the UI is frozen and I can’t do anything. It doesn’t respond at all.

I have to switch the machine on and off 3 times to be able to use it again.

Any clue on this ? Anyone has had that bug too ?

Thanx a lot !


#59

On 1.30B on my Mk1, roughly 50% of the time, I have been getting UI NOT TESTED screen if a card is not inserted, or if it is inserted the screen looks OK, but everything is locked up :frowning:
Also, this time, when it has finally booted, all the menus are screwy … i.e. Fn > Mixer (project) turns metronome on and off instead of the project menu


#60

Just saw your post, same problem here


#61

I am 100% behind you that you’ve found a bad bug

I had another play with a slightly more portable/controlled setup

Pattern 1 Part 1 T1 Flex uses muted T5 on SRC3 as its feed to play Recording 1 (rec len=16)

Pattern 2 Part 2 T2 Flex uses recording 1

Both have a muted T6 playing a different sample

If I tweak the record setting for T1 Pattern 2 Part 2 on Recording page e.g. Len=3 or SRC3=T6

and then jump back to Pattern 1 it will load Part1 and show the right previous recorder settings but it will have adopted one or both of the tweaked values - occasionally, it may be OK but mostly it borks it for me, it also can be recovered in pattern one by saving the Part (no changes required !!) or reloading, so it clearly has a different working part from the one which is shown and saved - i.e. bug

To make matters worse, sometimes just changing to pattern 2 it would not even consistently play the correct recording1, it would have somehow erased the recording1 buffer even though it was never tasked to do so (pattern 2 has no rec trigs for any track) (may be due to changing during recording though)… so I think there’s a bad parts bug underlying all of this … saving both parts just before pattern hopping was the best way to make it play ok, but the tweaks on pattern 2 part 2 t1 rec-setup would be fed back to pattern 1 part 1 t1 even though they were not shown !


@sezare56 I’d suggest submitting a Parts bug report ticket with your simple steps (or mine above) to support unless @simon and the support team know about this already, I think there was something recently on the MKii that may or may not relate to this issue, but it clearly needs attention on the MKi


#62

There was indeed a Parts bug in the initial MKII OS release:

I imagine Elektron’s got the iron still hot with another fix on the way.