Octatrack OS Bug Reports


#184

Which 1.30 ? A B C D ?
Do send notes to OT ?
Total freeze ?


#185

Yeah total freeze. and version D


#186

Where have you got 1.30D from? The latest official OT firmware version is 1.30C.


#187

Another issue with internal track recorder which is a bit similar to that I mentioned earlier.

Clean project, one pattern, 64 steps length.
Some continuous sound on T5.
T6 set to rec. buff. #6. Rec. len. is 16 steps, no loop, src is T5. A recorder trig on the first step of 3rd page, and a play back trig on first step on 4th page for immediate playback of the recorded bar.
It works pretty well except when touching the rate knob during the recording phase. Even if I set it back to +63 before switching to the playback on 4th page, I hear no sound from T6. However moving the playback trig 1/384th step forward on the 4th page, it plays back the previously recorded sound even if the rate knob was moved while recording.


#188

copying and pasting between static slots does the same thing to the destination slots

Save project & reload project is easiest workaround when it’s all your slots, otherwise go into editor on affected slot and func+yes to preview & it will come back

how can bugs like this be around SO LONG?


#189

Pre-installed.


#190

Probably a known bug but my OT was hard locking all of the time. Removing the USB cable 100% fixed it. MK1 + 1.30C.


#191

I down,oaded it i think? from the site?


#192

Probably pre-loaded on the Octatrack.


#193

I continue the story.
My three pattern setup uses two parts. B1 with P1 while B2 and B3 (the playback pattern) with P2. The T5 is a static machince in both parts but with different samples.

After running into the playback issue I described in the post this one replies to, and just opening the affected T6 in editor to check its content, and then back, and then reloading both parts, the B1 (with P1) plays back the sample on T5 from P2. Really. Even if I press T5+PLAY. But if I open T5 in the sample editor or just double click on T5 and then back, I get the expected sample back on B1.

CRAAAAAZZZZZYYYYYYY!!! :slight_smile:


#194

OctaMKii

when controlling pickup machines C+D monitor level the MIDI CC58 on respective channel changes only the numbers on the screen, but instead using the corresponding octatrack dial button changes it for real. MIDI only changes on screen with but with no real effect.

anyone?


#195

I had similar bugs, Rec Setup settings not updated when changing parts…
I can’t tell if it was already the case befire 1.30x.

A workaround would be to share same settings with the previous pattern, adding rec trigs or not. It worked for me, it was the opposite, the recording was too short because of previous setting.


#196

Unfortunately this issue implies other ones, too. If you place a playback trig for the recorder buffer at the very next step after the recording finishes (so on 17th if reclen is 16 or on the first step of next pattern if reclen is 64) you can often hear either nothing or strange artifacts instead of the recorded sound. It sometimes really records nothing but other times it records the expected sound but it doesn’t play it back on the play back trig. In this last case it plays back by pressing track+play however :slight_smile:

The other big issue is that OT can mix up even static samples between parts (or between patterns with different parts). I sometimes run into the issue when I hear static sample from the other part (even by trig or by pressing track+play) until I open the sample in editor or just open the slot list by pressing the track button twice. After doing so I get back the the expected sample :slight_smile:


#197

I think I may have found one.
When you cue a fill (down arrow + page), before it executes/finishes, go into “step record” mode. First page is visible, but if you hit page button for the next, everything disappears until fill is over


#198

It seems that I managed to find a way to reproduce the issue of mixed samples between parts (with firmware 1.30C).

  1. Choose an empty bank (let’s say C), and prepare two patterns (C01, C02) using Part 1 and Part 2 respecitvely like this:
    1.1 On C01 (Part 1) set track T5 to a static machine and assign a sample to it (let’s say P1-sample.wav). On the playback setup page turn loop mode on. Set pattern length 64. Place a single playback trig only on the very first step of the pattern. Save the part (Part 1).
    1.2 Assign Part 2 to C02. Set track T5 to a static machine, too, and assign a different sample to it (let’s say P2-sample.wav). On the playback setup page turn loop mode on. Set pattern length 64. Place a single playback trig only on the very first step of the pattern. Save the part (Part 2).
  2. Keep T5 selected. Go back to C01 and press PLAY. You must hear P1-sample.wav.
  3. Continuously wriggle the Pitch knob in order to alter the parts.
  4. While playing C01 (single loop only) queue C02. When it switches to C02 you must hear P2-sample.wav.
  5. Once C02 is over, press STOP.
  6. Go back to C01.
  7. Reload part (Part 1) by pressing FUNCTION + CUE.
  8. Switch to C02. Do NOT reload the part (Part 2) here!
  9. Press PLAY. I expect you here P1-sample.wav instead of P2-sample.wav. However the latter is on the display (which is fine). You should hear the wrong sample even if you stop the pattern playing and press T5 + PLAY.
  10. Double click on T5. You see the sample slot list and P2-sample.wav selected. Press FUNCTION+YES. Now you should hear the expected sample (P2-sample.wav).
  11. Exit from sample slot list and start playing C02 again. You should hear the expected sample (P2-sample.wav).

Would you mind to try to reproduce it on your device? :slight_smile:


#199

Done. :confused:


#200

Interesting…

Replicated?

I’ll try and give this a go if I can find some spare time somewhere…


#201

Reproduced with a new project, a bit simplier :

  • Pattern 1 with part 1, static sample 1, save part

  • Pattern 2 with part 2, static sample 1, pitch 12, save part

  • Play patt 1, tweak pitch - 12

  • Queue and play patt 2, stop

  • Patt 1, reload part 1

  • Patt 2, play : part 2 is not loaded

Not possible to reload it. Pitch shown is +12 but you can’t hear it. Seems related to part 1 reload
after a part 2 played then stopped.
Doesn’t seem to happen without stop.
Same behavior with Flex.

Very quick way :

  • Play Patt 2 (saved part 2)
  • Stop
  • Tweak Patt 1 (saved part 1)
  • Reload part 1
  • Play Patt 2 : no part 2 loading.

Never stop OT ! :grimacing:


#202

Ok, so it seems to be related to part reloading. The tweaks may not affect the issue.

Would you mind to report it on support? I’ve already added my way of reproducing the issue to my support request, but more voice more noise :smiley: