MegaCommand // MCL 4.51

I do, certainly! I have made 150-200 units in total for a couple of years, almost every unit have been very well working and had great look. I offer custom designs with color schemes you can choose yourself, and other options…

1 Like

How can i get more info about this?

Send me a PM and i can fill you in with the details. I am in the process of quitting building, as soon as my backorder list is empty i will only make severely customized units. Not sure if i can take another order, but send a PM and i will check it out. In short, i offer three standard case colors (white, black and silver-gray) and five led colors. Of course i can give you basically any color you want on case/LEDs, but it will be special orders. Also, i have atm two std types of encoders; sifam and the more exclusive Bastl ones (in silver, gold or black aluminium). But as said, PM me!


Can the Minicommand run Megacommand Live?

1 Like

Hello All.
Apologies in advance if this has been asked previously, I own the R&W MiniCommand bought in 2010… scrolling the reIeases I saw that the compatibility with the original MiniCommand hardware has been included as of 2.40.
Please, could you tell me which is the latest compatible release?
Thanks in advance.

The Minicommand does not have enough program memory to run MCL as it is today.

MCL is 240KB, Minicommand CPU can only store 64KB of program code.

Even stripping back many features I was never able to get MCL below 128KB.

After performing some archeological work

The last coded version was 2.11 but likely never compiled or released.

MCL version 2.40 maintained support for the 16x2 display, but this was before the OLED support was completed. The firmware was already too large at this point to back port to the Minicommand.

The code:

Manual + Binary for V2.0:

The old development thread:

I’m posting these out of convenience / curiosity.


Hi Justin,
Do you still have some of these DIY MegaCommand units?

MCL 4.42 released: :alien:


Thank you Justin.

Woohoo finally got access to a 3d printer again. I should have about 3 or 4 MCL’s to sell in the next month or so. This orange is just a test print, testing the organic supports etc. do people want a different color than orange? Gonna put in an order for different colors soon.


MCL 4.43 released: :floppy_disk:

Fixes MIDI SDS sample upload.


Got a few PCBs left, was going to save for my alu cases but delayed i build my normal units. Pm me if interested.


Hello, im new here, but got a machinedrum sps1 from the start. Its the mk1, so yes i found out about the megacommand! What a great looking project. Respect for all the work!
I got one, Now at version 4.43. MD at x.08
But what a hell! Sorry to say.
No good sync anymore,
i can not find the recorded steps in the sps?! I hear them, but can not change it.
Also i can not realtime record in MD?!
It also does nog save a thing i do. (Sometimes, but i dont understand when)
Also some tracks are getting out of sync independently??! YES? For instance, My snare starts ‘walking out of sync’)
it sometimes peers, sometime not. And i did not changed the time or something. Sounds like it struggles with the data🤷‍♂️
And now after tonight?!?!! I can not record anymore??! I don’t understand it? I disconnected all, did a restart. And my MD wont go in to recordmode? And i can not change to a other pattern anymore. Then i have to factory reset before i can do anything?
I have it for 12 weeks now. No love here! I try to check some video’s?! But al are minimal. Asked the guy who made it to help,no reaction yet.
I just want 64steps and probability to work stable. But this takes away al of the fun…

i am really interested in how much of my terror is because of my human error?! :wink:
And if someone can use this stable on stage?!
For now, I would shit myself.
I always hope the diy gets better by time. And mostly do, but now after waiting and testing, i lose hope. Can anyone tell me if you can really use this in a liveset??! Or is it not reliable anymore?!

Im so sorry to drop the bomb here, but i can not believe this works well?
Or is it only the MK1
What are the tricks?! Is there someone how can tell me whats wrong? Or am i right?!
Or was there a moment in updates it worked better? Why are there no videos of it working in a liveset? Or where to find it?

Anyway, im start hating the machindrum because of the MCL. I spend money on it, and it takes me further away of making music than i ever had.
I really hope someone have time to help me, or buy my MCL of me, so i can forget this part.
Thinking about, trying to de-bug this already makes me sad… but if i can use my machine with 64steps and save it, and also in sync, i can smile again.
Or anyone a UW for sell? :wink:
Sorry for the rant, thanks for your time.
Love the project, just gate my life ;p
Have a good day, :v:

try setting turbo midi on the mcl to 4X

Hey, thanks!
I try it now… nope. It starts sometimes on time, mostly totally off…
I wish i could send a video. Its crazy. No logic where it starts, somewhere around the first step​:sweat_smile::roll_eyes:.
But this did not change it unfortunately…

Can you list your mcl midi settings?

So problem solve mode:

Does md work in standalone/extended mode as expected?
When it peers with MCL do both EXT+Classic LEDS come on?
Have you tried the two midi in out connection with different cables?

Midi settings (for basic connection on port 1 IO removing port 2 stuff to avoid conflicts) which are working for me on mk1:

TURBO 1 : 4X


Yes, here we go;
(I got my external midi-in comming in to midi2, machine connected tru midi1 in/out)

Port config: turbo 1,2 and usb on 4x
Driver2: Elekt
Ctrl port 2
Ps, when i am in this menu,and want to leave it by pressing ‘no’, it freezes and peers again? Than i can press the ‘no’ again and go back.

Sync: clock and trans recv: both on 2
Sends all off

Route: midi1 fwd: 2
Midi2 fwd: off
Usb fwd: off
Cc loop: off

Program: prg mode: basic, but als tried adv
Prg in/out: — —

MD midi: chro chan: int
Poly chan: - -
Trig chan: int

I think this is it
:slight_smile:thank man for checking with me!

let’s see if we can get it peered and synced standalone before introducing ext midi first.

try changing sync: clock and trans to 1

port 2 should be X1 and gener if it’s just a midi controller.

if you were trying to launch it via midi from port 2 this would’ve caused issues unless it was an A4 or MnM (elektron device with turbo functionality)

Oke, i just did,
I press play, and now i hear sounds, but there is nothing in the stepeditor.

Ow and i use an analog 4 to start :wink: