Machinedrum SPS1-UW X.10 Released [ Unofficial ]

I’ll check it later, to be more specific, the led of the track assigned blinks when the kick punches and the vst doesn’t respond BUT if I put a trigger on the midi channel it trigs the vst so that’s what makes me think something weird is happening


Found this

So 0.6x had this fix which is great

** Bug Fixes **

Re-Allow MIDI track triggering from any channel in base channel range
Some tracks could become unmuted on sequencer stop start.

But triggering a MIDI track from any other track of the MD still not working, I can confirm is a bug and not a routing issue

@JustinValer is possible doing something here? It would be super great having this working fine

To be clear the issue is:

Let’s say track 1 is kick and track 16 is MIDI ch16, so when picking a machine for the kick I assign it to trig too the track 16

The midi track is going to be triggered as you can see is blinking when kick pumps up but it does not send any MIDI. BUT track 16 does if you manually put a trig on it


thx for bringing this up again! A fix would be most welcome :slight_smile:


Ahoy! I have a MD SPS-1 MkII and I read above that X.08 can be installed on non-UW. Does anybody know if that is also the case for X.09?

yep, no problem with 09 on my mk1 non uw.

1 Like

unsure if this always happened on the original elektron firmware, but I encountered a lock up and freeze and random soundscape on the md yesterday.

Has anyone encountered the following? -

X.09 md mk1

GND PU synth- on 15 tracks, tonal setting
ctr-al - on track 16, heavy global plocking and recording.
two lfos in hold mode on track 14 and 15 modulating decay and pitch on ctr-al

then I’m scanning through each lfo destination on tracks 14/15 which is awesome for soundscapes and switching back over to live recording with ctr-all and messing with ctr-all lfo recording and mute

Then had random sounds and glitch amb soundscapes -a total screen freeze and lock up.

Reboot, play screen freeze and glitch out, occures 5 times in a row.

Until I changed the lfo hold on 14/15 to trig. The screen freeze never happened again. And couldn’t get the screen freeze and glitch sounds working again.

Might be memory and plock overload.

Sounds familiar (processing overload) to what I had a couple times (couple of years ago). Was using 16 GND machines in tonal mode with very long or maximum decay plus max delay. Was sort of playing the MD polyphonically (without a MCL). After some time it started to choke up and glitch. Switched it back on and it did the same after about five minutes but when I dialed back the decay and delay, no problems.

Probably only a matter of the number of voices / long decay / long delay tails and would’ve happened on the OG firmware as well.


thanks korpinen for your response, that makes sense and i thought that might be the case and an OG os limitation also.

I will try the decay and max delay and see it i can lock it up again :upside_down_face:


Is anybody still making the megacmd units? I tried
the link below and the website seems to be down

I think @mbang is still making them.

1 Like

Yes, i do. :slight_smile: PM me! Or erik.marcus.bang at gmail dot com


Sweet! PM’d

Hey there!

I’m on X.05 and I don’t own/use a MegaCommand.
Should I update to X.09 anyway?

And if yes, (probably silly to ask) can i update from X.05 directly to X.09?

For a long time I used a midi processor with pitch conversions to CC messages, before the tonal mode was introduced by the new firmware.
So I’d like to understand.
In the past, depending on the machine, the notes didn’t always drop as low, on some machines (and the old table) you could see that, for example, a CY machine would only react at 2 octaves, while an EFM RS would react at 4 octaves.
So I have two questions.
With today’s Tonal mode, does every machine react to the same notes?
Will the same notes play the same CC value on each of them? For example, C: 64 CC value.

1 Like

Yes and yes. Upgrade to X.08 at least

1 Like

Thanks for the reply!

Well, since X.09 is out there, I think I’m gonna update to it :slight_smile:

1 Like

I recently updated to X.09, and I’m running into a bug where tracks 4-7 stop producing any sound. I first noticed it after I did a factory reset (simply because I never have and wanted to see what the factory kits were like) and then sent my backup to the unit to get my own patterns and kits back on there (while doing so I did notice that the sysex send/rec only sent over 217 of 232 messages, with no errors. not sure if that is related?). When I came back to the MD the next day, tracks 4-7 were not producing any sound. I did another factory reset and that fixed it. I again restored my backup, and it again only sent 217/232 messages with no errors, but everything seemed to be there. So I came back to it today, and again, tracks 4-7 not producing sound.
Has anybody else experienced anything like this?

First I’d rule out any MIDI devices by disconnecting the MD from MIDI input and see if that fixes things.

1 Like

Yep no MIDI connected

Did you check to see if the track audio routing has changed?

1 Like