Machinedrum SPS1-UW X.10 Released [ Unofficial ]

Sorry for bombarding you with questions. I have just tried to update the MD to X.10 a few times, but it fails. I’m on a mac. First I tried C6, and my MD received all the way to the very end, where it said it failed, and that I should try again. After that I tried SysEx Librarian, and the first time it failed before the process had gotten to the second trigger. Then I tried it once more and it failed it got further but failed before the progres reached the third trig. I imagine it might have something to do with the settings in SysEx Librarian, and maybe i am trying to send it too fast? I have used the app with newer synths so maybe I have changed the preferences to go too fast?

My preferences in SysEX Librarian:
Pause between played messages: 150 ms
SysEx recieve timeout: 1 sec

Transmit speed: 100% 3125 Bytes/sec
Transmit buffer size: 64

Btw, I guess it is enough that I only have my midi interface connected to the Midi In on my MD, so I don’t need to also have the MD’s midi out connected to my interface?

Edit: Tried the C6 again and the progressbar again went all the way almost until the end, the trigger progressbar was on trig 16, and the “sound selection” progressbar (showing the progress of each trig) was on 4 MT. If that could be a clue to someone… I also have some slight memory that I havn’t gotten the C6 to work the last times I have used it, so that I instead have used the SysEx Librarian, but not sure, but could have been for a newer synth… But I think getting the SysEx Librarian to work, probably is the way forward…

Try reducing the speed to 50% and adding a 5ms pause

C6 I think is the better choice, for turbo midi to work with the TM-1 you need both in and out.

It should look something like this but with turbo midi off if you are not using a TM-1

Thx Acidbob. I just got it to work with Sysex Librarian, I thought I try one more time and changed “Transmit buffer size” to Default , and it worked (don’t know if it was the buffersize or luck)! Took forever though, and I didn’t dare touching my computer so didn’t see your msg (my settings didn’t look like yours at all, actually every single setting was different except the “turbo-off” recommendation).

Now I’m on X.10! :)) Thx everyone!

Is there a manual for the X.X firmware, or is Machinedrum SPS1-UW X.05: the living documentation the best place to go through it?


Good morning all. A basic question - I did RTFM, watched the videos, but I guess question is so basic it isn’t covered :man_facepalming:

How do I keep the “Kit” consistent across patterns?

Say I work on a pattern A, I’m super happy with it etc. Now I start working on the B part. I want both parts to “sound” the same, albeit with different trigs and locks.

On non MCL-MD, that’s the default. But with the MCL, if I change part B’s “kit” how can I make Part A match it? is there a way to copy-paste kits, or some other workaround?


Classic mode (vs extended, which loads the kit with the pattern). There’s a button for it.

Thanks. This question was specific for the MCL so was moved to that thread here - MegaCommand // MCL 4.51 - #635 by waftlord .

dumb question noob here
i just got an sps-1 mk 1 - non uw
2 days ago
can i use this firmware on my machinedrum?

Welcome to the community! Yes, X firmware is compatible with all models of Machinedrum.


thanks chad
do you think i should train on the old os first or update and learn on the new one?

Update straight away, so much more flexible! I started on X.07


thanks Claid
you’ve been so helpful


Maybe you guys are a bit tired of the same comment here from me.
Please please please can the resolution on CTRL-8P be changed if there will be a X.11?

I like to record realtime knob movements with the CTRL-8P machines, but I feel like this machine would be so much more useful with an update to the resolution when a knob is pressed to record realtime. Right now the resolution is too low and the knob is all over the place.

(EDIT: Maybe this is only a problem when 8P encoder is assigned to a midi CC value, I need to check)

Please :hearts:

1 Like

Another suggestion for X.11, just shooting here, but step record mode like on the Monomachine, Digitone and Digitakt.


Perhaps the sequencer tricks could be a midi command request. id say the alt firmware is pretty much prefect thank you the redacted team.
but if there was room to move in the os and the team is open to suggestions and in keeping with the md principles i’d suggest:
coffee machine screen saver (elektron-user joke)
some weird tonal setting for some PI and e12 machines
GND-SID sid machine
wrong kit/pattern function machine
looper delay machine -extended delay buffer record in delay ala the ram machines or a different take
grain machine built on the E12 machines
E12 sample replacement
step offset record - live record left/right function

1 Like

Hey all.
I’m on the verge of updating to the unofficial firmware.
I’ve read it takes an hour or more, so have been putting it off.

I have a few questions about the unofficial firmware.

  1. Does it add trig conditions?
  2. Does it add scale per track? IE 1 track can be 64 steps and 1 can be 15 steps and so on?

I read through the changelog notes in the firmware file, and didn’t see either of these listed,
unless I missed it.

I dont have a mega command at this point.
But would consider finding one if it helped with the above.

The MegaCMD connected to the MD allows all of that and more - trig conditions, scale per track, the awesome grid sequencer, chromatic modes - it’s like the best Elektron box ever, except it’s not an Elektron.

1 Like

I’ll hunt one down.

So I’m assuming none of that is possible with JUST the firmware update then?
I need the megacommand too.

Do you then program those parts of it (trig conditions etc) on the mega command itself then?
Or is it more it UNLOCKS the functionality on the MD?

No and no.
Currently MCL is a must for the extras you listed.
MCL takes over sequencing when the new enhanced mode is selected and MCL sequencer has those extra features.


Hi, All.
I use Octatrack MKⅡ(OS 1.40B), It’s my main machine.
and I use MACHINEDRUM MKⅡ (OS 1.09).
Then I send MIDI Message from Octatrack to MACHINEDRUM.
Suddenly my MACHINEDRUM dosen’t work with my Octatrack.
It’s Bug?
or My setting is wrong?
Please tell me

You have to provide more detail than this in order for people to help you or provide feedback. “Doesn’t work” does not tell us anything.

1 Like