Keystep, Digitone configuration


#1

Just bought a Keystep to use with the DN. It’s great. Love it in fact and I would say for the price then it’s worth every penny. I also use it to play my M.I Elements plus the mod cv out is really cool. I’m just wondering if I can sequence my Elements from Digitone into the Keystep? So Digitone midi into Keystep and out to Elements. I’ll try it out and report back.
EDIT - yes of course I can use the DN’s midi out to Keystep to Eurorack cv/gate. Amazing! I think the Keystep is the best value device I’ve bought (after the DN).
EDIT #2 Ah…I can use an LFO on DN to modulate the Keystep’s mod strip which in turn outputs an LFO’d mod cv into my Elements. hahaahah


Do you use an ext. controller w/DN? Aftertouch, breath
#2

The Keystep has midi out and can be powered with a micro usb charger (iPhone charger should work right?).
So if it is powered I should be able to plug it directly into the Digitone via midi right?


#3

Sure you can connect via midi.
You can do midi in and out.


#4

Great. Then I think the Keystep is for me.
Have you tried using a smal usb phone charger with it?

If you set it near 125 BPM for instance will it then play that exact tempo or will it be a bit off?


#5

Yes, a small phone charger works fine for the keystep. Or a simple microUSB battery pack. It only pulls ~100mA, maybe a smidge more if all the LEDs are going at once. It’s a very efficient unit.


#6

As for BPM… MIDI clock is always (forever, and in almost all except the most ideal cases) slightly “off” by .1 or so - it will center on the exact time, but don’t be surprised to see very small drifts. This is common, and in fact the drifts are usually not as big as they look. It has very little to do with the quality of the sending or receiving units (unless they are actual crap), and everything to do with the shitty clock standard that MIDI has built into it and the fact that the clock signals are interleaved with the note signals and are still timing dependent.

But we can get into the shittyness of normal MIDI later… it’s a performance feature, works perfectly well enough for live playing and for recorded playback, and in studio use it works, but it’s nowhere close to sample accurate as a protocol.

However, to your point, the keystep and digitone work as flawlessly together as MIDI ever will, and it’s a real joy to use them as a pair. I do every day.


#7

Yep…and you can even power it from an iPad. It really is a ‘must buy’ if you have a Digitone. Also you can use midi out (lfo)of the Digitone to modulate the mod strip and then have that modulated mod strip on the Keystep go back into the Digitone via midi. Kind of fun.
I would suggest editing the aftertouch settings in the midi control centre software. I have mine set to ‘soft’.


#8

Thanks for your detailed replies guys.
I want to use the Keystep with the Digitone without having to use my computer. The Keystep has that fun sequencer but can I use that with the DN in sync?

My Octatrack is master and DN slave so would I connect like this: OT > KS > DN ?
I guess that would work well. This is probably how I’ll be using it.

In case I use KS with DN only I’ll set the Keystep as master > midi into DN and then control tempo from the Keystep? And without a BPM display is that possible?
Or can I have DN going by it’s own tempo and still use the Keystep sequencer?


#9

I’m sure you could do this but the sequencer on the OT and DN are much better. There is the chord mode on the Keystep which is really good.


#10

OT > KS > DN is possible but also KS > OT > DN (you can find more details here
External keyboard set up)

If you set the KS as Master and DN as slave, the Tempo will be displayed in DN, so don’t worry about this.

You can also run the DN free (no tempo sync[connect midi but press play only on DN) and then activate record mode on DN and record the notes you are playing on the fly with KS into DN.

I also play DN with the KS, there a lot of options how to set things up and it works pretty well.


#11

Bought this beauty yesterday and boy, am I happy with it! It looks great and is very solidly build. I had gotten use to playing the Digitones trigs as a keyboard but this is so much better. I never learned to play paino but this allows me to practice regularly while composing.

I run it like this: OT > KS > DN. KS set to MIDI on the back. This lets me play the DN and OT still sets the main tempo. What I want though is that starting OT should not start KS sequencer since I generally want to play manually and I can start it myself if I want to use the KS SEQ og ARP. Is there a way to so this? Via The Midi Control Center I can set Midi Thru to “On” but it still trigs KS SEQ…


#12

If I remember correctly keystep needs to be master clock to use the arp.


#13

Arp on mine works fine in slave mode.


#14

Well there you go

Edit: maybe you could explain to the person asking how to do it?


#15

On KS im always in ARP mode, so when pressing start on the master KS is not triggering DN.

Edit: This way you have to stop KS every time before playing single notes.

I think the only workaround then is to set it KS>OT>DN.

See this post for the setttings on the OT.


#16

Ensure KS is in ARP mode. Send MIDI clock to the KS via the method it is set up as slave for (e.g. USB MIDI or DIN MIDI). Send MMC START or press “play” on the KS. Mash one or more keys = arp joy.


#17

Thanks for your inputs. My current configuration is probably the best since KS needs to receive a master tempo and this way both SEQ and ARP works synced. KS as master doesn’t work since KS lacks a tempo display and I want OT to be the master.
I’ll just have to stop KS every time I want to play single notes as knh also suggested. I’m just wondering why setting Midi Thru to On still starts KS SEQ/ARP. I’ll write Arturia about this and see if they can make a “Manual play/stop button” setting.


#18

The arp need not be stopped, you can use SHIFT+Kbd Play to play freely–you can even choose a different midi channel if necessary.


#19

Didn’t know about that possibility, thanks :smile:


#20

Has any of you Guys an idea why a keystep modwheel wouldn’t be ignored by DN? Got a keystep and everything’s just fine, besides the modwheel being dead. Any ideas where’d I start troubleshooting?