How to sequence all tracks within Overbridge of the Digitone

Hi guys,

I finally found the time to hook up the awesome Digitone into Ableton. I want to create 4 midi channels and lood the Plug-in into it. And sequence all 4 tracks from Ableton. But whatever I try, all the midichannels only play sounds from track 1 on the Digitone.

What am I missing?

Please help!

1 Like

I have no Digitone but on the other machines it works like this:
Go (on the hardware) to Global Settings -> Midi Config -> Channels and make sure that each track of the Digitakt is set to a seperate midi channel.

Unfortunately that’s not working on the digitone. It is set by default to have channels 1-4 for the 4 different tracks. If I select the specific channel on Ableton it keeps playing the first track from the piano roll. Also the audio tracks is not working. I can set 4 audio tracks with the sound of track 1 to 4. But they all receive every sound.

Is there anyone who knows the problem? I have it aswell with the Digitakt. I use Ableton Live 10 and Windows 10.

  1. I add the Digitakt VST as a track
  2. I say Midi from; Digitakt
  3. Channel 2 (Snare)

Then when I use the pianoroll in Ableton it will allways play the Kickdrum. I only want to have 8 separate midichannels with the VST on it. So I can create midi tracks with the Piano roll and do Automation with the VST on all of them.

How can I achieve this. Same problem with the Digitone.

Hey,
I´ve had the same problem. I created a new midi track and loaded an external instrument next to Digitone midi track with Overbridge running.
External Instrument:
Midi To
1-Digitone
4-Digitone

Now it´s playing track #4 on the digitone. Still a little bit buggy with audio but quite useful anyhow.

Yeah that solution works. It is not perfect because for the sound you would need a extra Audio track. I guess it has to do with a windows update for Midi over USB. My Moog Subsequent 37 has also a VST with it like overbridge. But if I add that to a midi track the midi notes in Ableton wont trigger the Moog. Moon says it has to do with the Windows 10 update. The are working on a update.

@DaveMech, how are you?

I know you have a lot of experience with OB. Do you know how to fix this problem? Already a big Thank you!

Hello how do you do?

It happens the same to me with iMac and Logic Pro. I’ve set MIDI channel 1-4 for all each 4 track channels on Digitone, but only works for the channel 1 and doesn’t recognise 2, 3 & 4.

I’ll hope they could fix this bug soon.

Una abraçada! see u elektronauts!

1 Like

Yes hope for an fix. But I gave up Overbridge because for me the software doesn’t offer me something usefull. The audio out off the USB is way to soft compared to recording into a separate audio interface. The day it is for headroom. But they won’t give me an option as I want to record as is and not standard x decibel below.

Check this Post :

Have you tried without using Overbridge? If all you want to do is triggering seperate midi tracks to the Digitone.

Overbridge is only needed if you want to record the four audio tracks to seperate channels.

If you want to trigger 4 separate sequences from Ableton to the Digitone, you need to create 4 midi channels and one audio channel.

then configure it like I show on the picture below I did for the Digitakt as example:

Then the Audio track needs to be set to Ext In and then select the Audio Input channels from your interface to what the Digitone is connected to. Like Line 1/2 or 3/4, etc.
Then set Monitor of the Audio channel to In to arm it and be able to hear the audio from Digitone coming in.

Hope this helps.

PS. If you want to do it the other way around and sequence 4 different VST’s in Ableton via their own Midi channel and use the Digitone as a Four track sequencer. Then it’s the other way around and make sure you arm each channel by setting Monitor to In. Otherwise you won’t hear anything!:

I run the latest Windows 10 patch level, latest Ableton Live 10 version and have no issues sequencing seperate tracks/channels!
But you have to do it and configure it like I described above or it won’t work and/or won’t hear anything.

I regularly use the Digitakt to sequence VST’s and external gear through Ableton Live (even without Overbridge) like my Behringer Crave and Novation Circuit, but it’s important to setup both the Midi and Audio tracks correctly!
In this example, Novation Circuit’s two synth tracks only listen on Midi channel 1 and 2, so I set the Midi channel dip switches of the Behringer Crave to listen on Midi channel 3. Then VST’s l configure to Midi channel 4 and so on.

Also, like above mentioned. Go to settings in your Digitone > Midi Config > Channels > Here make sure each track is listening to the correct Midi Channel they are supposed to receive Midi data from (when sequencing to Digitone from Ableton) or sent Midi Data On (when sequencing from Digitone to Ableton) !

Thanks for the tips. This issue was giving me a minor headache. I had accidentally did it one time, but forgot how I did it.

Hi,

Thnx, butI know this will will work. I got this to work already. It is just like any other synth. Connect the right midi channel and pop a audio channel next to it. Then you can sequence the machine from the midi track.

But what I want is use the Digitone / Digitakt VST within Ableton. Set up like 8 midi tracks for the Digitakt and 4 Midi tracks for the Digitone. Then sequence them from Ableton in arrangement view for creating a track. The VST lets me create easy modulation lines on the track. But that is not possible. Just like I mentioned in the opening post. It won’t let me change to Track 2-8 on the Digitakt and not to 2-4 on the Digitone. It keeps sending audio from track 1.

It’s sending Audio from just track one, because only the first VST in Midi Channel 1 is active. The other Digitakt VSTs in other midi channels are completely ignored.
Just check. The first Digitakt/Digitone VST that is loaded in a Midi channel becomes active. Every other Digitakt/Digitone VST you load into other channels are ignored.

The problem is that what you want to do is not possible.
The moment you load for example the Digitakt VST (or any other VST for that matter) into a Midi channel, the Midi Out channel disappears and is replaced with Audio Out.

So how are you going to tell that Midi Channel on what Midi channel to send the Midi Out to?
You need to be able to send the Midi Out on a specific channel and you can’t when you load a VST in a Midi channel. The moment you load a VST in it, it can only receive Midi and won’t send Midi out!

That is one issue. The other issue is clearly with the Digitakt/Digitone VST itself that only allows one instance of the VST to be active at a time.
So whatever midi sequence you put into the Ableton track, its only send to Track one, no matter what. The VST itself won’t allow you to change this.

All Overbridge does really and the function of the Digitakt/Digitone VST is, that you load it into the first Midi track so you can split the 8 Audio tracks (Digitakt) in different Audio channels.
That is really the sole purpose of Overbridge at the moment.
Like shown here in my Example Template in how I use Overbridge:

So you either do as above, use Overbridge and use the Digitakt/Digitone as Sequencer.
Or you do not use Overbridge (and the Digitakt/Digitone VSTs) and use Ableton as Sequencer to the Digitakt/Digitone/other gear like I showed in my earlier post.

It’s the only way sadly.

I did some more experimenting and here is another way to do it, if you want to use Ableton as Sequencer to the Digitakt/Digitone and still want to use Overbridge to split the Audio channels.

You still limited to one instance of the Digitakt/Digitone VST, as like I said, the sole purpose of the VST is to split the audio tracks. That’s it.
But at least for those interested. Here is an example screenshot of my experiment, to send individual Ableton sequences to in this case Track 1 and 2 on the Digitakt and then Output them over separate channels back into Ableton via Overbridge(Digitakt VST):

Thnx for experiment this. To be completely honest then I don’t understand the fuzz about Overbridge and why it is so “big”. If it only splits the audio in selectste channels. The VST is for me the biggest thing in there. So I can tweak and modulate from there and put it in the arranger. Sure the split of audio is nice, but just a “minor” thing and not perse needed.

They could just leave the current vst out of it then and just created a plug-in for the split instead of tweaking the parameters. As I saw the idea was that you can program and sequence the whole thing from your computer. So you get a 8 track midi in your DAW for the Digitakt. Where you get automation for all the parameters. That’s where for me the fun starts.

But I ques I misunderstood. So for me Overbridge is not really suited.

In all honesty. Me neither and totally agree with you. Elektron has really oversold Overbridge and some of their marketing is outright misleading.

I don´t understand the purpose of the VST either and why it exist in it´s current form. It´s just a useless gimick. It´s easier to fiddle with parameters on the actual hardware, than with the mouse.
It´s why we bought the hardware for in the first place!

1 Like

I couldn’t agree more. Been using hardware more and more lately and left my DAW alone. Just record sometimes something in. But nothing more.