Ableton Live Autochannel settings

Just bought a Digitone. I am using Overbridge connected to Ableton Live. Both are updated to the most recent version.

The Auto channel is set to MIDI Channel 10 in the Digitone as per the default.

I have tried so many permutations of setting up the Autochannel and have read posts and the manual now for over an hour, without luck.

What are the proper MIDI settings to be setup in the Digitone? I have it set to USB + MIDI input and USB Overbridge active.

There was a time I got it to work for about 10 mins by activating MIDI Out in Ableton Live to the Digitone, creating a new MIDI channel and routing that to Channel 10 in the Overbridge plugin - but maybe that is not what I should be doing? Does anyone have any suggestions of how to setup Live and how to setup the Digitone to do this?

All I want to be able to do is change the Track and still be able to play the selected track with my Push and MIDI keyboard hooked up to Live. (btw having same issues with Analog Four).

It should work, in the ableton options make sure midi is set on for in and out for digitone…
You need to send midi to the digitone destination, not the overbridge plugin or you won’t be able to record notes…

I sometimes have had to switch the digitone off and on to get a connection

After fiddling with the settings and multiple restarts I got it to work.

Now for the next part - how can I use the midi tracks properly on my Digitone?

I want to use it in overbridge mode but also be able to record into it with midi and record that onto digitones midi sequencers. And then use those sequences to drive other VSTs in Live or other MIDI synths.

As of now I can get autochannel to work so if I click midi track 1 for ex I can get it to trigger the proper synth, but I can’t get the trigs to send out the info properly.

In MIDI CONFIGURATION > PORT CONFIG > TRIG KEY DEST must be set to INT+ EXT if you want to play your Soft Synths with the Digitone Keyboard (Trigs). You want to send MIDI from the Digitone Keys.

Maybe this is the missing link.

Appreciate it but that is how it is setup already (I changed that setting from the default).

If you post pictures of Ableton set up, I can help you. I already use my Digitakt to sequence and play my Soft Synths.

Strangely I got it to work by pressing on the synth button and turning knob 1 to channel 1. I guess I never picked a channel there. Sorry about this. Really struggling with setting this up!

1 Like

I’m also struggling to set this up, I couldn’t find an auto channel in logic so I switched to ableton. However, when I change it out of overbridge it order to record notes onto the digitone from a midi keyboard (via ableton), I get no sound at all. I can see a meter lighting up though. I’ve configured midi to go in and out of the digitone in the main ableton settings. Any help would be massively appreciated, I’m thinking of ditching my daw completely and getting a key step, although I’m very attached to my komplete kontrol keyboard due to its nice key action and encoder for browsing plugins.

What do you want to do exactly? What is your setup?

I’m basically trying to use a midi keyboard to live record onto my DN through ableton. I’d also like to be able to set up the auto channel to be able to automatically have the midi keyboard play which ever track is selected on the DN.

Your Keyboard has only a USB Port? No 5-Pin MIDI Port?

Unfortunately yes

I’ll do some tests tonight and come back to you.

Thanks!

Just to be sure, are you using Digitone via Overbridge in Ableton Live? Can you select a MIDI Channel on your Keyboard? If so, I got the answer.

I’ve been using overbridge but I read it needs to be set up as an external instrument track and as midi rather than overbridge in order to record onto the DN. Unfortunately I cannot select any midi channels from the keyboard which is why I’m considering changing it for a Keystep. Thanks.

I found two ways of doing this. One with External Instrument, the other with a regular MIDI track and it doesn’t involve setting a MIDI Channel on your Keyboard. Look at the Screenshot :

On Digitone : MIDI CONFIG > PORT CONFIG > RECEIVE NOTES Enabled
In my case, the Digitone Auto Channel is 10. You set this in :

MIDI CONFIG > CHANNELS > AUTO CHANNEL

This way, your Keyboard should play whatever Digitone Track you select on the Digitone and you can Record Notes in the Digitone’s Sequencer.

By the way, my Keyboard is a Launchkey Mini MK3. So if you look at the last two Tracks on the Screenshot, you will have to replace MIDI FROM with your own Keyboard.

1 Like

Thanks so much Tchu, I’m going to try this later. Really appreciate your help!

OMG you are an absolute legend, it works with the external instrument settings. Thank you so much! The other settings you have for the independent midi channels, is that using overbridge? That’s my next saga to figure out…

Hi Tchu, do you have any idea on how to set this up in Logic pro? I’m much more used to it than ableton. I’ve tried to set it up using the same configuration that worked with Ableton, using an external instrument configured to midi channel 10 for auto channel. I’ve made sure the DN is on USB midi, not overbridge. I can see audio going into the track (lights up green) but can’t hear anything. (the external instrument shows up as a drum track for some reason, not sure if that is affecting it). Any help appreciated