Digitone 1.01 : bug reports


#22

Yeah, the MIDI / Trig Key behavior on Digitone just seems wrong compared to Machinedrum, Monomachine, and Octotrack, where the MIDI track’s MIDI channel is all that is needed to direct the output from the trig keys. I reported this on another thread, but thought I’d mention it here. I’m not trying to use an external keyboard (I’m not a keyboard player), but just the trig keys on the MIDI track. I can sequence from the MIDI track without all of these hoops, but to use the trig keys (and thus get the Digitone’s ‘Track note’ scale and chord config stuff in place which I really like) I had to go through this:

The heart of it was this:

The way I got the Digitone’s trigger keys to play the Modor NF-1m I had connected was:

  • Turn off MIDI channels for Digitone’s internal tracks (I usually do this on all my Elektrons as I just want them on their internal sequencer so I can freely use things like channel 1 on my other gear without interference)
  • On MIDI Config - Channels page, I had to set MIDI Track 1 to Channel 1 (the channel I had configured on MIDI Track 1’s SYN1 page, which is what my Modor NF-1m was set to).
  • On MIDI Config - Port Config page, I set Output Ch setting to Trk Ch.
  • On MIDI Config - Port Config page, I set Trig Key Dest setting to INT + EXT.

Then, I could play the Modor NF-1m with the Digitone’s trigger/keyboard.


Introducing Digitone
#23

Interesting.
It smells like an anomaly.
Have you guys reported it already ?


#24

I’ve reported it only in these two posts. I kindof wanted confirmation that this felt wrong. I’ll submit it as a ticket.

Update: ticket submitted (20804) as “Digitone’s Trig keys should follow and talk to a MIDI track’s channel setting by…” (should be “by default” but I think my title ran a little long).


#25

Thank’s @jshell for confirmation !

Thank’s @LyingDalai, I will make a ticket for the no midi signal transmitted from an external keyboard to an external synth, and also some small stuff like the LED colors on page menu.


#26

reported as a bug, was rejected. bit i still think its a bad implementation


#27

sometimes the unit states, “dsp error” on startup and has to be restarted. anyone has that too?


#28

Yes I do. On my Blofeld :stuck_out_tongue:


#29

Isn’t this only the embed Blofeld detector for poor synthesis choices ?
:wink:


#30

Nope… Blofeld has poor synthesis choices embedded already. It’s called “randomize sound” :smiley:


#31

Sure thing ! I do not understand why it should be that way…Does analog heat clicks when switching from active to bypass ? No !


#32

Really… MIDI has been around for how long? MIDI USB has also been around for a while. Elektron is not the only one apparently unable to get MIDI stuff to work properly. Issues with MIDI and USB MIDI are very common even today. I don’t get it, this is a really simple tech. We have multichannel digital audio streaming over USB/ Firewire/Thunderbolt but for some reason MIDI is still a problem. :disappointed_relieved:


#33

Just received response from Elektron that they are aware of the pattern sync issue and it will be fixed in the next update!


#34

That’s great. Though I’m blown away by the amount of indifference on this board concerning correcting this behavior so color me impressed Elektron is doing something about it.


#35

This bodes well for the same issue being fixed in the Digitakt as well :slight_smile:
I also couldn’t see the benefits of the current functionality so I’m happy it’s getting fixed.


#36

Also getting small clicks/pop on inputs running 1.01.


#37

I seem to only get clicks and pops (but quite loud) when starting up Digitone with external inputs connected. I haven’t noticed them elsewhere yet.

I was also able to upgrade from OS 1.00 to OS 1.01 via USB (saw someone mention they couldn’t earlier). I used SysEx Librarian on Mac to do the upgrade and it worked (but seemed slow).

I have gotten the “failure to boot DSP” message twice now.


#38

As soon as I use the audio input of the DTo and the MIDI input, I got very loud clicks, mostly while the pattern loops, but also sometimes in the mid of the pattern. If I disable the MIDI input (or disconnect the MIDI cable from the MIDI input), everything is fine. The level settings are okay. This happens while slaving the DTo to my DT, but also when I use my Monologue as sync master.


#39

My setup is exactly the same.


#40

The 10.000 $ question is: Do you have the same problems? :sunglasses:


#41

Yeah. That’s what I meant. However. Now, I’ve just tried to hooked them up in reverse order, where DT is slaved by Dto, but it still happens. Seems to happen mostly when voices are maxed out in busy patterns. So maybe it’s a thing with voice stealing?