Digitone 1.01 : bug reports

any known bug with voice assign ? I got 2 voices with unisson on track 1, 2 voices with unisson on track 2, 2 voices with unisson on track 3 with an arp and trying to play a two notes chord on track 4,sometimes it just cut out

Also i would be pleased if elektron could confirm the “DSP BOOT FAILURE” as a software bug because i had in total 3 or 4 during 48h or early usage, i hope my unit dont have a hardware defect!

Did you run the tests?

2 posts were merged into an existing topic: Digitakt 1.06 : Bug reports

yes of course, but tests can fail sometimes ! had another one this evening

Not sure this is a bug, but the Master settings (input level, panning and fx sends) is saved with patterns. Most of the time unless the pattern you load is blank.
My opinion is this should not be linked with patterns at all.
EDIT : btw i just discovered that the Master Page (like any other) can be copied and pasted. That’s great to know !

I have had my Digitone for a week and I’m running 1.01. So far I had three issues/bugs?:

  • All of the sudden the transport buttons started to do their secondary function as I was actually pressing function, copying and pasting were all I could do…after changing patterns I was able to use the primary function of the buttons again.

  • On one occasion I couldn’t switch it on! I got a blinking light but was not starting at all. It only worked until I’ve unplugged all cables (USB, MIDI etc) and I was able to boot into safe mode by pressing function. Next time I switch off and on it worked fine.

  • When sweeping the frequency and resonance of the filter at the same time in a fairly complex pattern the unit freezes. It kept playing but all keys and buttons were unresponsive. The only way to fixed was by restarting the machine.

I haven’t use the arpeggio so I haven’t had any issues with clicks and pops as reported by some people. Also, somebody mentioned a problem with a pattern not switching to another but apparently that is because they have a different pattern scale mode, or one is set to infinity…

Beside this, I absolutely love this machine, I think is brilliant and it sounds amazing…in fact, I’ve decided to get one after falling in love with my Rytm MKII and the Elektron workflow…watching the Digitone release in NAMM make me wanted one right away!

I’ve had the transport 2nd functions thing too. had to reboot to fix.

This sounds like the issue I mentioned abobe

Got mine today, love it so far. Everything except the popcorn. Seriously pops all over the place. The third demo track for example (the one called ‘Floats’) has a loud pop on the 1,5,9,12 beats of every bar.

I dunno if this is a bug or just the nature of the beast but its regarding the DN master overdrive.

When you engage it even just 0.01 it squashes the frequency spectrum and stereo spread of the inputs very noticeably, so for subtle use its a bit awkward. It would be great if that could be a bit smoother as you increase the overdrive.


Yup noticed this with my op1 tonight

I’m not hearing any pops on Floats demo. If you have been using the inputs, try turning them down fully even if they’re already set to 0 (another bug is that master page settings are carried over from the previous pattern)

Maybe, funny thing is now that I have cables plugged in to the inputs it’s not doing it.
I should of recorded it, it was sharp clicks. Straight out of the box, 3rd pattern I loaded

Weird, you can tell if the clicks are coming from the inputs by cranking up the reverb on the master, as they become massive reverbed clicks lol.

1 Like

Yeah wasn’t anything but my headphones plugged in when it was doing it. Good to know that the input click is reverbable, now I can test clicks in future to check if its machine or inputs. Might put in a support ticket

Think the clicks are actually worse and more frequent when there’s nothing plugged into the inputs and the levels are turned up.

When it isn’t a total click frenzy, the OP-1 sounds great through the DN overdrive and reverb!

Just had a complete freeze which required power off and on. So far not reproducible but was when playing notes in rapid succession on the keyboard

I program a melody on each track, when I come back to it after working on another track or pattern, some notes from a melody are not lit up anymore and I have to re program them back in even though I have saved the project.

Does this have something to do with the voice allocation? Surely it should keep your sequences in tact and just not play the note if there are over 8 playing?

Anyone else had this issue?

I am having an issue where I program in sequences on each track and save the project. I go back to the project after working on another one or after a power down and the sequences I have programmed now have several notes missing. I have to go back and re program the notes and re save.

Does this have something to do with the voice allocation? Does it choose the notes to play based on how I have the voices set up and delete the rest? I would have thought it would keep the sequences I have programmed and simply not play the note if there are over 8 playing. It is annoying to go back to a project and have to re enter the notes I have already programmed and saved.

Is this a bug or is this the way it works?