Digitakt And Virus Ti in DawLess setup... stable?


#1

My Digitakt and Virus TI Snow have some problem sometimes about Sound Pattern selection(sequencer mode).
In the Digitakt, 4 Midi tracks are configured with Channel (1 to 4), Bank and Prog to get the sound I want to sequence.
It works, that’s great…BUT sometimes the virus Ti Snow requires to be rebooted because DSP or whatever got stuck and the correct sound is not assigned to its midi tracks.

Question: Does anyone have been using the Digitakt with any Virus TI device in this way and got a stable setup ?

I wondering if the problem is coming from:

  • My Virus TI Snow (CC overflow - hardware problem ?)
  • The Virus Ti Snow config (CC overflow or …?)
  • The Digitakt config (CC overflow or …?)
  • Is it a problem with all Virus Ti Snow ?

Thanks in advance for your experience !


Access Virus Ti desktop - still relevant?
Access Virus TI Snow
#2

I have been using DT and snow together? Seems stable enough and have had no crashes …?

I had it set up with a single midi cable and had DT channel A and B for Snow voice 1, C and D for voice 2, E and F voice 3 and G and H for voice 4… giving lots of control!

I sent my DT to elektron with a seperate issue and it has been replaced. And i cant get my back ups to reinstall. To see how it was set up? But it was just a one way midi out from DT.

I will try with my new DT however have you tried a brand new clean slate project on the DT to see if you have a project related issue?

When i had my sub phatty plugged in the same way i would get a hang in one project but no others?

How is your dt and virus patched and configured?


#3

Hi Adam9,
I just checked with a Control Midi App the outgoing signal from the DT and it may that the way I was using LFOs was generating too much traffic.
Let’s see if triggerless parameter locking provided so better results.
Problem is not related with any project so far.

Right now , DT is configured in the same way as you explained(Midi Channels per Midi tracks); only are specified SRC-> CHAN, BANK and PROG for each midi track. LFOs have been removed.
Virus TI Snow is in Sequencer Mode and Midi Program Change is Enabled.

So far, no problem yet. Can you give some tips about the way you are modulating your Midi tracks ?
TriggerLess parameter locking ? LFOs ?
Sequencer Mode or Multi ?

Thanks !


#4

Interesting🤔

Yip sequencer mode
Triggless p locks of the lfos mainly filter cutt and cycling through wavetable position. Sometimes osc 2 pitch…

But let me do a test later and see if i can push it to the point of choke? I will see if i can get all 8 lfos sending data at the same time…??? And get back to you…give me some time…

I have had this trying to send multiple lfos to volcas using FL2.0 and a motu midi interface…its gliched and spluttered but trying the same from the dt to the volcas worked really well i ran out of parameters to automate. Let me try…and let me look at bit rates for midi conversion on each device…stab in the dark.


#5

“Triggless p locks of the floss” ! Nice ! Good tip, I Iike a lot this idea, it will be put in practice today !
Concerning the Wavetable position, I checked in the Virus CC midi list, Can’t find it.
Which CC number is it ?

Will be nice to know until which point you have been able to move the midi crash test, Thanks Adam9.


#6

Ah Yeh its not called wave table index in the MIDI CC appendix as that terminology is only specific to wave table OSC types, and as you know you can choose from MANY osc types…so its called waveshape/index or something.

So it depends on what osc type you have selected in the patch, automating this cc will have an effect on any osc type you choose, just a different type of outcome for each osc type… But all do something interesting…So if you have the osc type set to any of the wavetable osc types then it will index through the wave table, if you have it set to the classic subtractive osc it will blend between the two waves you have selected in the oscillator, if you are set to hypersaw it will controll the density of the hyper saw (1 to 9 but very smoothly)…

CC 17 for OSC 1
CC 22 for OCS 2

Here are my other favorite things to mod with triggerless p locks of a DT LFO switching rate in tempo…
Ring MOD volume CC 38
FM amount osc 2 CC 27
OSC 1 Pulse Width CC 18 (on certain waves not sine hahaha)
OSC 2 Pulse Width CC 23 (on certain waves not sine hahaha)
OSC Main Volume CC 36 (goes into saturation from 100 to 127!!! so if you set the saturation curve in the filter section as a wave shaper or bit crusher you blend between gnarly and gnarlier in a very rhythmic Elektron way)…:heart_eyes: going into and out of saturation or digital distortion in a fraction division of the bpm.

Saying all that dont forget the virus has a complex matrix and 3 LFOs as part of its architecture, Which are very controllable and have access to more parameters than the direct MIDI in limits…So… you can also set A Digitakt send CC of 87 (virus LFO 2 to FM amount) and a second Digitakt send of CC79 (Virus LFO 2 Rate) and let the DT control the internal LFOs of the Virus…you could seta 3rd Digitakt CC52 to switch up the shape of the LFO rhythmically or switch filter types LP HP etc…using this method you can control the filters with the Virus internal LFO2…the amounts can be accessed through CC88 and CC89 and the LFO Rate again is controllable through CC79…etc etc etc Letting the Virus do the work internally and maybe solving any of the above mentioned MIDI overflow as the data sent is a far less continuous stream…! the above parameters are always the same in each patch so its a great start point for a Digitakt Template.

And if you havn’t had enough of me and want to get your hands real dirty… you could set a matrix slot in an individual Virus patch to control ANYTHING!! Set a Matrix Slot for Virus LFO 1 and let it control -:
Filter bank frequency - set to Vowel Filter Set with Hi Resonance (oooohhhhawwww)
Distortion Intensity - distortion set to Bit Reducer (Robot oooohhhawwww)
Phaser amount - (70s space robot oooohhhawww)

Then control the Virus LFO 1 the same way as above letting the virus do the LFO and the DT Plocking the changes with the beat.

Thats just one of six slots available!! have fun…!


#7

OMG !!!
I understand that you have the Snow for almost 10 years :rofl:
That’s really great Adam, thanks so much for sharing your tips with so much details.
I take good note of that.


#8

Maybe you can help me on a another problem I cannot fix by myself yet:

Snow in Multi mode.
I want to chain various Digitakt patterns.
Each pattern uses its own set of sounds and midi CC programs (MIDI X -> SRC -> CHAN, BANK & PROG defined for each Snow part).
The problem is when I pass from a pattern to another one, the Sow take tooooooo much time to react, last snow program is still playing while the requested one is not here yet.

My goal is to be able to do a live with only Digitakt and Snow using many sounds of the snow (not only 4).

Did you find a way do this or to avoid it ?
Thanks in advance.


#9

Mmmmmmm

This is something i haven’t had experience with the virus and DT…but i have something similar trying to get the program change spot on when using the DT to control the ARMKII…i think its not the virus however…you can find other threads here discribing others struggling to get many Elektron devices to change other devices patterns and programs in working sync. My current work arround is to have a duplicate for every pattern where you want to change virus patches. On the DT pattern that loops just before the change of virus patch try placing a triggless plock that contains the midi cc for the virus patch change…and experiment where that step needs to be for the virus to change at the correct moment…might be 3 whole steps before the end of the pattern and might need some shifting in ms left of right…might not matter as the dt might not send the program change until the end of the pattern…once you find it will be the same each time…

Then say you want to change from pattern 10 to 12 you would have a duplicate of 10 copied to 11 with the added program change cc plocked.

So you patterns might look as follows
10 x 3
11 x 1 (early virus program change plocked)
12 x 4

Not sure about this but give it a try and let me know.


#10

Sure ! Thank you Adam, I will let yo know :+1:


#11

People have mentioned that program changes plocked into the midi tracks have a two step latency. Maybe that will help.


#12

Hello, thanks you Adams for all your tips :smiley:
I just ordered a Virus ti snow for make darkpsy / hi tech et acid live with my digitakt.
Im very impatient :slight_smile:

See you soon on this post if i have a problem.
I hope i havent same problem like you psyraw

( Sorry for my bad english speeling )


#13

Welcome Home :smiley:


#14

Hello Adam, I have a problem with Virus Ti snow. I receveid yesterday and it work great but today, I put on et there are no sound in output. Do you know what is the problem ?


#15

Could Be MANY things but if it worked yesterday its probably a setting and nothing to worry about. They are not prone to failing so its a setting for sure…and probably MIDI or

Can you explain how you have it set up?
if you have a PC running? or is it just DT direct to the Snow? are you running VIRUS TI software and if so are the outputs configured to USB or OUTPUT?
If you are stand alone hit EDIT/SHIT & EXIT/MODE to switch to “Multi” and check midi channels by selecting EDIT / SHIFT “Config”

Tell me more about how you have it set up and we can look at what it might be.

And first thing to try is to press PART “select the part you want to Hear” and then Press EDIT/SHIFT AUDITION…the sound should play from the output you have it sett to…regardless of MIDI settings. If you have a PC plugged in and VIRUS TI pugin is operational the sound could be headed to the USB 1 2 or 3 channels and not the main outs…

If you can hear sound in the main outs, by pressing the EDIT/SHIFT “AUDITION” combo the you know its MIDI settings of either the SNOW or the send device…

Let me know in as much detail as possible how you have it set up there are soooooo many possibilities with this thing that im taking shots in the dark…

When you get it working dont forget to EDIT / SHIFT “Store” the multi patch …


#16

Hey y’all! I’m sequencing my TI with a digitakt and had a quick question. When in sequencer mode all of the TI patches are panned at -64 by default in the balance part of the surround menu. I have to manually bring each sound to 0 and save it just to hear the sound while playing. Has anyone else had similar issues? It’s rather annoying and I’m trying to figure out my way around this. Any help would be appreciated!


#17

Nope! Mine all default to the centre. It must be in the DT pattern. Check all 8 midi out channels to see if you have any of the 8 assignable knobs on the assignable parameter page set to CC#8 or CC#10 if so the value is at zero (or -64) disable it or set it to centre…also check by loading a fresh blank pattern. If a new pattern doesnt default to pan hard left you know its in the DT pattern for sure.


#18

Just tried and no luck :confused:


#19

Oh weird…yet interesting.

K

Try shifting the pan on the Virus to the center of any patch while playing…

Hit stop and then start on the DT, if the pan jumps hard left again then its definately the DT sending a midi message. And come to think of it, if you have messed with the midi routing in the DT it could be coming from any channel including the sample channels so check midi in channels of the virus and make sure that any sampler channels in DT midi configuration are not set to the same midi out on the DT as the virus is recieving.

On mine i have DT sampler channels set to channels 1 to 8 and the 4 virus snow channels as 9 to 12 so that settings of the 8 internal DT sample tracks dont mess with the virus…

Then also seperately see if you can use the DT to rectify the problem by changing one of the assignable midi outs of the DT to pan…and setting it to centre…seeing if that at least helps.

Also before we delve into the configuration of the 2 machines can you tell me if you have had the virus working fine with any other device driving it… midi or computer??? Even stand alone no midi cable triggering the shift audition??? If it only happens plugged into the DT we can go deeper into virus and DT config…:slightly_smiling_face:


#21

I hit stop and play and it’s definitely the DT! Where are the settings for Sampler channels located on the DT? I changed the midi channels on both devices to channel 9 to see if anything would change but it does the same thing. It’s really annoying cause I can’t even save the patchs in ROM because it diverts me to saving in RAM and then says it’s protected once I try saving. And i need to save the sound each time in order to hear and play it ^___^

I tried playing with the midi assign settings with cc#10 & 8 but it doesn’t change anything with the default balance being -64 on the TI surround setting. I’m pretty sure it’s DT midi config issue. But also i know the previous owner had the same issue and he was sequencing it with other hardware. So it might be a setting on the TI perhaps? :thinking: