C6 sysex send results in empty patterns & projects


#1

So my stomach just turned around a bit…

I’ve been thoroughly backing up projects since 2017 when the Digitakt was released. All in good faith that the backups were succesfull as the C6 software detected data coming in and the size increasing as projects became bigger.

Now I’m trying to backup a couple of seperate patterns from one Digitakt and send them over to my second Digitakt. No dice. The pattern is empty, sample slot is at -1, tune shows ‘error’, and all the parameters are in full left position. Playing the pattern even results in a full freeze.

So I tried backing up and sending an entire project. Same issue. Whole project empty. It’s also acting very strange in that it takes time for all A1 to a16 patterns to load and then B1 until H16 are loaded within a second.
Then, to be sure, I backed up one pattern from a Digitakt and send it to the same Digitakt. Same problem. I am now very afraid that all the backups I have ever done are completely broken. Either that or there is something going wrong on the receiving end.

  • First I noticed a midi LFO sending data while backing up, so I disabled it to see if that was the problem: nope
  • I have set the midi setings to output only USB and when receiving to USB only input.
  • When sending sysex to my laptop it receives data. Each project is about 31kb and a project about 4MB
  • Both units run latest beta 1.11OS6

Anybody came across this issue and know how to fix this? I’m completely stumped that this doesn’t work…


Total Recall - Digitakt
#2

Bad situation, i can’t help, but maybe the video in this thread helps?


#3

If you are on a beta firmware it was mentioned in another thread that backup and restore is broken.


#4

holy moly…

@Olle can you confirm?
That’s pretty scary tbh.


#5

Yes, the SysEx in the beta seems broken. It should be solved by downgrading first but, let me test a few things in the office tomorrow to be on the safe side before you do any downgrading.


#6

Thanks olle, really appreciated.

Do you know if it is broken on the receiving end or the sending side of things?


#7

Not sure right now, but will soon.


#8

Yea I had the same experience. Tried to load my DT backups to another loaned DT while mine was in for repair and it would not work no matter what I tried. 1.11B6 on both machines.


#9

Hi Olle, did you get chance to test this? Interested to hear your findings…


#10

I know this isn’t the same thing, but I just recently accidentally recovered some old patterns from Total Recall.

I was testing Total Recall a few weeks ago, and since it stores the whole project I was pleasantly surprised to find several old patterns I deleted.

So now I just created a project in my DAW for each project I want to back up, and turned on Total Recall (esp after reading this thread!).

I don’t have 2 DTs to test this with, but I wonder if you can recall on a 2nd DT to either restore from a backup, or to transfer entire projects between DTs.

Best regards,

Gino


#11

Yeah could try that. Good idea to back up single patterns. From DT to another DT won’t work though as it is working with a specific identification string or something to recognize the project to recall.


#12

bump


#13

I’m glad this has finally been acknowledged, I’ve raised multiple tickets about this over the last couple of months and Elektron support finally got back to me confirming this today.

It’s so bad that they’ve not fixed this in an updated beta and have just let it run for months.


#14

Whoops, wish I’d seen this before backing up my projects prior to a full reset of my Digitakt. Mine was doing very weird stuff with the sounds - appears that the sample links got messed up somehow - and now I have 2 projects I can’t restore. Any update on whether this is on the backup or restore side? I’ll happily downgrade the OS to get them back if need be …


#15

I wasnt aware of this. I loaded up a bunch of sounds over sysex and it seems to have worked just fine, I’m on beta


#16

The backsups are fine. It’s the restore which doesn’t work. Once they fix the problem, existing backups should be ok.