Analog Four/Keys OS 1.35: bug discussion


#22

same here


#23

DId make one too
they said dev is on it soon


#24

I can’t seem to get parameter slides to work properly today. If anyone could double check that would be great, not sure if a pattern has corrupted or something like that.

Using mk.1 OS 1.35 :slight_smile:

edit: tested with an empty project/power cycle and the issue is still there, definitely seems to be a bug

edit again: set up a completely empty project and it worked, went back to my project and it magically works again! some kind of weirdness :joy:

Anyway, a project compatibility bug but easily fixable.


#25

I’m getting this same issue but on mk.1 A4…


#26

Ok, so one mk1 and one mk2 with wrong octave led showing. Anyone else care to check it out?


#27

confirmed pattern change bug fyi


#28

i send a support ticket Request yesterday about the pattern change bug


#29

Unsure whether that’s intended behavior, but didn’t notice it before:

Set an oscillator’s “coarse tune” to any value other than 0 (let’s say 12).
Then set that oscillator’s “fine tune” to some arbitrary value (let’s say 20).

Now when using the function button to snap the “fine tune” quickly back to zero, the “coarse tune” also snaps to zero. (I’d have expected it to stay unchanged (in this case, on 12).


#30

Another thing I never noticed bevore:
In Scale Menu of Pattern length when turning not the Level Poti left of the Display, but some of the 10 Potis on the right side. They will react and parameters will be changed on the page selected before opening the Pattern Scale Menu.
Is it a bug or normal behavior?


#31

It’s a horrible oversight imho, I’ve mentioned this to Elektron a few times over the years

worse still is if you accidentally accelerate the coarse tuning to either extreme, then the fine tune is forced to one extreme - I understand the numerical connection between the two values, but the user experience of working with these values is a let down (not necessarily a bug) and it’s been there since the beginning - the state of either dial should be protected in certain circumstances … e.g. iirc (not near a4) quick-zeroing fine tune will unhelpfully zero coarse too

I create fast octave locks by pressing the encoder, it should not be possible to reach either extreme whilst doing this … this is how you end up with out of tune oscillators when the fine is minimised - it’s just an unhelpful algorithm which is dealing with the extended resolution range, something which could be easily improved imho


#32

I can confirm that this is happening and i do not want that to happen :face_with_raised_eyebrow:

:grinning:


#33

I feel like this is not a bug as the scale menu/pattern length menu is displayed as a popup, and not as a screen (it does not totally replace the information beneath). So it makes sense in a way that the right pots still do their thing to the screen underneath. It serves no puropose tho, and I’ve been fooled before too, so it may be bad UX.


#34

There’s a dim red light on the bottom octave of my analog four even though it’s not p-locked…


#35

I’m 3!!! I sent tickets. Silent. I have in test mode, gives an error. A very unpleasant moment. I’m not even in the mood for work. This is the most interesting - perfomance!


#36

Scale menu, all entries: Func + Track Level knob is counting upwards instead of downwards when turning to the left.


#37

Not sure how it has been before the update (have the device only a short time):

Pressing several (e.g. 3) trigger buttons in grid record mode simultaneously can clear accidently the complete settings on one trigger. Holding several buttons can be used to copy multiple triggers and paste somewhere else or to change any p-locks for all triggers at the same time. This is a great feature. It seems that this is working in the correct way if I press and hold the buttons each after the other. Pressing three buttons “at the same time” causes this problem.

Can someone confirm that this is a bug?


#38

Had strange behaviour of loosing last kits and patterns after saving a project and was looking if this is a bug or my mistake. I saw now:

Press project-button long gets me to list of projects and to load a project. (It comes the message “Any changes will be lost - proceed with loading? y/n”. I haven’t read it carefully and thought it would just be a warning that I am going to overwrite the selected project and that I am saving the project - which would be helpful there, too, btw)

Press func + project (= save project) too quick together could also lead to the load menu (already a bug). Cancel with no. Press func, hold it, after a short time press project. Sometimes it gets into the load menu again instead of the save menu. This behaviour is a bit buggy.

I would suggest beside fixing the buggy button behaviour:

  • add a warning message before overwriting an existing project
  • add a headline with “load” or “save” at the top of the project list to make it more clear

At the moment I am glad that I found the reason for loosing kits and patterns.


#39

When I hold a trig to show its parameters, the mini keyboard is showing a dim LED a few octaves below whatever note I have p-locked. Not affecting playback but it probably shouldn’t be there, unless it has a purpose of course…


#41

On the OSC2 page 2 screen, I can only set ‘MET’ on the SMD option. Seems like 1-2 / 2-1 are completely missing.

Can anyone else verify this?

Also, is it safe to downgrade? Unfortunately I’ve already saved a few projects with 1.35 so I guess I shouldn’t load those on an earlier OS

Edit: Tried downgrading and got ‘NVRAM restore failed’ and then ‘Error Loading’ on projects saved with 1.35. Apart from that it seems ok but I upgraded again to have access to my newest projects. I guess I’ve got to wait for the next bug fix release.

Edit 2: I found a fix for this by simply loading a preset patch that uses one of the missing options, in my case I used the ‘Snakecharmer’ patch from the factory content. And the missing options magically appear for all tracks!


#42

Oh man, - it’s really sad to see how sloppy bug fix releases are done nowadays at Elektron. All reported regressions/bugs here should be easy to catch by QA :frowning: