Weird XLV behavior on Octatrack MKII (1.30D)


#1

From scratch, I assigned a different sample to each track 1 thru 7. Track 8 is mater.
Scene A is 1, B is 9. Both scenes are cleared (no locks).
Crossfader is all the way to the right (scene 9 fully engaged).

At this point, I hear all 7 tracks, as expected. From here:

  • In scene 9, lock track 1’s XLV to XMIN --> Track 1 is now muted. As expected, no problems here.
  • Clear scene 9 again, and do the exact same thing with track 3 --> Tracks 3, 5, 7 are all muted!
    Why are tracks 5 and 7 getting muted, even though I only locked track 3’s XLV?

And then a further mystery: From this state, I mute scene 1 (which has no locks, so this should have no effect) --> Tracks 5 and 7 are unmuted, only track 3 is muted (as originally expected).

Is this a bug, or am I missing a subtlety with how scenes work?

Note that this only happens with XLV. If I lock XVOL instead, things work as expected.

Thanks!


#2

Do you have midi connected?
Can you reproduce the issue with a new project?


#3

No midi connected. Yes, I reproduced this on a new project (existing set).


#4

So to sum up, to reproduce the issue, I just need 7 tracks with audio and plock track 3 XLV?


#5

Correct. Thanks for looking into it btw! Happy to send more details or a video if needed, when I get back home in a couple hours.


#6

I gave it a try, luckily it works as expected for me. 1.30B.


#7

what happens when you adjust XLV of track 2 or tracks 4-7? I take it since you don’t mention them doing anything weird they behave properly like track 1 does?


#8

I changed track 8 to a normal one and repeated the steps for each track. Here are the results.
In each case, the crossfader is all the way to the right, scene A (1) is empty but not muted, scene B (9)'s only locked parameter is that track’s XLV --> MIN.

Track 1: Track 1 muted (ok)
Track 2: Track 2 muted (ok)
Track 3: Tracks 3, 5, 7 muted (bad)
Track 4: Tracks 4, 6, 8 muted (bad)
Track 5: No tracks muted (bad)
Track 6: No tracks muted (bad)
Track 7: No tracks muted (bad)
Track 8: No tracks muted (bad)

In each case, if I mute scene A (which is fully unengaged and has no locks), then everything works as expected.
If I set scene A also to scene 9, the weird behavior persists.
If I repeat the whole thing with scene slots A and B swapped and crossfader all the way to the left, I get the same results.


#9

Are your tracks’ machines static ot flex?


#10

They are all static machines.


#11

your test-case is pretty clear and simple, you’re starting from a blank project, and it’s hard to imagine there’s any user error at work. If my machine was doing that I’d be assuming a hardware issue, but I’m not sure how that behavior could be caused by a hardware defect, very strange. I would open a support ticket


#12

Really weird indeed. I don’t think it is an issue with previous OS / MKI, or it would have been reported many times.

I’d try it again and again with new projects, Static and Flex, nothing plugged in OT (midi / usb).
I you want you can post a compressed project with that issue, with short samples (1 bar), so we can test it. Ideally, someone with 1.30D would test it if other OS users don’t have that issue with your project.


#13

Thanks everyone for confirming this is in fact weird, and not due to my lack of knowledge of the OT :slight_smile:
I reproduced this a couple more times with a fresh project, with flex and static machines.
I’ll file a support ticket, and see if I can export the project too.


#14

You can make one with short samples and use the PROJECT > COLLECT SAMPLES function

Compress / zip the project folder after.


#15

PROJECT 181225a.zip (375.7 KB)

Here is a project demonstrating the issue.
Tracks 1 thru 8 have one sample trigger each, on steps 1, 3, 5, 7, 9, 11, 13, 15.
Each track is pitched such that they play CCDDEEFF in short-long pairs
Scene 9 has T3’s XLV locked to MIN.

Expected: When crossfader is all the way to the right, I should hear CCxDEEFF (x = silence)
Actual: I hear CCxDxExF. If I mute scene A, I hear CCxDEEFF as expected.


#16

Just filed a ticket. Looks like Elektron support is out until Jan 2nd - oh well :santa:


#17

if it’s any consolation I don’t really find XLV that useful :sweat_smile:

edit: is seemingly nonsensical design decision to limit setting post-fx track levels with xfader scenes to only maximum or zero. also don’t like the curve of the XLV and how it maps for doing a fade-out, feels/sounds wrong 99% of the time for me and not enough control


#18

I tested it, muted track 3 with scene B / 9 / XLV : normal behavior.
1.30D bug? MKII? :slightly_frowning_face:

:slight_smile: I’d rather use VOL or XVOL too but XLV can be needed in certain circonstances. If you record a track with SCR3 T1-T8 / CUE, XLV don’t affect recording level. VOL and XVOL do.

Edit : and as you said, XLV is post fx, which can be interesting with a lock delay or whatever.


#19

if they give us VOL and XVOL for proper control of pre-fx gain/levels why not a LVL for the crossfader scenes to go along with XLV? is a very unfortunate omission that makes dialing in crossfader scenes more difficult than necessary, sometimes I resort to using compressor gain and/or a neighbor track for access to proper post-fx gain control via the xfader

this might be my #1 complaint about the way levels are handled inside OT, since in my mind it’s so important and crucial for really maximizing the crossfader, which I essentially view as mixer presets - but it’s lacking a proper post-fx track level control, which I consider pretty important for mixer presets… :laughing:


#20

I agree. Same for CUE !