Weird tempo of a sample


I am having a weird issue with my samples… Basically I took some of the full tracks I use for dj’ing, converted them to my octatrack and tried to mix the tracks using octatrack, same way like I do on cdj’s or turntables but I hit a wall.
No matter what I do, some of the tracks are having wrong tempo and I can’t get them to match nicely.
I know the situation sounds stupid but… I know that both tracks are 174BPM so I loaded these tracks (both are wav, 24bit, 44100khz) into a static machines, opened the audio editor, set the start to the downbeat and ensured that the bpm of the sample in the ATTR page is set to the expected 174BPM. I warped hundreds tracks in ableton, I create all the beatgrids in rekordbox and serato so this is a process I am familiar and know how to do it precisely.
One of the tracks is fine and it perfectly matches the metronome etc. while the other one (and about 2-3 among the others I tried so far) feels not right at all.
For some reason it gets timestretched (omg why???) even the attr is set to 174BPM, same like the project tempo and if I disable the timestrech, this track plays much faster than it should be (I’d say like 190-200BPM) - there is no pitch change set or anything obvious to me. If I mount the CF card and play the concerned wav, it sounds normal…
Am I missing a point somewhere?

Thanks for help!

Faster without timestretch nor pitch, with a 44100 Hz file?
Pitch is not higher by ear, it sounds like timestreched ?
Seems weird.

Yeah its weird and I am very confused and frustrated… :frowning: If the timestretch is enabled, it timestratches even it sould not (the sample tempo matchest the project tempo). If I disable the timestretch on the track level, the sample plays faster than the original. Its almost like if the OT “sees” the original sample/track differently.

And you’re sure the pitch is not higher when it’s played faster ? (By ear)
I’ve never had a faster sample without pitch nor timestretch, right sample rate with OT…

Double check everything maybe.
Timestretch, pitch, plocks, lfos, scenes, attributes…and the file’s sample rate.
Edit : easiest is with a new project of course.

You can send me an MP if you want me to check your files. Not hundreds ! :slightly_smiling_face:

Checking attributes with a long file reminded me the tempo 0.25 stupid increments !
With FN+ left/right arrows you have 0.04 increments but it doesn’t match the xxx.x tempo !
That’s totally stupid.
I’d prefer tempo with 2 digits, and/or 0.01 increments. Even 0.1 would be better.
Not logical at all.
Need a computer for specific tempos.

1 Like

You have to push the encoder down or press yes after you set the bpm.

1 Like

try making 4 bar loops in the daw prep stage … or if you are using that already try making a 2 bar loop or an 8 bar loop of the particular section irritation scenario… the OT might take to it better for some unknown reason… a different perspective or timestretch victory perhaps.

although sometimes things don’t always work perfectly with the OT, from experience the machine is quality and if you go for the things that are working nicely then hopefully it all comes together just fine in the end.

the OT does have a quirky personality but most of the time behaves quite reasonably.

1 Like

Isolate between the OT hardware layer and the x.wav software layer by encoding a new version of the file. ( don’t copy the one that plays weird in the OT to test with )

Just saying, even if it’s only a few files out of the batch, and taking into account the OT limitations, shouldn’t you ask the question “where is the error being introduced? Is it the OT’s limitations or the software used to create the files I’m playing in the OT that is creating this playback issue?”


Seems like a wrong sample rate or something, never had the OT play something at the wrong speed if timestretch is disabled…

Make sure timestretch is off in the flex/static setup page, that overrides the attributes setting unless set to “auto”… Make sure pitch on flex/static main is at zero and that there’s no lfo depths up that your not using, they default to pitch…

If you do use timestretch make sure there’s an arrow pointing to the bpm and not the bar length, the arrow means it gets priority…

1 Like

fascinating, i didn’t know about this…

talking of bpm, sometimes with some files the OT does not display the bpm in the preview screen when looking for a file to load to a track.

and yet the file plays totally okay and in the Audio Editor the bpm is displayed as usual.

1 Like

Haven’t noticed that… Mines pretty much a looper with only a few samples loaded. I’ve read the manual a bunch of times so I remembered the arrow thing…

1 Like

Ah yes, the gentle art of manual reading.

i just tried selecting between Original Tempo, Trim Len and Loop Len … the arrow does change position by selecting Yes.

Prioritising … very cool!


Maybe its a well known problem, but my recordings are all recorded with a x2 tempo value in Attributes, if I select RLEN = MAX, use QREC = PLEN. Edit : it happens below 80.7 BPM, from 80.6.

Didn’t noticed that before, as I usually don’t use timestretch with my recordings, or used RLEN different from MAX. With RLEN = 64, tempo is correct only if I record 64 steps.

How do you use that? I tried the 3 possibilities, wrong tempo.
With Quick Rec you can check Attributes tempo while recording, and the Arrow goes in front of Original Tempo when you record.
Tempo value is correct while recording, then it is x2.

Does it mean that below 80.7 BPM it’s not possible to record in live conditions something longer than 64 steps you’d like to time stretch with RATE for example ?

Edit : answer in the manual, but I thought tempo guessing was for CF files, not recordings !
Wrong tempo values BTW, (80.7, not 85 BPM), and musically 80 BPM is still too high for certain songs. :sad:

The tempo guessing algorithm analyzes the sample filename for tempo figures,
checking if the initial guess is off by a factor 0.5 or 2.0. The ”normal” BPM range
the Octatrack uses to make its initial BPM guess is 85 BPM-170 BPM. If you have
loops with tempos outside this range, it might be a good idea to put the BPM value
in the filename. Typically, a 70 BPM loop is initially loaded as 140 BPM loop, but if
the number 70 is found anywhere in the filename, the octatrack will use 70 BPM
instead. Similarly, if 280 is found in the filename, the BPM of the sample will be 280.

Yeah, I’ve experienced this with PU’s as you can’t turn timestrecth off for those… I think it has to do with this:

(Which I see you spotted in your edit… :slight_smile:)
Although realistically the value range is slightly different. The opposite is true as well where if you record at too high of a tempo it will half it… I think it works with flex recordings and timestretch disabled…

It’s useful for OT to guess tempo if the sequencer isn’t going, but I think that if your recording sequencer synced loops using qrec and already have the sequencer running it should just set the bpm to the sequencer (which it does if it’s in the range). Seems a “bug” or rather something obvious that wasn’t implemented…

The arrow business I haven’t messed with I just remember it from the manual… I always just make loops synced to sequencer within the bpm range and it works flawlessly and never have to mess with anything… I don’t really use pre-made samples…

1 Like

Yep, I thought tempo guessing was only for external samples, not recordings. An option with recording tempo = sequencer tempo would be nice. I’d use 64 max if I needed time stretch.

The actual range is 80.7 - 161.4 ! @elektron ?


Hey all!

Thanks for all your input! I have tried almost everything mentioned in this thread but no luck… I also tried to create a new project and start over but I hit the same issue with a different track.
Same like previously - one track plays noticeably slower on the OT than exactly the same file does when played on my computer. The track is 174, but when played on OT, its much slower so I can’t timestretch this track properly.
I have exported the project including the files for those who would like to try and repro…
Basically there are 2 static tracks - track 1 and track 5. Both are set to “play free”.
While the track 5 perfectly matches the the OT tempo and locks to the sequencer tempo thanks to the quantization, track 1 doesn’t play nicely at all and even the track is 174bpm, it can’t be matched… At the time of saving the project, the timestretch on T1 might be disabled and pitch might be not 0 - its because I tried few things so don’t forget to change these values…
you can get the set here:

Thanks for any input!

Are there any fluctuations in BPM in the track. If somehow the information was retained that may be your problem. even the smallest fluctuation of 0.1 bpm can affect an export and at such a very high bpm this seems likely. Warping may not have helped and you may have to do it manually with markers in Ableton. I dont think its a problem with the OT but in Ableton itself.

Its not wraped - its just a converted mp3. If I play the same file on my cdj, its stable. If I try to wrap this wav (the one used on T1) in Ableton starting at the very same point as the start marker as 174bpm straight, its also ok and I don’t need to do any adjustments nor add any additional warp point.
What really mystifies me is that the track definitely sounds slower and little bit pitched down when I listen to it on the OT with TSTR off when compared to the same wav file listened on the computer… I have absolutely no explanation for this to be happening…

Try cutting the track up into smaller parts then exporting. See it that works. There may be some that stay at 174bpm and others that dont. The high bpm may have small innacuracies that the OTs software algorithm has detected.