USB bandwidth: what's the deal?

Hi, I have tried several times to use OB to record individual channels of my Elektron gear into my DAW. Whatever DAW I use, and whatever Elektron device, I can’t get over 6 input channels, when I add 1 more, (or a output channel) I get the message that there’s not enough USB bandwidth.

No USB hub is involved: just one Elektron box direct into computer. I didn’t even check with more than 1 Elektron connected.

The same computer handles the 32 ins and 32 outs of my audio interface over USB2, 24bits 48k just fine (DAW running at 1024 samples buffer, but I could get away with much less, I chose 1024 for safety only, I don’t play any virtual instruments so latency is not an issue.

Overbridge chokes on 6 channels 24 bit, I need to set it to 16 bit. Is there an explanation?

I did a forum search, but only found old posts. BTW, this is on a a Win10 PC.


Are you using MK1 devices?
When I remember correctly these have a bandwidth limitation on USB so you will have to swap to 16 bit of you want more channels at the same time

check following threads:


Yes I tried with my Analog Keys. You’re correct, the Digitone doesn’t give me a “too many channels” message, I can’t even switch channels on and off, everything is enabled bt default. So it fair to suppose it’s a MkI limitation? Good to know, as I’m in the market for a AR MkI. It’s not a HUGE deal, but I was a bit surprised. Thanks!

As others also mentioned using a hub with MTT capabilities could solve your problem
Keys is MK1 device :slight_smile: with limitation
You are welcome

1 Like

I’ll look into that. So you suggest that a MTT capable hub could help to get more bandwidth for my MkI devices? If so, I’ll get one. Do you happen to know if the quality issues with the Overhub been solved, or are they still as fragile as many reports suggest?

Analog Keys has USB 2.0, unlike A4 and AR MK1.

With a MTT hub, if you plug in a lower speed usb device, the other ports can still go at their max speed.
A lower speed usb device on a STT hub will cause bandwith on all ports to go down to the speed of the lowest speed device currently connected.


Ah sorry, my fault
Covered here: USB 2.0 with full speed

Yes, I knew that. Thanks for the Quick Start manual but I think I’m past that stage right now :wink: And that doesn’t explain why my AK can’t send more than 6 channels over USB2 via Overbridge, plugged directly into my (desktop) PC, no external hub involved… (Tried on my laptop, with the exact same result!)

It’s a limitation of USB 1.1 speed that it runs at. There is no way around this on Any analog Mk1s and it is well established and ought to be carefully discussed. The message from OB has nothing to do with whether you have a hub or not. The hub just potentially preserves the bandwidth that other older usb peripheral devices might otherwise steal. MTT hubs are only of use to pre proper USB2 devices

1 Like

Yes, but like @Schnork mentioned, and as seen in the document he linked to, the Analog Keys is USB2 not USB1. . Futhermore mine is on a internal USB controller on it’s own. The “big boy” (my Soundcraft mixer with 32in/32 out over USB 2 ) runs on another internal hub as you can see here:, so they don’t steal bandwith from each other:

Device manager USB

If you read what I said I stated it runs at 1.1 speeds. This has been endlessly discussed and the reason is documented. The hardware is 2 spec but it simply cannot be run at that speed or it introduces noise in the analog circuits. So as mentioned, it runs at 1.1 speed, not 2 not 1, irrespective of whatever you look at. That’s why OB has the warning message. It’s normal and cannot change. The issue was fixed in the Mk2s which also have similar usb2 hardware. It’s just that they can run at that speed and offer superior bandwidth. This is well discussed, search usb 1.1 or look up usb full speed specs


I read what you stated but without any explanatory links or other evidence I don’t take what anyone says for face value. If the official documentation says it’s USB 2, how could I know that I need to do a search for USB1 to discover it’s USB1. OK, problem, solved.

From the overbridge manual. Appendix C bandwidth limitations for older devices. As someone whose not used overbridge, this took maybe 2 minutes to find.


The 1st gens are “Full-Speed USB 2.0” devices, not High-Speed USB 2.0.
High-Speed USB 2.0 devices run at 480 Mbps (2nd gen devices, digi machines etc).
Full-Speed USB 2.0 devices are actually 12 Mbps USB 1.1 products. Hence the limited bandwidth.


As soon as Overbridge was realised i made the decision that the best thing about Overbridge was simply rhe powerful DAW integration for device setting project recall and automation.

Trying to incorporate the mk1 devices as USB audio streaming was not nearly as good as running analogue outs from them ausing overbridge silent but still synced up for recall. Of course a user requires the hardware to deal with the analogue outs.

That’s what I do too. I’ve 64 physical inputs on my mixer, but “only” 32 channels over USB to the DAW. Was just experimenting with Overbridge to see if I could speed up the workflow and save some money on cabling: quality audio cabling is an often overlooked item in the budget and I’m a bit tired of spending big money on multicores.

I don’t mind OB streaming really (but it could come in handy if I exceed my 32 channel limit which has happened once or twice, but surely not that often). I don’t even use the editor much for sound design, usually I use only them if I get lost in a modulation matrix.