RTYM OS Upgrade stuck at "waiting for sysex"


#1

Ok first off… im not new to the OS upgrade process using C6 on all of the Elektron products, so I know how C6 works and the OS upgrade process.

The problem is that my A4 updated fine today, but RYTM is stuck at “waiting for sysex”. C6 is seeing the RYTM in the ports section, handshake is on, I can even see the RYTM in the Overbridge window using the same USB cable, so I know my mac sees the RYTM and its not the cable.

I’ve even tried to use the function and power on to do it through there and still same except its says “ready to receive”

I’ve done this on both my macs and the A4 works fine, but the RYTM wont on any machine. I’ve rebooted both macs and the RTYM multiple times also.

I’ve done a factory reset to be more sure its simply the RYTM acting dumb.

Is anyone else having this issue?

Sucks because I have the new OB beta that came out today, but the last RYTM OS isnt supported until upgrading to 1.22… and my RYTM wont upgrade.

BTW the OS on my RYTM right now is 1.21C


How do i update rytm 2
Transfer Beta 1.46
Issues updating Rytm to 1.22
#2

Try turning off Overbridge mode on the Rytm.


#3

I’ve got the same issue both A4 and AR. Just installed new OB beta and can’t upgrade boxes OSes via C6… both stuck at waiting for sysex while the file is being transferred.


#4

Ok problem solved but not in a good way… seems like the Overhub was the problem??? I unplugged the Overhub and stuck the USB direct into the mac and it worked.


#5

Yeah that’s what it was thanks!


#6

I hit the same thing. Worked out the answer above myself. :slight_smile:


#7

had the same problem with upgrading both A4 and AR from 1.21C. no overhub, no overbridge mode though.
amusingly, in my case, all it took was clicking send in c6 a second time. didn’t even have to bother with resetting either the elektrons or my macbook. really all it took was a second click…


#8

Thanks, that fixed it for me.
Now let’s see if OB actually works in Logic! :slight_smile:


#9

Same here…tried everything (even OB settings)…plugging directly into my iMac and not by USB hub did the trick, no idea why.


#10

Maybe its best to upgrade the Rytm OS first? I didn’t which meant I had to use a regular MIDI cable to send the sysex, nothing showed up at the RYTM from C6 via USB after I upgraded to OB 1.10.0. check port config to make sure you can receive to the regular port.


#11

I had a similar problem. I plugged my AR into my keyboard usb (Mac) and this was the problem. Once I plugged the AR directly into an USB-port on the back of my iMac, it worked.


Rytm not updating [resolved : corrupt syx file]
#12

found it.


#13

Analog Rytm Mk 2 with this issue. Tried C6, Midi, USB, TM1, Sysex Librarian nothing works.

How do you update this?


#14

Same issue with 1.46 beta. I am “ready to receive” forever. Story of my life.


#15

I managed to update mine by trying a different mac. Go figure!


#16

My digitakt is stuck too. I was so happy to try the computer then it showed me why I’m dawless


#17

Thanks for circling back, I’ll try that. I might have a few of those laying around!


#18

Tried another Mac. Didn’t have Transfer on it yet, nor overbridge. Downloaded the 1.46 beta, Transfer and Overbridge. Installed in order Overbridge (rebooted), then Transfer. Transfer recognized the RYTM MK2 and moving the syx file to it was instant, then it rebooted. So a different mac worked for me too. Hopefully the solution in the future isn’t a 3rd or 4th because 2 is all I have! :wink: It could also just be fresh installs of overbridge and transfer, or that I was paying closer attention! Who knows?! Lotsa luck.


#19

I tried with a different computer and still doesnt work! just dont know what to do!!!


#20

Sorry - I’m no expert. What happens when you run Transfer? When I launch Transfer and the AR is connected (and ports set at MIDI config/Port Config to USB in and USB out), Transfer starts on the Connections screen. I can select Analog RYTM Elektron MIDI there for MIDI in and MIDI out, and Connect then “connects” which takes me to the Drop screen. Once you’re there you’re all set I think. You plop the new syx file in there and it should be automatic from there. If you don’t get to the point where Transfer sees the AR, I’m not sure where to go. Probably not worth continuing to try different computers, rather troubleshoot the main one and get it going from there.

Also, on System menu / USB config / Overbridge mode is checked.

Good luck!