Rigging a Midi Keyboard to an Analog Four

I’ve never programmed a Midi Keyboard before(had some experience trying to program a Midi Pedal to an Octatrack…which seems like a easier gig on account that it’s just Midi Notes, instead of ranges). But right now, I have a midi keyboard plugged into my A4. And it works for Voice# 1, but regardless what voice I have selected, only Voice#1 is being played from the keyboard.

Anybody know what the keyboard needs to be programmed to?

You just need to send midi to your AUTO channel. By default your midi channels are set as follows,

track 1 = midi channel 1
track 2 = midi channel 2
track 3 = midi channel 3
track 4 = midi channel 4
FX channel = midi channel 5
cv channel = midi channel 6

then it skips 7

performance channel = midi channel 8
AUTO channel = midi channel 9

if you send midi notes to midi channel 9 it will play the sound of whatever track you have selected, or whatever sound you are currently browsing through. I’m pretty sure this is what you are looking for.

3 Likes

Thank you very much, sir! I’ll definitely try that!

I have a question regards the A4 in combination with my S61 midi keyboard from NI.
I connect the A4 via USB to the mac and use ableton live.
Is it possible to play the A4 via the midi keyboard on every track?

At the moment I only can play the first Track No.1.

Best regards,
Marc

autochannel?

1 Like

Use the Autochannel feature (described in the manual in the section on the GLOBAL > MIDI CONFIG > CHANNELS menu) to have incoming MIDI messages control whichever is the active track on the Analog Four.

1 Like

Thank you for your fast replys.
Will this also work via USB only, means the A4 is only connected via USB and the S61 midi keyboard also?

Yes.

I set the under Midi config / channels / the Auto channel to 9.
Unfortunately the midi keyboard only play track 1.
It is the same when I change the Auto channel to 2 for example.

Have you configured your keyboard and Ableton Live so that they send out MIDI messages on the channel number that you set for Auto channel on the Analog Four?

On the AF, are you selecting the track that you want to control from the keyboard?

It seems that my midi keyboard work on midi channel 2, this is also the setting in the ableton track.
Unfortunately it seems that I can´t change this midi channel.

I can play the analog four via the midi keybboard, but evry time only track 1 from the A4.

Why not? The S61 can assign a MIDI channel number to any key zone, and I would be surprised if Ableton Live cannot change the channel of a track.

The workaround is to set the autochannel number of the AF to be 2 and to ensure that none of its tracks respond to channel 2.

I assign in the Controller Editor of the S61 the keyzone for one whole keyzone to Channel 9.
In the A4 I set the Auto channel to 2.
It play only the track one via the midi keyboard.

In ableton the track is set to:
midi from: komplete kontrol S61
channel 2 (no other channel works)

This seems foolish if you are now trying to address channel 2 on the AF.

I hope that an Ableton Live user reading this can help.

On the AF, are you selecting the track you want to play?

What MIDI channel numbers have you assigned to the various tracks on the AF?

Yes, I selecting the track that I want to play, but always track 1 played.

The other midi channel number I assigned to the varios tracks in the AF are:
Track 1 channel 1
Track 2 channel 2
Track 3 channel 3
Track 4 channel 4
Track FX channel 5
Track VCV channel 6
Perf channel 8

Auto channel 9

Prog Ch in Ch Auto
Prog Ch out Ch Auto

So all you need to do with these settings is to get Ableton Live to transmit on channel 9.

1 Like

I appreciate your help very much, unfortunately my s61 does not take over the setting for the channel, for whatever reason

In the midi track in live, you can just set the output channel to whatever you like.

Did not use live a long time, maybe the row for that is hidden by default. Pretty sure that will solve your problem.

So just reset the A4’s channels to its default and just choose the output channel in live’s midi track.

1 Like

Find out a way now for the correct assignment of the midi channel for the S61 mk2, I have to use the komplete kontrol software - the controler editor dont work not longer for the mk2.

I assign now the midi channel for the S61 to channel 9.
When I now set in ableton channel 9 I hear the analog four track 1.

But unfortunately it doesn´t change the behavior that the midi keyboard only plays track 1 from the A4.

Any further ideas to solve the problem?

Look above, my first answer.

Found this pic online, as im mobile atm.

Left side, where there is the Juno, select channel 1-4 of your A4 to adress the voices.