Rec button issue

Hi there,

The rec button on my AR is not responding properly, after a few days without using the unit the button becomes “sticky” and it doesn’t have that loose feeling, if I really push it down it doesn’t come out easily. Is a 2nd hand machine, maybe the previous owner dropped some coke (cola :innocent:) inside.
So does anybody know if it’s easy and safe to open the unit and reach that button for cleaning?
Thanks guys

Don’t go straight to that course of action, the button caps can be gently pulled off … it needs some very careful pliering and probably some tape on the end of the pliers to prevent scuffing - the cap can be pulled straight up as it’s a simple friction fit … this will afford you a looksee at what is happening underneath - also look to see if the perimeter of the button hole is catching on the button edge - this has also been documented as a sticky button cause

in terms of cleaning if you find spillage etc i’d seek clarification from support to prevent greater damage if the wrong approach is taken - I guess you might find a fractured button which would need to be replaced professionally

best run any action past support first to prevent you blowing your warranty tbh - yhbw, but I can’t see them objecting to you peering onto the button if the cap is pulled of carefully

Thanks avantronica for the quick reply. How can I take off the button cap, by using a little tweezers ot nipper? or just pulling with my fingers

Sorry for the question… not to good in english. Got it now: PLIERS ! thanx again

Was easy enough! So, here’s the naked button, hope you can see the bright around it… looks something sticky. Is it possible to pull out that white cap? Got the feeling that the sticky stuff penetrated the axe where the cap is inserted

1 Like

Never tried anything beyond replacing a button cap. Ask support for best method tips or look back for good advice on here. It looks sortable so proceed with care

No, you can’t pull out the white cap. Depending on what that sticky stuff is, it is probably advisable to disassemble the AR and clean it up, so that the liquid doesn’t damage the PCB in the long run.

You could try to clean the switch with a Q-Tip and some alcohol, but I think the proper solution would be to replace it.

1 Like

Hi there,

I tried the q-tip-alcohol propyl. I did not use a lot (just in case…) looks like working as the button recovered its loose action again.
I’ll give you some feedback in a few days. Thanxs for the help guys.


After a few days the button feels better but not completely ok: now is slighty hard to push (mostly the 1st time you hit rec), but then the action is better and the button comes out nicely. Maybe with some more cleaning it’ll work as expected. So: I’d say propyl-alchohol helped cleaning out that sticky stuff around the withe cap.
Hope at long term this wont harm components on the board hosting the button; so my advice in case someone is going for this type of cleaning is don’t use too much product, try little, check, try a little more if needed. Cheers guys.

I had this same problem, but mine was caused by an intoxicated woman spilling wine. I did the same as you, cleaned out with 99.9% iso, but 5 months later my whole rytm stopped turning on. It voided my warrenty so i had to pay for the repair. They were very fast and cost efficient, and now i’ve got a near brand new rytm once again. I hope yours wasn’t as serious as mine!

Well, happy to hear that’s working again. Did the AR stop working because the use of that alcohol? who confirmed that? Hope mine will not follow… I got already a brand new AK that misses the CV keyboard calibration at startup (check my posts in this forum) and it needs to be recalibrated; that means going to Sweden… shipping costs around 150E. Just bad luck, as the instruments are simply great. Next time give that woman a glass of 99.9% iso…

The tech was quite sure it was corrosion from the wine sulfates and other sticky stuff. I live in Canada so the Los Angeles office was close to ship. 3 weeks total since the day I shipped it.