OT + M32 + Miditech Filter Box to filter out transport messages


#1

I am connecting a Mother 32 through the Miditech Thru/Filter Box to OT to filter out the transport (start/stop) messages. This somehow does not work, the midi notes are not properly received by the M32 and it only catches the notes occasionally.
I checked the filter box and M32 with another sequencer and this worked.
I checked the OT and the filter box with a drum machine and it properly filtered out the transport messages.
It only does not work in combination with OT + M32.
Anyone experiencing similar issues?


#2

Does it work properly without Miditech between OT and M32? (Eventually disabling Transport Send in OT).

I’d use a midi monitor to check what is sent or not.


#3

Yes this works properly if transport is disabled.
It also works through the Miditech box if all filters are disabled (but the internal sequencer starts of course).
Good Point with the midi monitor :slight_smile:
Edit: It appears that Note Off event is sent way too late when real time messages are filtered


#4

OT’s Notes Off are Note On with value 0. I don’t know if it’s related. Surprising.
Maybe late Notes Off cut Notes On…


#5

It is strange because Note Off is sent correctly, when Clock Send is deactivated in OT Midi menu. This also works even if OT is not playing but just sending midi notes in OT chromatic mode.


#6

I guess the Miditech is limited and add latency when filtering clock (24 messages per 1/4 note IIRC). I’d try with another midi processor, software eventually.


#7

I contacted Miditech support and they told me that this is a known issue and that the filter box seems not to be fully compatible with Electron Gear. They also do not have a solution for this.


#8

:sketchy: “it’s their fault!” :smile:
Midi clock is a standard midi message. I don’t know why Elektron clock would be worse…

I used several midi controllers with OT, never noticed latency. I can check one of mine with midi clock filtering if you wish :
Midi Processors with Octatrack