Octatrack MKII midi notes sticking in OP-1 and Organelle

When sequencing midi with my MKII one of my midi notes gets stuck playing in the OP-1 and the Organelle. Both of these synths have to go through USB midi converters because they don’t have regular MIDI in, and that’s where I think the issue lies. I think it has something to do with USB midi, and it’s totally ruining sequencing these devices. It works perfect with my Volca FM and SH-01A, both use a midi cable. Anyone have any ideas?

Did you try with Op1 and Organelle independently ?
Midi Hub ? I rarely use midi usb.

I did, both still have issues. It has to be because they both can be midi hosts

A midi note get stuck when it doesn’t receive a note off message (Ot : note off = note on with Velo = 0).

Maybe you send a lot of midi data. Do you send CC with lfos, or things like that ?
For tests avoid INF values for note LENGTH.
Avoid long daisy chains, long midi cables…

I need to see if it’s my OTMKII or all the OTMKII’s that are failing to trigger midi on the OP-1 correctly. Notes get stuck and most don’t trigger at all. Same happens with my organelle. Works perfectly with the Digitakt, and the OT works to sequence midi on my other synths. THings to consider is that the OP-1 and the Organelle are both host machines, however, I have no issues with he Digitakt so I don’t see why it would matter.

What I need is someone to make a sequence or just try to play their OP-1 over midi with their MKII and tell me if it works.

What are you using to convert DIN midi to USB midi?

If you are in fact trying to use USB midi from OT - then there’s your problem. Only DIN midi on the Octatrack.

1 Like

No, I have a small USB to midi converter. It works just fine with the Digitakt. Super bummer so far. Have you tried it?

No. Don’t have an OP-1.

What DIN to USB midi thingy are you using?

1 Like

Hobby Tronics USB-MIDI converter.
image

I know the Digitakt didn’t work properly w/ USB midi to start with. It was remedied at 1.03 or 1.04. Something with properly handling USB hosts and USB midi.

Now I’m speculating. But could it possible be that the firmware of the OP-1 or your Hobby Tronics is lagging on current updates?

Maybe on the hobby tropics but not the OP-1. I’ll look into that, but why would the op-1 work so well on the Digitakt?

If the OP-1 is working well with the DT, I guess it’s probably not a problem with the USB-MIDI host box, right?

Are you sending wildly different stuff from the DT, vs from the OT?

Have you tried reducing the system to the minimum, OT -> HobbyTronics -> OP-1?

Are there any particularly interesting conditions, when the notes stick? How frequent is it?

(I haven’t done much playing with OTmk2 + OP-1, but I’ve done some, but (unfortunately? :-)) I haven’t had any such issues (so far!))

I’ve been using a Kenton MIDI host, fwiw.

Ughhhhh. Ya I have tried that, I have tried everything. Maybe I’ll just get the Kenton midi host and see if that works better. Damn thing is over a hundred usd. :confused:

It’s probably not helpful, but I’ve had this happen with other gear over the years (thankfully not the OT so far). If I tried to sequence my old MidiNES from the MPC2000xl, all of the notes would get stuck on as soon as a pattern looped. Never happened with any other synth, and rarely happened when sequencing the MidiNES from any other sequencer. Similar, but less consistent, problems trying to sequence an MT32 from a Beatstep Pro - After a minute or two I’d start getting notes stuck at random and could only stop them by power cycling the MT-32.

Unfortunately I never found solutions for either.

Hmpf seems a lot to spend on a hunch… especially when the DT tests suggest your USB host is working ok.

What about another kind of testing, where you manually trigger notes, simultaneously, quickly, mashing the keyboard etc, and see if you can recreate the problem that way? Perhaps you will gain some insight into what exactly is causing the notes to stick (missed note-off?)

You could also try routing your MIDI via a computer, running some kind of MIDI spy tool to print all of the messages as they come through. Depending on what set of MIDI interfaces you already own, you could eliminate (or not eliminate) the USB host box from the test, too.

Are you sure there’s no difference between what you’re sending with the DT and what you are sending with the OT?

Ok… so now we know. Kenton midi it is I guess. I still don’t know why the Digitakt works, but it doesn’t matter anyway.

I don’t have any solutions but I’m interested, using the 3 big O devices here. Do you sync the op1 and organelle at the same time? I have the mk1, but I’m about to embark on a similar journey

Hi @mpiecora , i see this post is a couple of years old but was wondering if you made any progress on understanding what was wrong here? I have an OT MKII and have just bought an organelle M and I have the same problem when connected to organelle via its midi (jack) input (stuck notes) but don’t have any problem if I connect using a din to USB adapter cable. Any thoughts?

Unfortunately, I did not find an answer to that. I think the Octatrack sends a lot of unwanted midi data that argues with devices like the Organelle. I found that some patches work, and some do not, mostly they do not. Maybe there is something about the USB that filters some of the midi data vs the 1/8" midi adapter on the M.