Muting/unmuting multiple tracks at once is unreliable


#1

Hey all!

I noticed that it’s not possible to mute or unmute more than two audio tracks reliably. Half of the time, some of the tracks just would not react. For example, you press tracks 1, 2, 3 and 4 – tracks 1, 2, 3 get muted, but 4 does not. UPDATE: this happens regardless of whether the sequencer is running or not, and even in an empty project, so is not processor load dependent, it seems.

Anyone else noticed this issue?

I am on O.S. 1.11 but as I recall this also happened on older versions.


#2

Must admit I’ve noticed the same but assumed it was me not pushing them evenly or hard enough… I’ve have a closer look next time it happens


#3

No this is definitely not the case of me/you not pressing one of the keys hard enough. You can test this by stopping the sequencer, exiting mute mode, and pressing several keys at once very gently to trigger the sounds - DT will always trigger all the keys you have pressed. Also, when in mute mode, but sequencer not running, it will also mute/unmute all tracks for which you pressed the keys. Not the case only when the sequencer is running - it will skip mute/unmute actions at random. With all 8 top tracks, it will not act on 1-2 buttons almost every single time. Clearly a serious bug as it will ruin any real-time performance if you want to mute/unmute several tracks at once.


#4

Okay so this is also unreliable when the sequencer is stopped. Here is an example: sequencer stopped, entered mute mode, pressed keys 1-8 all at once (held for like a second) - as you see, tracks 1 and 6 remain muted. The other time it may unmute all, or skip tracks 5 and 7 etc. it’s totally random and unreliable. I hope this is added to the bug list and fixed in the next update, as it’s hampering the workflow quite a bit.



#5

This is easy to reproduce on my DT (1.11).

Even if I do mutes in sets of 4, it still seems to miss a few.
If you hold down all 8, it misses more.

Did you file a bug report with support?

Best regards,

Gino


#6

I’ve done tests on my DT (1.11) and find nothing similar-always mutes/unmutes reliably. Why doesn’t this thread post some videos to make it clear what you’re talking about.


#7

Ask and you shall receive:

Best regards,

Gino


#8

BTW this problematic behavior is the same with track mutes and global mutes.

This is clearly a serious bug and I am pretty surprised that it hasn’t gotten much attention yet, let alone wasn’t yet fixed in previous updates… I hope Elektron guys will get to this soon.


#9

I just checked mine… No prob whatsoever… I’m on 1.11


#10

How many tests did you perform? Was the sequencer running or stopped? Sometimes it works correctly even after a few tries (4-5), but then it does finally happen.


#11

Sequencer was running, tried both mute functions for about 5mn non stop, with 1 to 8 mute… No issues


#12

When did you buy yours? I bought mine in the fall of 2017. I wonder if it’s a hardware problem on some particular units. We really need Elektron to respond to this.


#13

Got mine about 6/7 months ago


#14

Gino, when did you buy yours? Trying to guess if it’s some issue on devices manufactured during some period…


#15

I should also add that doing ANY other action with the keys is totally fine. Such as: triggering multiple samples at once, putting multiple trigs at once, and so on.


#16

I have experienced the same issue muting/unmuting tracks while the sequencer is running. You have to be very deliberate with your presses to get consistent results and even then, the buttons don’t react to presses reliably.

The DT is such a great performance tool, this should be addressed.


#17

Just tested this with my Digitakt (v1.11) and I have the same problem.
However, mine doesn’t need the sequencer running for this bug. The muting is completely unreliable even with an empty pattern with nothing going on. This should be adressed ASAP.
edit: (I got mine almost 2 years ago.)


#18

Yes my initial statement that it happens when the sequencer is running was incorrect. I then tested this with an empty project and no running sequencer and still can reliably reproduce it. I think it starts to behave unreliably if you press three keys at once or more.


#19

Just to be sure, i ran the DT for about an hour… No prob on my side…


#20

I think this happened to me too but didn’t realize it was a bug… I’ll do some testing later