Model Samples Button comes out

Unfortunatey the Function button of my model samples comes out
Is there anything I can do? Doesn’t look broken, might need some re-assembly!
Tips are more than welcome
I already contacted support, but they have summer holiday.

(upload://ipckDybArsXIQnsdT8QhnvjPeN9.png)

It’s a known issue, see other threads here about it. Elektron say it’s with a small batch of buttons that had the wrong thickness edge or something. I don’t quite believe that, because I assume a “batch” of buttons like that would be in the thousands. Then again, it’s not happening to everyone (and hasn’t to mine). Anyway, all you can really do is get Elektron To sort it out, which they will when they come back.

Edit: I guess if it’s within the return window of whoever you bought it from, you could get a replacement, and hope it’s not part of the bad batch.

Thank you, just found the ‘build qualith’ topic
Too bad this is happening
But i expect this to be solved soon
I had some issues before, elektron support was always very helpful.

For reference to others finding this topic

1 Like

I also have the same issue, also sent a ticket recently. does anyone know how this cold be fixed?

The fix is Elektron sends you a new function button that was manufactured appropriately, as a warranty service.

2 Likes

I also have the same problem with trigger button 9. Have you solved it?

Has anyone actually opened a MS up?

1 Like

https://www.youtube.com/watch?v=kSbCc9jXnCw

2 Likes

Just happened to me as well …
have contacted support …

From the S/N it seems to be a 2019 unit

Oo now I want to yank mine out to see how it’s made

How did you find it out?

Actually, there’s a “MFGDT” tag next to the S/N that gives YEAR-WEEK, so i presume thats the manufacturing date code commonly used in electronics.
The same info as YYWW is in the S/N.

2 Likes

I wouldn’t mind replacing most of the rubbery M:S buttons with more plasticy ones (maybe all except the larger T1-T6 pads). So many of mine get stuck down halfway, I’ve even accidentally erased patterns because the FUNC button was stuck and I didn’t notice in time to back out of the change.

1 Like

Your MS also from 2019 or later?

Not sure if your question was to me but mine is 2019-W08, made in Sweden.

My func button broke 2 times already. I see it as a feature of the Model:Samples. It’s just too funcy! :slight_smile:

1 Like

2019 unit or later?

Funcy first batch yo!