MD Black Screen

My MD MkII (non-UW) is showing a mostly black screen at start-up :frowning: I’m able to Fn+Start and ran a test, everything checks out as okay, tried factory reset with no luck. This is the second time it’s happened - I got a new power supply about a week and a half ago and that worked like a charm… until today.

Is there an internal battery or something that I need to change? Anybody experience something similar?

Can you elaborate on ‘mostly a black screen’. When does this occur?

Also, are you able to access TEST-Mode when the screen is black? Does the screen work in TEST-Mode or does it remain black?

1 Like

Thanks for the reply. As I mentioned, it occurs right when I boot it up, and yes I can enter test mode and everything comes up as OK.

By mostly a black screen, I mean the screen’s filled with black pixels. Sometimes it’s just a few black squares and the rest of the screen is empty.

Hmm… I would guess either your screen has some kind of connection issue or the processor is scrambled somehow. This is not a commonly reported issue on the forums. If your MD is out of warranty you might want to open it and have a look around.

1 Like

The O/S might be corrupt?? Try resending the latest O/S by using the TEST menu.

Also, there is a connector between the two main circuit boards. From memory, if the connection is not secure you will get a black screen or distorted pixels.

Might be worth waiting for others to chime in before you consider opening her up.

Man, I can’t believe my eyes! I’m having this exact same problem. Sometimes it’s black pixels like yours, sometimes it works fine for hours, and sometimes I get alien messages like this:

Filed a Support ticket two weeks ago but still waiting for reply…

Yup, I see that one too, 4.33! Please let me know if you hear back from support. I’ll be submitting a ticket myself as well.

The odd thing is that the new power supply did manage to fix it, but only for about 10 days. So I’m thinking it’s probably not an OS issue or loose connection, but who knows.

I will, comrade. Please could you do the same if you hear from them first

Had that too was a problem with the mainboard and a connector,
mine had dsp issues plus the pixel vomit.
I think you are best off if you send it in for repairs as this seems to be some kind of flashrom or mainboard issue.
Also the repair wasnt that expensive eventhough my MD is out of its warranty

My OT woke up one day with a completely black screen. Because it was still under warranty, I sent it in for repair. The problem turned out to be a detached cable inside. If your MD is out of warranty and you are comfortable with opening it up, you might consider checking that all the cables are connected correctly inside.

I started getting lockups along with with these hashmark signs a few months ago. While I was waiting for support to reply, I had a conversation with Elektron’s former repair contractor in the USA, who told me the CPU is likely dying and needs replacement.

1 Like

This has just happened to me. intermittently over the last few days and the MD has finally given up the ghost!
Ironically, I’ve just got my OT 2 days ago and was thinking to myself " Eureka" now this! Blast…,
Mine too is out of warranty, it’s been back once already (£50 p&p)

Has anybody tried Kent Spong (in the UK) for Elektron repairs.

I bought a second powersupply of ebay for my MD. (non genuine)
After a few days the md would blank screen on start up. Or the sreen would switch on normaly and then fade to blank.
Turned out to be the new power supply power rating wasnt quite right for the MD. I ditched it and got a genuine psu and havent had a problem since.

I also tried using my genuine MD psu with my monomachine. (they are rated the same). After about half an hour the MnM screen went crazy.

It’s possible you may have a failing psu. Don’t go and pull the MD apart before you have checked the power supply.

1 Like

PSU - it’s the first place you go. :slight_smile:

1 Like

I had the same problem about 2 month ago. I fixed it with 2 Euro. mine was the button battery that was dead.

1 Like

Hey, guys. I tried to take the screen off the machinedrum in order to change it with a white one. And i messed up i think. The result after i put the screen back on is as you see from the pictures just random dots and pixels.
I used a chopstick to lift the screen from the pins after replacing it. And i damaged the board underneath the screen as you can see from the pictures. Is this the reason? Am not too engineering savvy. So if anyone can confirm… or if anyone had a similar issue. The screen is the original one - i did not put the replacement as it did not arrive yet with the mail. I was trying to see if I can remove the original first. Panicking here, if anyone can help…would be grateful…

and the screen…

I found a amiga 500 in a dump once that had close to 30 broken lines like this.
Any half decent old school electronics repairman can fix those “veins” for you.
FYI my amiga is still running strong and that was a loong time ago :slight_smile:

Yikes! :anguished:
Definitely looks like you didn’t just “scratch” the PCB, but cut through the protective coating, the conductive trace and into the PCB substrate. Picture quality is too bad though to tell whether its an easy fix as EasternNoise said or not.

That’s a shame.
Lessons learned: 1) let the professionals deal with it and 2) never use chopsticks to “force” a component up or out.

Geeze, you really dug into that thing!
I know, this isn’t helping.

But yes, it is possible to repair the “vias,” as they are called. Repair would involve scraping a tiny bit of solder mask from each of the 6 lines prior to the chopstick-chasm, and a tiny bit after. Tiny wires could be soldered on either end to bridge the gap. DON’T TRY THIS YOURSELF, though!