Machinedrum SPS1-UW X.10 Released [ Unofficial ]

Grab SysEx Librarian for OSX should be a better option C6.

Can help / troubleshoot OT <> MD tomorrow if need be?

4 Likes

I couldn’t reproduce it either, had them running for about 30 minutes, MD following OT transport, tempo and patterns. Tried throwing MIDI notes at it too but it kept working.

1 Like

I’ve not really had time to keep up with this but it’s all very exciting. I assume I also get all the features from X.04 if I upgrade? also any issues going from 1.63? I’ll do a backup obvs

Thanks for taking the time to solve this out @JustinValer @JSZ

I think I found the issue. I have a meloDICER module that gets converted with a Kenton Pro CV to MIDI and then goes in the MIDI IN of the OT. I didn’t power it on and now, there’s no freezing. I’m wondering why is it affecting the MD (MD receives MIDI from the MIDI OUT of the OT)? MIDI messages from the OT MIDI IN shouldn’t be going through the MIDI OUT of the MD?

1 Like

I’d be interested to know what MIDI data is causing the MD to freeze. If you’re running a mac and have a USB-MIDI interface, snoize: MIDI Monitor is a good tool for inspecting MIDI traffic.

3 Likes

I’m on Windows.

pocket MIDI Windows.

3 Likes

Found a nasty bug!

Renamed a snapshot and it got corrupted. Empty snapshot now! :scream:

(Thank god I backed it up…)

Update #1: Relatedly, copy/paste snapshot no longer works.

Update #2: A reboot fixed things and now the snapshot is back, with the new name, and I can copy/paste snapshots. (The paste from the previous session failed.)

3 Likes

Another bug encountered. All my GND-PW and GND-SW machines in my existing snapshots have gone silent. I created a new snapshot, and confirmed that initialized GND-SN, GND-PW and GND-SW machines no longer make sound.

Edit:
Resolved itself after downgrade and re-upgrade.

Looks like someone else saw this too. Not sure what triggered it for me yet.

1 Like

I browsed some older snapshots today and didn’t have this.

1 Like

What revision? Mine is UW+ MKII

MkII UW with the +drive retrofitted.

That shouldn’t make a difference … I think plus models simply had the upgrade pre-installed. It must be some global setting. But the issue happened even on a brand new snapshot.

I’ve downgraded to X.04 but I might try re-installing it later. Gotta get some work done.

Wait! I’ve just dedicated the last week to getting my head around X.04 and you release this???

How rude!

:smiling_face_with_three_hearts:

What next? You gonna wave this around so much that I’m gonna fail to see reason and try a MC build???

That’ll really make everyone at home happy…

:wink:

Thank you again!

2 Likes

I’m having a potential issue/bug with X.05A running on mkii non UW. My machine will no longer receive program change from octatrack or digitone. The MD receives tempo and start stop transport with no issues but not program change. I tried on both Octa and DN, confirmed PG channels match, tried multiple dif channels, even set up more new global configurations on the MD. Thanks in advance.

Fwiw, OT sending program change to X.05 works as expected here, on a mkII UW.

3 Likes

Thanks, I’m gonna try reinstalling it later

I reinstalled X.05A and still have this problem.

You have set the pc channel on both devices?

Yea, had them both at 16 per usual, tried a few different channels to be sure.

1 Like