Machinedrum SPS1-UW X.10 Released [ Unofficial ]

Machinedrum X.05A Hotfix :hot_pepper:

** Bug Fixes **

  • NFX machine group was not accessible on non UW Machinedrums
  • Fixed MIDI regression. Incoming CC messages were responding outside of base channel range.

Machinedrum_SPS1-UW_OS_X.05A.zip
mdx_4

25 Likes

Yatao and Justin I love you!!! Thank you!:heart:

3 Likes

Very spicy indeed.

1 Like

Thanks a lot!!! Love you all!!!:raised_hands::raised_hands::raised_hands::raised_hands::raised_hands::raised_hands::raised_hands::raised_hands::raised_hands::raised_hands:

1 Like

Documentation thread: Machinedrum SPS1-UW X.05: the living documentation

10 Likes

I love you guys, you’re the best

THANK YOU!

2 Likes

And… talk about awesome service:

Wow. Awesome work again @JustinValer and @v-yadli :slight_smile:

3 Likes

Hey, same boat. I just installed the free VMware and “demo” Windows10 onto my BigSur machine to see if I can run C6 on Windows and it seems to function. Haven’t sent anything yet, but do need to update my Machinedrum so I’ll report back.

Don’t know if it’s related to the X.05 but the UI is always freezing. I’m able to tweak the Parameters and hear them but nothing is moving on the screen.

Edit : I’m going to revert to X.04 and report back.

Hi @Tchu , no bugs, no freezes here on mk2 non-UW X.05A ,everything work as expected….
Hope you can fix your situation

7 Likes

Reverting to X.04 fixed the issue, no more freezing screen. I’ll re-install X.05 and see from there.

I don’t even have a machine drum but this is so insanely awesome.
How long did it take to reverse engineer!?

I found one little already.
Really basic
3 machines

Impulse, comb, and enveloppe nei, one aftee the other.

Trig menu : audio machine trig envelope machine machines,
while comb pitch are p locked on leach step (put a trig on each step and randomly turn pitch knob)
Set envelope settings.
Just change the triggers of the imp machine, or trig imp machine manually.
Add delay reverb, add a kick, and add a comp nei lol

This is amazing

Anyway I’m waiting your better tips impatiently.
Thanks !

1 Like

Re-installed X.05, same issue, the screen freezes in less than 5 minutes of use. Anyone else?

I’ll re-download the X.05 file and report back with the results.

Edit : After troubleshooting, it seems that the MD doesn’t like to be the receiver (slave) on X.05. It’s totally fine on X.04, though.

In resumé, when the MD is Standalone, everything’s fine but when the MD receives Transport, Clock and Program Change from the OT, the screen freezes after a few minutes.

Can anyone reproduce this issue?

1 Like

I can try in a couple of hours.

1 Like

Thank you.

So that worked for me. Just upgraded to Big Sur. I got VMWare Fusion for free as single user, I downloaded a copy of Windows 10 and installed c6. Uploaded X.05 to my MDUW MK2 no problem. Sent an 808 kick sample over and it transferred fine. Kinda sucks having to install a whole secondary OS just for c6, but I’m sure there are other Windows utilities I’ll end up throwing on here.

Are you on OSX, Windows or Linux?

I was on Mojave but upgraded because it was having issues with the MPC Live 2.10 plug-in. Big Sur resolved that (for the AU but not VST, but whatever, that’s way off topic…). Anyway, that lost my 32 bit support, but throwing a virtual Windows machine on there seemed to solve that.

I can’t replicate this.

Would really need a profile of the MIDI messages being sent from the OT to work out the cause.

Can you eliminate:
Transport, Clock and Program Change from the OT.

One by one until the freezing stops?

1 Like