Machinedrum SPS1-UW X.10 Released [ Unofficial ]

new MD SPS-MK1 owner here. what cord are you guys using to transfer from a laptop? my old m-audio usb to midi didn’t seem to do the trick, nor did going through my other interface. feels like im missing something, i’ve read the manual front to back.

Try connecting via a different hub if you can. Took several goes here with a normally reliable USB/MIDI cable, different hub and it worded immediately.

1 Like

Which USB interfaces are you using? Not all of them handle sysex (well).
What software are you using to transfer as well?


i used C6 software, tried using my behringer umc interface as well as the m-audio cable which is supposed to be an interface … i even tried rigging up my digitakt as a hub… obviously im missing something and i apologize if i seem dense about this… just used to loading from laptop to digitakt/digitone via transfer and that usb cable.
when i hit send on C6, nothing happens on the MD.

There was an E-MU branded USB-MIDI cable that handled Sysex and firmware updates well. It looks like every other no-name interface, but actually works.

It’s still available, a decade later:

Only problem is I have no idea where mine is right now. Fortunately, my TM-1 magically started working again with my mac :man_shrugging:


brilliant. i appreciate that - gonna order one and give it a go

1 Like

Try lowering the transfer speeds as well.

1 Like

Dont buy a new midi interface just for that, try setting a pause of 5-10 mS in C6 first.

Does the Disk+ is erased until X.05 firmware upgrade ? I suppose it is not. Hope only current patterns and samples could be erased but have to be sure.

Appreciate if somebody could confirm my suspicion.

No it’s not wiped by a firmware update.

1 Like

It’s doesn’t, but do a back up 1st of course.

May is ask, is there any sort of +Drive functionality planned for future updates with Megacmd?
Would be awesome fo the no +Drive but UW MKII Dudes and dudettes, like me :slight_smile:

Just bought a Machinedrum (with X.05) and I’m a bit of a baby when it comes to the setup. Will this remote work with X.05 or does anyone know of a similar m4l/vst plugin that can do the same thing on X.05, preferably with the new machines? Elektron Machinedrum Remote 1.57 Max for Live Ableton

Hi everyone, got a bit of an emergency on my hands and wondering if it has anything to do with the firmware update. i’m on x.04 and i’m unable to do program changes. i’m on the correct midi channels and everything, this has worked on 1.63 for me. sending to my dsi evolver. midi sync/info works except for program changes. i have a live set in 2 days and i’m relying on this feature. can anyone help or lmk if they’ve encountered this issue? thanks.

strike that, on x.05

A, B or C?


resolved with an upgrade to x.05c. thanks!

1 Like

Hey there - the update is amazing. I have a question: is it possible to have different track lengths? I don’t have a MegaCommand.

You need the MCL for that.


Just ordered mine.

I hope that this banishes the computer from my beats for good… (maybe even entire songs…?) Hate the limitations of the MD sequencer but I also hate dealing with computer crap when writing and performing.