Machinedrum SPS1-UW X.10 Released [ Unofficial ]

Haven’t encountered any bugs myself in X.04 or X.05. It’d seem the bugs have occurred in fairly specific circumstances (complex midi setups or whatnot - I’m mostly using the MD standalone so I wouldn’t know, ha) and the devs have also been able to fix (most of?) them.

Already said it multiple times but for me the X.04 update was nothing short of a revelation. Getting new, very useful gnd machines and having the ability to tune stuff to actual notes opened the MD to a sea of possibilities for me. Like several people have said, this update essentially turned a fantastic drum machine to a very capable groovebox.

Obviously there’s a lot more to these updates but these features alone were gamechangers for me.


On Mac, you can use the free app “Sysex Librarian” to send the update. (And do a backup of your MD!)


X.04 is not buggy, try that or wait for X.05 stable subversion.

1 Like

Yea I had one minor bug regarding pattern changes, but Justin fixed it within 24 hours! I’ve encountered no issues since.

1 Like

I am using X.05 and really like the new machines. I made a few cool patterns with NFX machines, however one of them is “poisonous”. It plays well all the time but when I switch to another pattern with NFX used some tracks are badly initialized. No filter and volume page parameters, even track volume setting is unworkable and track plays directly.
Only I could do is to load some old pattern without NFX which initialized normally and then switch to a new pattern. During experiments with the weird patterns I could make MD freeze, all LEDs light up, no sequencer, no button response.
I keep searching on what makes the strange act.

1 Like

Are you using the X.05 ( C ) version, mine was doing sort of the same thing, if you download it again, there is a hotfix, it doesnt say it’s the C version.

1 Like

In my experience, it’s been rock solid to use, and has added many new features which are both cool and useful. Try it out, you can always downgrade back to the stock firmware if you get nothing from it!

Machinedrummoter’s: cant Elektron create the mk3, but with all suggested stuff?

x.o5 c usage here:

Some sysex changes causes a weird problem with 3 & 4 become unusable.

The errant sysex command from my setup is F0 42 30 58 10 F7

I’m not sure if this would normally be filtered by the machinedrum as the message is intended for a different device. Just putting it here for reference and to say factory reset solves the issue, should someone else be passing a lot of sysex in their system and encounters this.

Guys, i got a problem with my Machinedrum on os X05. The machine freezes when is midi-slaved to octatrack, first minutes it plays and syncs normally, but from time to time it just freezes and stops responding to any controls, the sound gets glitchy or disappears. Reloading helps. Test mode didn’t show no problems. Someone wrote on forum this was an issue in older official firmwares and got fixed in updates. I didnt have this trouble when machinedrum was tempo master, it could play for hours non-stop. I’m worried about my unit :frowning: Btw. octatrack’s psu is not original, machinedrum is powered from the original psu. Since they draw the same voltage etc., maybe these are some electrical problems?

In Global, take a new Slot and disable everything in the Map Editor.

Do you have the latest OS, X.05c? I think this issue has been fixed in the C version.

1 Like

Yes, it’s 05c. Changed slot and disabled map, didn’t help

The Elektron machines are generally quite picky about power supplies, so make sure to rule that out first.

What you are describing is the problem I had with the ( B ) version, I had to cut the power and power on again, no glitches or anything like that, just complete freeze

Hi guys,

I’m trying to update my macheindrum mk2 to the latest software and having some difficulties.
When I use the sysex transfer mode in the Transfer app, the machindrum immediately displays a ‘update failed. please restart unit’ message as soon as the file starts streaming. I’ve also tried to play it via sysex librarian but here the machiendrum doesn’t seem to recognise the update and just stays on the ‘waiting for update’ message when I start transferring the sysex file. Does anyone have any experiences here on how to troubleshoot this?

Try Elektron C6 instead

Sorry I don’t speak English well, and I haven’t read the whole forum…
Is there anyone who builds the mega command and sells it?

I am having this problem too. Seems to be a bug in the new update :frowning:

yeah as @acidbob mentions below make sure you have (re)installed X.05C

It seems that a few people are confused by the X.05 versions, so as I understand there was an A, B, and C version (All beta). So basically the newest version is called X.05 C. The download link is updated for each hotfix, so if you download it again, it should be X.05 C, the newest version where the problem is resolved. So maybe download and try updating again. The MD doesn’t display whether it’s A, B or C.

1 Like

Just re-installed X.05C and everything seems to be working as they should be. I was on X.05C before and it was working fine but when midi triggered by my Octatrack it would freeze up the MachineDrum. A re-install of the software seemed to fix the issue and I am no longer having the MachineDrum freeze-lock me. If problems again arise out of more usage I will report here in this thread.

1 Like