Logic Pro X + Overbridge + Digi´s

The last track is the FX track, you’re right (the last of the 9 x mono tracks). I’m not sure why you’re not getting it through – you might need to go into the Overbridge control panel on your computer to enable it, I guess, but it’s only in mono anyway so it’s not that useful at all really! You need it in stereo, so you’ll have to mess with your voice routings on the DT.

Unfortunately, I just packed my DT up for a house move so my memory may be a little hazy, but IIRC to get the wet FX you need to go into the global settings (the cog button), and then go to voice routing. Switch off the routing to the main output for all of the tracks except the FX track. Then you can send the main output to another bus and record the FX by itself in stereo, while still getting all of the other tracks on their own channels. Hope that helps, if not I can try to give better instructions when I’m back set up at the new place

1 Like

Thank you! That seems to have done the trick.
Still nothing on 9 (see nowhere to enable it in the control panel), but the global settings and routing main output to another bus worked. That leaves me with 8 dry tracks and one with sound+fx (and a whole lot of routing going on…).

I’m sure Overbridge will provide a few more obstacles (it’s beta, after all), but as long as I can record separate tracks with fx and some automation I’m happy (I think).

Thanks again and good luck with the move :slight_smile:

2 Likes

At least on my A4mk1 the last track (in my case 5th, or 6th if you count main), is not the FX by itself but actually the (dry) external input. So it’s silent as long as there’s nothing connected, of course. Is that the same on the DN/T?

2 Likes

Oh, yes, you might be right about that last channel, it could be monitoring the ext in and not FX, which would explain why @Kontainer isn’t seeing anything on that channel . I’m just going by my hazy recall and can’t check as my DT is still in a box :slightly_frowning_face:

1 Like

Ah… Sounds like that could be it. I’ll check the next time I got it hooked up @senor-bling @spikysimon

This is my setup as well (posted by spikysimon). I configured it yesterday exactly like that and today I saw this thread :slight_smile:
And the AU-plugins finally fixed my sync problems I had previously when recording directly on audio tracks. Now it’s possible for me to record long and short loops on separate tracks and layer them together without bothering about sync issues.

Although some issues that still not resolved:

  • The actual recording is always delayed one bar (leaving the first bar with no sound at all)
  • Crashes and sync-problems occur occasionally, restarting logic gets it back in business.

That’s odd, it doesn’t do that for me. The only issue I have is that recordings from OB and from my sound card are slightly out of sync, but a little nudge fixes that. I wish I was more of an OB/Logic expert so I could suggest what might fix your issue.

Hi again,

Funny thing, a month ago when I asked about this and got the answer, I just checked that I got connection and signal, witch I did. I never really recorded anything…
And now that I have actually made something that I want to record, it doesn’t! hehe

I have signal, and the play + rec works as normal, but I am not actually getting any recorded sound. The line is moving, but no sound is being recorded.

Anyone know why? :slight_smile:

You need to play around with the metronome settings i believe, Ive resolved that issue a long time ago

1 Like

You need to create audio tracks to record the audio

3 Likes

Thnx! I will try that.

1 Like

Yeah I use the plugin. I don’t mind giving it a nudge, it’s fine.

Sorry if I´m turning this into a Logic help center, but I (hopefully) have one last question:

Probably just me that´s too noob at this, but dear god this was more work than I expected. So I opened a new project -> software instrument-> multi (1x stereo 5 x mono)

Then I sent each track to a different Bus. Panned each buss all the way. Then I opened audio tracks, set the input to one of the Busses.
Each time I set a bus an Aux channels was opened. So I have 3 channels per track now. channel 1 seems to be the master.

The menu on my digitone says:
Route to main: 7/7
Send to FX 6/6

My recordings seems to have effects on them, but I might be wrong.
I read that FX might be sent separately?

My question is, does this look correct?

If so I guess I should save as a template, and I can do this again if I just change the names of the tracks. I am tempted to just record separate tracks in the OB recorder and drag the files into Logic, but I feel determined to make this work now!

Again thanks for all the help!

Hard to tell exactly but that looks like it’s working to me. For the sends, you probably should set them to zero, rather than turning them up all the way as that adds gain

The individual tracks won’t have FX on them. If you’re hearing the FX it’s because the master out from the Digitone is playing through Logic’s main outs too (either because you recorded the master, or because Logic is monitoring your DN and your Digitone is playing) . Try soloing your recorded audio tracks – they should be dry.

If you want to record the FX separately, you’ll have to mess with the voice routing so only the FX tracks are getting sent to your main DN outputs, then you can record the FX track from the main outs.

2 Likes

I messed around with this a lot, but I’ve found that, if Overbridge is enabled in the Digitakt’s own settings, then I can just take separate inputs for each of the 10 tracks using the Core Audio. I don’t need to use the Overbridge plugin at all.

I do wonder what inputs 9 and 10 do though.

Hm so if got you right, to record 10 tracks from your Elektron Device, you need these 10 plugin tracks + 10 busses + 10 audio tracks taking audio from the busses ?
That’s 30 tracks and a huge CPU load.
Don’t you guys know any cleaner solution ? Even though it obviously works, I can’t believe it’s the only way to do it …

No, just one plugin track, with the outputs that you specify (plus the busses, and audio tracks to record the audio). the CPU load isn’t especially high IMO. there might be a cleaner way to do it that doesn’t require the use of busses, but the method I outlined works OK for me. If you want it simpler (no plugin, just the outputs direct to their own tracks), you can probably use the method that @Mistercharlie outlined to just grab the audio outputs

Yes, of course, that was the method I used before, but I want to take advantage of the AU plugin, it’s absolutely awesome.
But thanks for your answer, I’ll go for it and hope my old macbook will take it :smile:

1 Like