Logic Pro X + Overbridge + Digi´s

Are you arming the record on each of the audio tracks? You have to do that otherwise it won’t record anything. Also, if you just want to hear the incoming tracks through the audio tracks you can switch on input monitoring (https://support.apple.com/kb/ph12934?locale=en_US).

1 Like

I was… but I thought because I couldnt see the input signal (like with normal recording ) that it wasnt going thru. hit record and behold it does work!


Logic does that sort of thing. I believe if Auto Input Monitoring is enabled (I have it in my tool bar up top) having channels record/input enabled won’t pass through audio until recording is actually taking place. Disabling that option should, if I recall correctly, allow input monitoring of anything you’ve enabled it for. Also, ditto on the DT routing so that the FX are the only tracks going to the main output (no sampler tracks) then you’ll have stereo pair 1 be FX, 2-9 be Sampler tracks 1-8, and the 10th stereo pair is a passthrough of the inputs. I’m not sure if that gets summed to mono, but otherwise looks like this is all how I have it set up. I first create arrange tracks for every track in the mixer so I can organize them (also have a Digitone Keys and iPad via IDAM along with my Audient interface as an aggregate), make folders, name nicely, etc, then hide all the tracks except those that actually record the bused audio and any other inputs. Hide tracks is wonderful for excessive setups like what this requires just to record some tracks off one USB cable…then, of course…SAVE AS TEMPLATE.

Ends up somewhere like this:


Really appreciate the help y’all. So which tracks should control the input volume? I notice several do affect the gain. Now to figure how and what tracks to hide. Such a crazy setup required for this…

Also, anyone else have an issue getting their DT to actually connect at first? Takes a good bit of toggling interfaces and often switching it off and on for me. Anyone have this issue and figure a startup/connection procedure that works every time?

Hey @emptyvesselband – I’ve made a 10xMono template for the Rytm if you need an example. It’s got one track for the plugin, then two track stacks – one for a cue mix and one for recording in. If you leave them collapsed you can arm/solo/monitor from the top level.

Hey everyone, thank you for all your superb help on this thread so far. There’s one thing that I cannot for the life of me seem to fix - when recording audio tracks from my Digitakt into Logic, the timing of this audio is always ~30ms faster (too soon) vs the MIDI sync, but works perfectly in sync during regular playback. I’ve dug into Logic recording settings on a few occasions and cannot seem to find anything that might solve this :frowning: I tried setting up Digitakt as an aggregate device to see if it was a soundcard issue but that didn’t change anything. I’d greatly appreciate if anyone has some words of wisdom on this :pray:

Thank you guys,

Ya super easy…
Go to the midi sync tab, in project settings, you can adjust midi offset for each item +/-

If you’re using OB as part of an aggregate, make sure it’s clock follows the master.

1 Like

The plugin pop-up advice suggests that you shouldn’t send Logic’s sync to the Digitakt at all and that you should rely on the plugin alone for the sync. I had problems with a Rytm Mk II when I had the Rytm show up as one of the Destinations in Logic’s MIDI Sync, but when I removed it from there (and made sure All wasn’t selected either) sync worked as expected with 2.0.24


Ahhh fantastic thank you for highlighting this and responding so quickly… look forward to trying this tonight and seeing how I get on :grimacing:

I myself, don’t use the plugin. It causes issues on my machine. I just use OB for the outs. Perhaps the issues with plug are the plug + logic sync. Without the plug and logic as master, the DT still comes in around 30-40ms early, which I fix with offset. I’ll try one and the other and see if there is any improvement.

Interested in results. :+1:t6:

I’ve followed your advice and the recording is now 0 latency into Logic it seems!! Thank you very much.

I’ve also setup the full Bus routing -> Audio track method mentioned earlier in this thread which is really satisfying, I can now whip up a full beat on the Digitakt and record it all into Logic in separate audio tracks all at once. Really handy. Surely Elektron could release some kind of simple setup guide for this… Or perhaps they prefer to let users figure things out with their own unique setup. Regardless, the advice of community members like you is invaluable!

In terms of recording the FX from Digitakt into the individual audio tracks, I’m getting the impression that this simply isn’t possible, and can only be done when recording the full stereo output as mentioned above. I can’t see myself being able to make use of this which is a bit of a shame but the machine is working like a charm otherwise, so I am a very happy man. Beats inbound!!

1 Like

Hey man, I don’t suppose you’d know if there’s any way you can adjust the recording volume from Digitakt audio tracks -> Logic? Beyond the track volumes and master volume, which I have turned all the way up pretty much. Perhaps this is a non-issue but the recorded tracks are a lot quieter than when I play the beat through the OB plugin

There isn’t. Looking at old screenshots it looks like this used to be a feature of Overbridge Control Panel. No longer. I don’t find it an issue, mind (the signal’s plenty hot enough). Here are some suggestions (assuming a boost of +4dB for example’s sake):

  1. Juice the region’s gain post-recording in the region pane
  2. Add a Utility/Gain to the channel strip of the thing you want boosting
  3. I usually collect the OB tracks together in a summing stack, so if you have three tracks, let’s say BD Audio, SD Audio and CH audio, you’d select all three, hit CMD-SHIFT-D and add a summing stack (which is really just a bus). Then add the plugin of your choice to boost gain. I like a Dynamics/Multipressor on the Hi-Fi Drums preset, possibly with a +4dB boost to the main out, like so:
1 Like

Oop, sorry, didn’t reply to. Anyway ^^^ :slight_smile:

I know it’s been some time, but I’m experiencing this as well:

The actual recording is always delayed one bar (leaving the first bar with no sound at all)

Did you ever resolve this? Thanks!

it’s funny you’re talking about this - i was working with Maschine through Logic and wondering how to bounce the Maschine multi outputs into audio tracks to mix later. I did exactly the method you did, sending to buses and using new audio tracks with buses as inputs.

That strikes me as very roundabout - why can’t you bounce and choose which VI outputs to bounce and auto import into tracks? Maschine can bounce out each group to a different wave file in the same bounce, it’s invaluable.

Well, I did a work around. Just create a bar (or one and a half) before bar 1 (move the arrow that marks the starting point to gain access to “negative” bars). If anyone knows a better solution, feel free to let us know :slight_smile:

Thanks for getting back! I did what you did… treat the bar before like a preroll. I find it very out though. I don’t have any other hardware that does that.

What I did to fix it was when just hitting play in Logic set midi clock mode to

Pattern mode

And to record set it to

SPP at Play Start and Stop/SPP/Continue at Cycle Jump

That should start correctly

1 Like