Investigating OB and reaper with Digitakt : notes for new users

Hi elektronauts !

I have been investigating with digitakt and overbridge in reaper.

So far here are my conclusions :

  1. Overbridge is more stable and works much better using a dedicated audio interface (my tiny audient ID4 does the job). I guess it is related to USB Bandwidth or something. Setting usb only in digitakt also helps. Regarding the settings of the audio interface, 48kHz with a 256 or 512 buffer does the job.

  2. The main issue with overbridge in reaper is sync. On that matter I found out a few things :

  • The track with overbridge has to be armed. There is more latency if the track is not armed (Native instrument maschine has also the same behaviour in reaper)
  • Sync option of OB plugin does not work with reaper. As indicated in the OB manual, one solution is to set OB to “no sync” and to set reaper to send midi clock to digitakt, and set digitakt to receive clock and transport.
  • making DT a slave of reaper works but I didn’t succeed in doing the opposite in reaper that is making reaper a slave of the DT clock.
  • Finally, even using reaper clock, take care to add the option “No SPP/position” when configuring the clock in reaper. Otherwise, sync will have a very strange behavior. Alternatively, one can only set digitakt to receive transport and not clock : if reaper tempo and digitakt tempo are the same, it will stay in sync.

I hope it will help those that uses reaper and elektron devices.

If any of you has something to add regarding reaper and OB, I am all ears.

9 Likes

Hello reaper users,

For those who might read this threads, I have since discovered a bunch of new tricks:

  • if midi is sent to the overbridge plugin (on its track), it is still out of sync. To correct this issue, you can :
    1. go to the routing options of the overbridge plugin and disable midi
    2. go to the routing option of reaper track and add a adware send the midi port of the directly ()
  • set the record mode to record output and multitracking. It is convenient because the whole multi-audio record will occur on the same track without having to have a huge number of tracks
  • set the reaper region change with Program change (in the reaper action menu). This way, when digitakt midi in port is set to control message and digitakt is set to send Program changes, regions of reaper and patterns of the digitakt will be synced. For this you might need custom action to make it properly work but I can explain, if any of you is interested
3 Likes

Hey Dissofiddle, I read this. (Your formulation is a bit like the warning the alien ship sent to the Nostromo in Alien :wink:)

I have been trying to incorporate my Digitakt / Digitone into Reaper ever since I have them.
I find your advice to be very useful. At first I hoped the tricks in your first post would solve my sycing problems.
It works way better than with OB sync. At times it´s really very good.
But just yesterday I had a very frustrating session where I tried to compose and just have playback from the Digitakt.
It went slightly out of sync whenever I stopped the playback.
This is the main issue in my eyes.

As for your further tips:
I always have midi set to no input on the actual track that holds the DT OB plugin.
I am sending notes to the DT via a send from a track called OB pattern change which works quite nicely. (Is this what you mean by your Nr. 2. tip?)

I am using looped midi items in the length of the actual pattern which makes it easy to extend a part by just dragging it.
I want to use DT for all my drums while composing. This means a lot of stop and restart and sync is the main issue.
It is so sad. In that very session I have such a cool groove going (with locks, probabilities and all that stuff).

The hint with Reaper region change is what I try to accomplish with my looped midi items, right?

Do you really have stable sync?

Thank´s for putting up this thread.

1 Like

Hi @TheWhistler

Actullay I use this posts as a kind of a memo to myself :slight_smile:.

Yeah, sync is a bit tricky in reaper with OB. Actually I try to use it the least I can, when I need to record the pattern in reaper when I am sure it’s good. When composing, I only use usb midi and I use a passive mixer to sum my DT audio output and audio Interface output (with reaper sounds). Without overbridge, digitakt is very reactive flawlesslly.

But yes I do have a quite good sync with OB otherwise. If the sync is a bit loose, I adjust the clock offset (of reaper to digitakt). You should not forget to arm the tracks that contains the overbridge plugin (it changes everthing). Another important stuff is to avoid to send SPP.
Another fun stuff you can try is no clock, but only transport send/receive. If digitakt tempo and reaper are the same tempo, it works :smiley:

1 Like

Hi Dissofiddle,

Then this memo to yourself is useful for me too. Thank´s for at least compiling your investigations.
They match with my experience. The only thing I did get wrong was:

I really thought you had perfect sync in Reaper with midi clock instead of OB sync.
If I get your right, this is not the case.
I really, really want to compose and jump across my piece of music and want the Digitakt to stay in sync.
The thing is, at times it does. But it can loose sync randomly and this is so disgusting.

I have read through forums and websites up and down. I know a lot about jitter and unstable midi clock now. :joy: :rofl:

My next thing to do is to try if it get´s better with this additional piece of gear.

Usamo

It´s the USAMO from exptert sleepers.
I will want to produce just midi clock with this an see if it makes things better.
It works with audio priority (so much higher in timing accuracy).
I will report if it works. Might be of use for others too.

1 Like

Hi TheWhistlers,

Not sync is never perfect,
But that’s not what I meant.
I DID mean that I have good sync with Overbridge using midi clock.
What I am saying is, you should try to get good thing in midi mode first.
If it doesn’t not work ith midi mode, It won’t work with overbridge.
The other thing I said is I Wouldn’t use overbridge for a live performance,
but to have a multi-track record, it is good enough :slight_smile:

1 Like

And so, I have a few question for you :

  • have you tried the midi sync itself without overbridge ?
  • Do you send clock to digitakt without SPP/song position ?
  • when using overbridge, do you arm the track using overbridge ?
  • Do you use a small enough buffer size ?
  • have you set your computer/laptop to work at full power ? (including usb )
1 Like

Hi, for those who would see that thread (no many people I guess),
here is a method to sync digitakt pattern changes to reaper region changes.

What I mean by this is that triggering pattern 1 on DT will automatically playback region 1 in reaper, when triggering pattern 2, it will playback region 2 etc, a bit like an ableton sesssion. Also, you can change the seeking behaviour in reaper > preferences > audio > seeking to decide if the playback of the region has to be finished before it seeks to new region, or if reaper has to wait for a few bars . IMO, one bar is perfect for this, try it.

Here is how to do this :

  1. First let’s download and import the following scripts (it has to be imported in reaper action menu, browse on the web if you don’t know how to to this):

https://stash.reaper.fm/v/41328/gotoRegionObeySeek.zip

these scripts are made to go to region 1-40 with smooth seeking (the same way you would change sessions in ableton live )

2 Let’s bind each of these actions to digitakt pattern changes. First go to reaper preferences > midi devices and set digitakt to “enable for control message”

  • in digitakt midi menu, set “send program change (PC)” on .
  • then in reaper action menu, select each script, click on “add shortcut” and press on the digitakt the corresponding pattern change . For instance, for script “go to region 1 (obey seek)”, press add shortcut in reaper and press func + 1 on the digitakt.
    Now pattern 1 and region 1 are synced, meaning that when you will select pattern 1 on the digitakt, reaper will playback region 1 ;-).

enjoy

3 Likes

Hello dear me (no one is insterested by this thread, maybe one day someone will need to use reaper with OB).

Another interesting notes :
When arranging a son with OB, it is convenient to use midi items containing either midi notes on channel 16 (with obverbridge) or program change on auto-channel (with midi input) to change pattern on the digitakt along the reaper timeline.
Unfortunatly, due to latency, most of the time the pattern change (note or PC) arrives too late.
A good way to fix this, is to set the track containing the pattern changes midi clips to playback a bit earlier. In reaper you can do this easily by opening the routing menu of the track and tick “playback offset” and set a negative offset. -50 ms is sufficient for this.

This trick can also be used when live triggering reaper sections (which can act as ableton live scenes, see REAPER | Resources) to trigger a given digitakt pattern. To do this, let blank space beetween section, and fill the sections with a clip containing pattern change (note or pc ), and apply the delayed playback.

Cheers

3 Likes

Dear Dissofiddle (wich is a really funny name :wink:),
First I have to say sorry. I did not reply because I did not get a notification of the newer posts.
I am still interested in this thread.
I was into my account settings and did not find a way to get informed per mail when new post arise.
So, sorry once again for not answering.

I can answer all of your questions with a big YES.
All works kind of. But I when moving in an arrangement I lose sync in a way that sets the digitakt just an annoying 16th/32nd off.
It would be better not to play then.

For the Usamo (which could be interesting for anyone else reading this thread).
I did everything right as it was described in the manual.
I had proper clock and start/stop/continue messages.
The Digitakt refused to follow the Usamo.
Send it back because it ist not useful, sorry expert sleepers.

hi TheWhistler,

When I first tried to investigate the overbridge digitakt problem, I had an issue that sounds similar : the sync was working when playback at the begginning of the time line (at beat 1.1.1), but not later on the timeline. The issue was a strange behavior due to song position (when using clock SPP or OB sync) of the clock . Otherwise, I don’t have much of latency with the setting I gave in this post.
Note that I still have to use very short latency settings on my audio interface (with reaper or ableton, which is a recommanded daw), and to set the overbridge control pannel
I have another bunch of questions :
1 - Have you deactivated the midi in/out in the digitakt (use only usb ) ? It seems to change a lot concerning the bandwidth.
2 - What audio interface settings are you using ?
3 - what are setting are you using in the overbridge pannel ?
4 - gave you tried with another daw on the same computer ? like ableton lite which is often included when buying midi keyboard or else

To minimize latency, I have to set my audio-interface not greater than 256, and set about the same value for the latency in overbridge pannel.

1 Like

1 - No, I never new this could be a problem. A thing here could be that it may take away the
possibillity to put in notes via a connected keyboard. I am pretty sure that the sequencer does
not accept notes that are put in via usb (maybe wrong - will try).

2 - I use a Behringer XR18 as my studio mixer and also audio interface. My latencey (output) there
is about 6ms. I never run into problems when playing e.g. VSTis in real time

3 - you see me baffled. I didn´t even knew that there was something like this panel.
I do not use the Digitakt as audio interface, though.
Would you recommend to match the latency settings with the ones in my audio interface?
Note: I do not use Digitakt as an audio interface.

4 - Yes I have. Ableton does not have these problems at all right away. I did not know of the control
panel, Digitakt stayed in sync. I always thought Reaper is the on to blame.

You mentioned that strange behavior where the Digitakt was in sync, when you play a song from the start, but not when you jump in somewhere in the middle of a song.
This is what I am facing constantly. Digitakt is in sync when I start from the beginning.
As you might understand, this is not a good way for producing, tedious and time consuming.

Reaper is my DAW of choice. I am so used to it when it comes to composing/producing.
Ableton is more of performance/jamming tool at least for me.

Thank´s again for taking the time to answer and keep this thread alive.

Seems I could update my forum-settings. I was notified via mail that there have been replies. :smiley:

1 Like

1 - No, I never new this could be a problem. A thing here could be that it may take away the
possibillity to put in notes via a connected keyboard. I am pretty sure that the sequencer does
not accept notes that are put in via usb (maybe wrong - will try).

You are wrong (and that’s good news I guess :slight_smile:). Precisely, when using digitakt (or other ovebridge device, you have 2 choices to send midi via usb:

  • Either by sending midi to the track where overbridge is, which is not really good in my opinion. Notably midi can be sent to digitakt or played back from daw/reaper, but not recorded in digitakt with this method
  • Either by using the other way, which is better in my opinion and which is to directly use the out midi port : in reaper preferences > audio > midi device, first enable midi out (normally you did it already if you are sending clock to the digitakt), then create a reaper track, go to routing and add an hardware send, choose digitakt. This way, using reaper track will work as if you were using the midi din (but via usb).

2 - I use a Behringer XR18 as my studio mixer and also audio interface. My latencey (output) there
is about 6ms. I never run into problems when playing e.g. VSTis in real time

Me neither, I am using a basic audient ID4

3 - you see me baffled. I didn´t even knew that there was something like this panel.
I do not use the Digitakt as audio interface, though.
Would you recommend to match the latency settings with the ones in my audio interface?
Note: I do not use Digitakt as an audio interface.

Yes, you should give it a try. You should lower the plugin latency and set also the driver efficiency. Don’t worry, if it is too fast, you will be notified by the overbridge engine

4 - Yes I have. Ableton does not have these problems at all right away. I did not know of the control
panel, Digitakt stayed in sync. I always thought Reaper is the on to blame.

Reaper is definitly to blame (more precisely, my guess is it is difficult to make overbridge work with all daw, and they chose the most populars) But what solve the issue of “good sync at the beginning of the timeline” is these 3 things :

  • no sync on overbridge plugin (otherwise digitakt doesn’t use midi clock as sync)
  • Midi clock
  • No SPP ! this is very important IMO, the song position seems to give a bad time to the digitakt/overbridge thing

Doing this, it works fine for me, as long as the audio interface latency is quite low, otherwise, I have to manually nudge the whole record.

1 Like

@TheWhistler : Also and once again, have you tried to sync digitakt and reaper Without overbridge first ? I know you want to use overbridge BUT if the clock without overbridge doesn’t sync, It won"t work with overbridge either.

Very, very much thank´s. :smiley:
I am still trying to get all this information to work.
You see me corrected. My Digitakt get´s the note information via USB for the sequencer on autochannel.
It´s good to be wrong (good news :wink:).
I am still trying to find the right settings in Overbridge settings.
Lowering it under the audio interface range seems to make things better.
I have to investigate on this tomorrow when I habe a bit of spare time.
I will once again give your recommendation another try, to not sync via Overbridge.

I will report back.

@TheWhistler : You are welcome and also I am still trying to figure out the best way to use overbridge too.
Currently, I start jamming using digitakt and a few soft synths or external synths controlled via midi only (via usb or midi din, with no overbridge). when I am done jamming, I use overbridge to “print” the pattern and further arrange (I could even use the standalone application, it would’t change much for this use…).
Ideally I would have prefered being able to sequence the overbridge track with midi items only (triggering patterns via Program Change and midi notes ) as if it really was “real” vst.
But unfortunatly, I still feel overbridge is a bit “too” heavy to be used like this. It works but it is not as smooth as using a vst and tends to kill my creative mood (even in ableton live or else).

I am hopping that elektron might improve the overall integration in a near future.

Update :

I have no idea why, but I don’t have much problems with overbridge anymore in reaper including with sync. Here are my settings :

  • OB 2.0.60 and DT 1.30
  • DT is not used as main interface, my audient ID4 is used
  • I choose 128 samples as asio buffer, and the same values on the overbridge control pannel. As said in a lot of post, it works better with low buffer values.
  • Sampling rate of 48000 seems to be a bit better (natural sampling rate of DT)
  • the track where overbridge is put on has to always be armed. I disable record on that track.

Total recall seems to work quite well too.

Hey Dissofiddle,

Seems they have sorted the hickups with sync.

Sadly I ran into another problem, this time with audio routing.
I have a track-template that I start when playing with the digitakt.
In Reaper you can get 10 stereo (20 in mono) channels for the Digitakt with 19/20 handling the master.
This is the track that does not work as intended/before.
I routed my sample tracks to have one channel/fader each.
All the FX are sent to the master out ot the Digitakt. This worked quite well in the past.
I could pick up the bare FX on the master out just like it was an FX-return on a mixer.
This does not work anymore.
I have been through the rounting menue up and down, back and forth.
When I set “Int to Main” to position “auto” nothing happens.
When I set it to “off” nothing happens (as it obviously should).
When set to “on” I have double the loudness and phasing.
As mentioned in the manual, when overbridge is active “auto” is the way to go.
This just does not work. I think this is a bug. I don´t know on which side, Overbridge or Digitakt.
It is not so much a Reaper topic (I first thought I had my routing messed up, but i didn´t).
Interestingly it works as it should on my Digitone, so maybe the firmware 1.30 on the Digitakt is the one to blame.
Do you think I should open a ticket?

EDIT: Sorry for being dumb. It WAS a routing mistake and my own fault. :flushed: :laughing:
I thought the main channel is 19/20 in fact it 1/2. Now it works. :grinning:

As for the recommendation to let put the track that holds the VST for Digitakt in record mode.
This is true to drastically reduce latency when playing sounds on the Digitakt live.
One thing to keep in mind is: If you put a track in record mode - it does just that, it records, or is open for incoming data/audio.
As Reaper is so wonderfully adaptable (some may say quirky and convoluted) just set the track to input “none”.
So you have both. Low latency and no unwanted data or recording.
I learned that the hard way when searching for a strange pattern jump I thought I would never have progammed.
It was just notes that I unintendently record while playing a VSTi.
Because I have my Digitakt track unvisible on the TCP I wasn´t aware of the notes I actually recorded.
Maybe this helps someone.

EDIT: Once again, firing too fast.
I learned that Reaper (and I would myself consider rather advanced) has surprises for me.
I never knew there was a way to put a track to input monitoring only while having it in record armed mode.
Means, there are two options for accomplishing this goal. Record mode on for lower latency and NO actual recording happening.

Hello @TheWhistler,

About Routing : Happy to learn that routing works, it does work for me.
Another trick about this : you can change the routing on a global basis or on a per-pattern basis. This is very cool as it allows you to dynamically decide for every pattern what should go to the master and what should not. To do this, you have to go in the pattern export menu.

About track arming : Yes I actually always disable recording on the track that holds overbridge so that I have no latency but no recording either :slight_smile:

A last trick : I think you know that feeding midi notes on channel 16 to overbridge, allows to command pattern change to digitakt. It is almost perfect to arrange a song with midi notes BUT the pattern change often occurs too late compared to what you would expect : you would expect the pattern change to starting exactly at the beginning of the query note. An easy way to solve this is to open reaper routing menu of the track, and request “playback time offset” with a negative offset. From there the digitakt pattern change is going to be “visually” aligned with the midi notes :-).