How to connect the M:S to the Korg NTS-1 via Midi - help needed

Hi there,

first post here. Recently got a M:S and it’s my first step into sequencers and electronic music production in a whole. Yesterday I assembled my Korg NTS-1 and I would like to connect it to my M:S in order for the M:S to function as a sequencer for the NTS-1. I know this is possible, and tried some things I found on the internet in order to make it work. Without luck though.

Here’s the settings and connection diagram I currently have setup: I used both Elektron CA-3 5-pins DIN-TRS mini jack Midi-adapters (with a Hosa-MIDI-Cable-5-pin-DIN in between) to connect both devices.

M:S:

  • Midi cable in Midi Out/Thru
  • Out chan: 6 (T6 Out)
  • Midi Ports: Out to M+U
  • Track setup on T6: MOut box ticket

NTS-1:

  • Midi cable in Midi in
  • Chn. 5

Because I don’t own a mixer yet, I for now only have my headphones plugged into the headphone jack on the NTS-1.

What am I missing here? Thanks in advance for your help!

If you have a stereo Minijack cable you could try that as an alternative to your din midi adapters. If that still fails probably means the problem lies in the config.

1 Like

Thanks for the quick reply! I don’t think I have one of those cables laying around at the moment, unfortunately.

If MS is sending out on midi channel 6 and NTS is on midi channel 5, it won’t work. MS needs to send midi on same channel as NTS.

1 Like

Hi there, thanks for your reply. From what I read on the net that’s a common mistake, because on the NTS channel 0 = 1, 1 = 2, 2 = 3 etc. but I can give it a try anyway.

Welcome to the forum!

On the M:S, as well as the settings you listed, you need to make the following setting in the M:S’s CONFIG > MIDI > PORTS menu:

  • set OUT TO to “MID” (or “M+U”)
  • set OUT/THRU to “OUT”

and ensure that Track 6 is not muted.

On the NTS-1, you need to ensure that the following GLOBAL parameters are set:

  • “SHr” (MIDI RX short message) should be “1” (On)
  • “Mrt” (MIDI route) should be “0” (USB+MIDI)
  • “CHn” (MIDI channel) should be “5” (MIDI channel 6)

Try these settings and report back to us.

Although your cabling should be correct, there is a very small chance that your MIDI adaptors are not what they seem and are messing up the polarity of the connection between the two devices. You can test this by changing the OUT POL setting in the M:S’s CONFIG > MIDI > PORTS menu between “STD” and “INV”; “STD” should be correct but it would be worth trying “INV” to see whether it makes a difference.

4 Likes

You’re correct, I forgot about funky numbering.

This bit, about the samples and cycles, should be in an FAQ somewhere. I always manage to forget one of those settings and spend ages hunting for it. Thank you @PeterHanes

Thank you so much Peter. All of the settings you mentioned were already in place. Your last recommendation did it though: I changed Out Pol to “STD” and now it works like a charm.

1 Like