DT bug reports - OS 1.02

You encountered something wrong in OS 1.02 and want to check if other can replicate it ?
Here is the place.

Doesn’t replace a support ticket, of course, but you might want to check if it’s not a feature before declaring a bug :wink:

Please report all bugs via the Support Tickets section on elektron.se


2 freezes so far.
both different , no repro steps unfortunately.
1 - pressing page - continued to play but no response…
2 - pressing play (it played audio but no buttons/encoders responded to anything) . fine after off/on

i’m using patterns / sounds / samples from 1.01
in general its crashed more than my experience with 1.01 , but i’m using it more thoroughly.

Still freezing while externally synced via USB to Live. Stops responding to live transport control, and is stuck in play mode and will not respond. Seems to happen when using midi tracks.

Tends to freeze on reboot.

1 Like

The effects still don’t reset to saved state when reloading pattern. The value display does, the effects themselves don’t.


Upgraded to 1.02. Hooked up MIDI via USB to Live. Was sequencing 4 synth vsts. Worked fine for a while. Then a freeze every time I’ve tried. It may (or may not) have something to do with MIDI clock because it freezes (every time) shortly after I turn the clock on in Live by pressing the “Play” button Live. Not exactly a scientific experiment on my part but something to look into.

Edit: It’s got to be the MIDI clock. Tried it a few more times and no freezes when I don’t have “play” pressed on Live when sending MIDI from the DT to Live. When I press “play” on Live, the DT freezes in a few seconds.

Mine also freezes when connected to my computer via USB, even tho it’s not sync’d to anything. -Just having it connected causes it to freeze.

1 Like

Seems like the 1.02 broke the Transfer app. :-/ Can’t connect anymore, I’m on OSX 10.12.3.

EDIT: After like 5 tries, restarting Digitakt, restarting Transfer, I managed to connect.

1 Like

Happens here too. I was actually thinking that something was pretty weird with FXs when reloading a pattern, now I know what it is.

The positive side is that Elektron’s aware of this and well, I expect they’ll fix it :slight_smile:


Upgraded to 1.02. Still no factory samples…

1 Like

Recorded sample and assigned to track 1. Playing back played it back as expected and was tuned to 0.00. Copied and pasted to track 2 and it was tuned to 0.00 but played 2 octaves lower. Pitching up to 24.00 made it sound “correct.” I would expect the sample data (and maybe tune, loop, etc. params of the sample to also copy over - at least the tuning.

This can also be reproduced by just initializing a pattern and copying track 1 sound to track 2. Note it is 2 octaves down after being pasted.

This bug was also in 1.01 as far as I could tell although I didn’t track it down in detail.

So strangely, maybe it’s only track 2 that has this problem…and track 5 seems to be one octave down, requiring tuning it up to 12.00.

FOUND IT: Aha! So on track 2 the TRIG NOTE is set to C1. track 5 has it set to C2. The other tracks default to C3 it would seem. So maybe this is just an issue of all of the params not being defaulted when resetting a pattern.


You’re not missing much, they’re pretty lame sounds. Having much more fun since I loaded new stuff.

1 Like

a factory reset should bring them back.

Are you sure you are looking at the +Drive? and not just on the Ram for the project?

Lol that may be but I’d still like to have them. I usually mess with factory stuff for a while before I start bringing in my own samples. Haven’t used a sampler since my ESX-1

With mine the factory samples are available through the SRC ASSIGN menu, and via the sample menu, but nothing is shown in the +Drive / Sound Browser view. No idea at all if this is normal, does this mean that while the factory samples are present, we don’t have the sound files for them?
Resets/reformat didn’t make them appear.

Didn’t get a single crash using midi USB clock from cubase for 2 hours here. That’s an improvement!

1 Like

Not sure its even a bug or this behaviour was present in previous versions as 1.02. Chances are its a normal implementations BUT theres a noticeable lower of volume once you engage Bit Reducer from 0 to 1of127. It would be nice if the BR would not change what so ever the volume of the track. Its not a biggie but still.


TUNE parameter:
OS 1.02: pressing the encoder down and turning is changing the TUNE in 4 semitones stepps instead on 1 ( should be one semitone, right ? i hope so at least )

OS 1.01 was 2 semitones

not filled a ticket

DT froze up tonight.
The pattern kept playing but DT was not responding and 1-16 pad lights quit flashing with the sequence.

I was tweaking the filter parameters when it happened.

I turned it off then back on to get it to work again.

yeah i’ve also run into this 2x now. sometimes it plays for 1-2 hours with no issue. this was on a new project with only a couple recorded samples playing. both times, after 20-30mins, the entire machine froze but was still producing the right pattern audio.

not a big deal IMO but I figured its still worth mentioning

i’m running elektron transfer 1.0.0 and i get high CPU usage if I leave it running for a while.

a naive guess would be it’s still checking for midi devices even when the window is inactive